aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-08-24 11:03:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-08-24 11:03:02 +0000
commita49bc4538d99525c5e49329beaf9987bcc14feec (patch)
tree0748f1386585fac0a325cfeccfeb6007800befe1
parentfacfa9bd603d77241c4b76b6e7afc9edb900e0ab (diff)
downloadports-a49bc4538d99525c5e49329beaf9987bcc14feec.tar.gz
ports-a49bc4538d99525c5e49329beaf9987bcc14feec.zip
x11-fm/polo: respect CFLAGS to unbreak the build on recent -CURRENT
Commit c57cd4390a27 had pacified one particular warning which often breaks Vala code compilation with Clang 16, thus correct fix is not to force an older compiler, but to pass down our CFLAGS to valac(1) together with -v option to make the actual compiler call visible in the build logs. Fixes: 09e56dc8e568
-rw-r--r--x11-fm/polo/Makefile10
-rw-r--r--x11-fm/polo/files/patch-makefile21
2 files changed, 20 insertions, 11 deletions
diff --git a/x11-fm/polo/Makefile b/x11-fm/polo/Makefile
index 024dca397f4a..b9ed97874a78 100644
--- a/x11-fm/polo/Makefile
+++ b/x11-fm/polo/Makefile
@@ -21,18 +21,8 @@ GH_ACCOUNT= teejee2008
USE_GNOME= cairo gdkpixbuf2 gtk30 libxml2 vte3
MAKEFILE= makefile
-
WRKSRC_SUBDIR= src
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
-USES+= llvm:max=15
-CC= clang${LLVM_VERSION}
-CPP= clang-cpp${LLVM_VERSION}
-CXX= clang++${LLVM_VERSION}
-.endif
-
post-patch:
@${RM} ${WRKSRC}/share/polo/files/gtk-theme/*.orig
@${RM} ${WRKSRC}/share/polo/files/install-*.sh
diff --git a/x11-fm/polo/files/patch-makefile b/x11-fm/polo/files/patch-makefile
index 041a1842d28f..607de7693c6b 100644
--- a/x11-fm/polo/files/patch-makefile
+++ b/x11-fm/polo/files/patch-makefile
@@ -2,14 +2,33 @@
+++ makefile
@@ -1,7 +1,7 @@
-SHELL=/bin/bash
+-CFLAGS=--std=c99
+SHELL=/bin/sh
- CFLAGS=--std=c99
++XCCFLAGS=$(foreach arg,$(CFLAGS),--Xcc=$(arg))
-prefix=/usr
+prefix=$(PREFIX)
bindir=$(prefix)/bin
sharedir=$(prefix)/share
localedir=$(sharedir)/locale
+@@ -43,7 +43,7 @@ app-gtk:
+
+ #polo-gtk
+ valac -X -D'GETTEXT_PACKAGE="${app_name}"' \
+- --Xcc="-lm" ${define_symbols} --Xcc="-O3" --thread \
++ --Xcc="-lm" ${define_symbols} ${XCCFLAGS} -v --thread \
+ Common/Main.vala \
+ Gtk/*.vala \
+ Utility/*.vala \
+@@ -60,7 +60,7 @@ app-util-gtk3:
+
+ app-util-disk:
+ valac --Xcc="-lm" -X -D'GETTEXT_PACKAGE="${app_name}"' \
+- "polo-disk.vala" Console/*.vala --Xcc="-O3" -o polo-disk --pkg posix --pkg gio-unix-2.0 --pkg gee-0.8
++ "polo-disk.vala" Console/*.vala ${XCCFLAGS} -v -o polo-disk --pkg posix --pkg gio-unix-2.0 --pkg gee-0.8
+
+ app-translations:
+
@@ -101,17 +101,15 @@ install:
mkdir -p "$(DESTDIR)$(sharedir)/${app_name}"
mkdir -p "$(DESTDIR)$(sharedir)/pixmaps"