aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-16 05:53:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-16 05:53:50 +0000
commita4a1a3253b056679e956111db215fd766eb12216 (patch)
tree82c3a158e6f65259783f06e68592fe005dbfd7b7
parent9220856235923751ba3654179663250c369e870f (diff)
downloadports-a4a1a3253b056679e956111db215fd766eb12216.tar.gz
ports-a4a1a3253b056679e956111db215fd766eb12216.zip
add ipdf
Creates indexed pdf documents from text files
Notes
Notes: svn path=/head/; revision=50113
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/ipdf/Makefile26
-rw-r--r--textproc/ipdf/distinfo1
-rw-r--r--textproc/ipdf/files/patch-document.h10
-rw-r--r--textproc/ipdf/pkg-comment1
-rw-r--r--textproc/ipdf/pkg-descr9
-rw-r--r--textproc/ipdf/pkg-plist1
7 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c5b1b0d6af25..16ebf6ed94df 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -69,6 +69,7 @@
SUBDIR += info2html
SUBDIR += info_to_html
SUBDIR += intltool
+ SUBDIR += ipdf
SUBDIR += isearch
SUBDIR += iso12083
SUBDIR += iso8879
diff --git a/textproc/ipdf/Makefile b/textproc/ipdf/Makefile
new file mode 100644
index 000000000000..45f33d3fe600
--- /dev/null
+++ b/textproc/ipdf/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: ipdf
+# Date created: Nov 16, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipdf
+PORTVERSION= 0.9.7
+CATEGORIES= textproc
+MASTER_SITES= http://hoopajoo.net/static/projects/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= pdf:${PORTSDIR}/print/pdflib3 \
+ png:${PORTSDIR}/graphics/png \
+ tiff:${PORTSDIR}/graphics/tiff
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= ipdf.1
+
+.include <bsd.port.mk>
diff --git a/textproc/ipdf/distinfo b/textproc/ipdf/distinfo
new file mode 100644
index 000000000000..17fea816abc0
--- /dev/null
+++ b/textproc/ipdf/distinfo
@@ -0,0 +1 @@
+MD5 (ipdf-0.9.7.tar.gz) = 245c94a55ad56e42c0b4e34c4e759219
diff --git a/textproc/ipdf/files/patch-document.h b/textproc/ipdf/files/patch-document.h
new file mode 100644
index 000000000000..1d232466551c
--- /dev/null
+++ b/textproc/ipdf/files/patch-document.h
@@ -0,0 +1,10 @@
+--- document.h.orig Fri Nov 16 13:49:25 2001
++++ document.h Fri Nov 16 13:49:33 2001
+@@ -4,6 +4,7 @@
+ #include <error.h>
+ #endif
+
++#include <sys/types.h>
+ #include <regex.h>
+
+ #define __DOCUMENT_H__
diff --git a/textproc/ipdf/pkg-comment b/textproc/ipdf/pkg-comment
new file mode 100644
index 000000000000..07890d18c346
--- /dev/null
+++ b/textproc/ipdf/pkg-comment
@@ -0,0 +1 @@
+Creates indexed pdf documents from text files
diff --git a/textproc/ipdf/pkg-descr b/textproc/ipdf/pkg-descr
new file mode 100644
index 000000000000..28603a048801
--- /dev/null
+++ b/textproc/ipdf/pkg-descr
@@ -0,0 +1,9 @@
+Creates indexed pdf documents from text files. Designed to aid creating an
+electronic distribution method for legacy system reports, since many
+mainframe type print spools are plain text. Allows indexing, customizing
+page settings, font size, font face, and super-imposing text over an image
+in the case of using pre-printed forms. Supports unlimited levels of indexing
+bookmarks in documents and system/user configuration files. Suitable for
+use in an intranet gateway for generating PDF documents in real-time.
+
+WWW: http://hoopajoo.net/project_info.html?projectid=18
diff --git a/textproc/ipdf/pkg-plist b/textproc/ipdf/pkg-plist
new file mode 100644
index 000000000000..bf1ba1b39074
--- /dev/null
+++ b/textproc/ipdf/pkg-plist
@@ -0,0 +1 @@
+bin/ipdf