aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2021-10-13 00:21:23 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2021-10-13 15:14:24 +0000
commita4ab68d2ffd11a583df69b52a94f4b82fa161688 (patch)
tree29d313ecd0338bf588867a0c3737585df29eb0c5
parent5e05ddcf5f096c2e9c970c12344a6dcaff47978a (diff)
downloadports-a4ab68d2ffd11a583df69b52a94f4b82fa161688.tar.gz
ports-a4ab68d2ffd11a583df69b52a94f4b82fa161688.zip
audio/alsa-plugins: Switch master site to GitHub.
The original distfiles are getting hard to come by for some reason, so switch to pulling source tarballs directly from GitHub. Replace patches that apply to generated files with patches that apply to their sources.
-rw-r--r--audio/alsa-plugins/Makefile12
-rw-r--r--audio/alsa-plugins/distinfo6
-rw-r--r--audio/alsa-plugins/files/patch-configure33
-rw-r--r--audio/alsa-plugins/files/patch-configure.ac17
4 files changed, 28 insertions, 40 deletions
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index e5da9bc7658e..e905c1f66eee 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -2,10 +2,14 @@
PORTNAME= alsa-plugins
PORTVERSION= 1.2.2
-PORTREVISION= 2
+PORTREVISION= 3
+DISTVERSIONPREFIX= v
CATEGORIES= audio
-MASTER_SITES= ftp://ftp.alsa-project.org/pub/plugins/ \
- GENTOO
+MASTER_SITES= GH
+
+USE_GITHUB= yes
+GH_ACCOUNT= alsa-project
+GH_PROJECT= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= ALSA compatibility library plugins
@@ -14,7 +18,7 @@ LICENSE= LGPL21+
LIB_DEPENDS= libasound.so:audio/alsa-lib
-USES= alias libtool:keepla localbase pkgconfig tar:bzip2
+USES= alias autoreconf libtool:keepla localbase pkgconfig tar:bzip2
GNU_CONFIGURE= yes
MAKE_ARGS+= RM="${RM}"
EXTRA_PATCHES+= ${FILESDIR}/alsa-plugins.patch
diff --git a/audio/alsa-plugins/distinfo b/audio/alsa-plugins/distinfo
index ca008eccbaaf..09cefefdb80f 100644
--- a/audio/alsa-plugins/distinfo
+++ b/audio/alsa-plugins/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1585923260
-SHA256 (alsa-plugins-1.2.2.tar.bz2) = 1c0f06450c928d711719686c9dbece2d480184f36fab11b8f0534cb7b41e337d
-SIZE (alsa-plugins-1.2.2.tar.bz2) = 406494
+TIMESTAMP = 1634083456
+SHA256 (alsa-project-alsa-plugins-v1.2.2_GH0.tar.gz) = 1872622227c474db9db57bf5b6ec91bbef391f9750e9d64d00d05af29f579e1a
+SIZE (alsa-project-alsa-plugins-v1.2.2_GH0.tar.gz) = 121998
diff --git a/audio/alsa-plugins/files/patch-configure b/audio/alsa-plugins/files/patch-configure
deleted file mode 100644
index 619bbad8c4b4..000000000000
--- a/audio/alsa-plugins/files/patch-configure
+++ /dev/null
@@ -1,33 +0,0 @@
---- configure.orig 2016-03-31 13:14:07 UTC
-+++ configure
-@@ -12402,21 +12402,22 @@ else
- $as_echo "yes" >&6; }
- HAVE_SPEEXDSP="yes"
- fi
-- if test "$HAVE_SPEEXDSP" = "yes"; then
-- HAVE_SPEEXDSP_TRUE=
-- HAVE_SPEEXDSP_FALSE='#'
--else
-- HAVE_SPEEXDSP_TRUE='#'
-- HAVE_SPEEXDSP_FALSE=
--fi
-
-
--
- # Check whether --with-speex was given.
- if test "${with_speex+set}" = set; then :
- withval=$with_speex; PPH=$withval
- else
- PPH="lib"
-+fi
-+
-+
-+ if test "$HAVE_SPEEXDSP" = "yes" -a "$PPH" != "no"; then
-+ HAVE_SPEEXDSP_TRUE=
-+ HAVE_SPEEXDSP_FALSE='#'
-+else
-+ HAVE_SPEEXDSP_TRUE='#'
-+ HAVE_SPEEXDSP_FALSE=
- fi
-
-
diff --git a/audio/alsa-plugins/files/patch-configure.ac b/audio/alsa-plugins/files/patch-configure.ac
new file mode 100644
index 000000000000..839cb3a23441
--- /dev/null
+++ b/audio/alsa-plugins/files/patch-configure.ac
@@ -0,0 +1,17 @@
+--- configure.ac.orig 2020-02-19 09:35:42 UTC
++++ configure.ac
+@@ -145,12 +145,13 @@ AC_ARG_ENABLE([speexdsp],
+ if test "x$enable_speexdsp" != "xno"; then
+ PKG_CHECK_MODULES(speexdsp, [speexdsp >= 1.2rc2], [HAVE_SPEEXDSP="yes"], [HAVE_SPEEXDSP=""])
+ fi
+-AM_CONDITIONAL(HAVE_SPEEXDSP, test "$HAVE_SPEEXDSP" = "yes")
+
+ AC_ARG_WITH([speex],
+ AS_HELP_STRING([--with-speex={builtin|lib|no}],
+ [build speex resampler (built-in code, link with external lib, or no build)]),
+ [PPH=$withval], [PPH="lib"])
++
++AM_CONDITIONAL(HAVE_SPEEXDSP, test "$HAVE_SPEEXDSP" = "yes")
+
+ USE_LIBSPEEX=""
+ if test "$PPH" = "lib"; then