aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-14 21:03:43 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-14 21:19:39 +0000
commita4c89641bb058f8aae3b4d5389881f8330e89628 (patch)
treeec3ea27987a9eec19d9a977b12441924e004fffa
parent3d03b28d52b3393c2b0282b05a6cd7f23ea2002c (diff)
downloadports-a4c89641bb058f8aae3b4d5389881f8330e89628.tar.gz
ports-a4c89641bb058f8aae3b4d5389881f8330e89628.zip
science/cantera: Fix build on FreeBSD 12
c++ -o build/src/base/global.os -c -isystem include/cantera/ext -isystem /usr/local/include -isystem /usr/local/include/eigen3 -std=c++17 -O2 -pipe -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -pthread -O3 -Wall -include-pch src/pch/system.h.gch -fPIC -DNDEBUG -DGIT_COMMIT=\"unknown\" -Iinclude -Ibuild/src src/base/global.cpp In file included from src/base/global.cpp:11: In file included from /usr/local/include/boost/stacktrace.hpp:15: In file included from /usr/local/include/boost/stacktrace/frame.hpp:38: In file included from /usr/local/include/boost/stacktrace/safe_dump_to.hpp:217: /usr/local/include/boost/stacktrace/detail/collect_unwind.ipp:101:7: error: no member named '_Unwind_Backtrace' in the global namespace ::_Unwind_Backtrace(&boost::stacktrace::detail::unwind_callback, &state); ~~^ 1 error generated.
-rw-r--r--science/cantera/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/science/cantera/Makefile b/science/cantera/Makefile
index 7fea4f5d81c0..437f335b6372 100644
--- a/science/cantera/Makefile
+++ b/science/cantera/Makefile
@@ -26,6 +26,8 @@ USE_GITHUB= yes
GH_ACCOUNT= Cantera
GH_TUPLE= LLNL:sundials:887af43:sundials/ext/sundials # bundled sundials is only needed for the Octave option
+CXXFLAGS+= ${CXXFLAGS_${OPSYS}_${OSREL:R}}
+CXXFLAGS_FreeBSD_12= -D_GNU_SOURCE
MAKE_ARGS= system_eigen='y' \
system_sundials='n' \
system_fmt='y' \