aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-08-26 07:36:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-08-26 07:39:03 +0000
commita60b5f495b51aaaf674ac9fbcd1ee83434544979 (patch)
tree72020b47d3f5d07d014926efe5f54ebdb63f4a63
parent9163562540248cda0e79f6e2e53c39a80d8d89e0 (diff)
downloadports-a60b5f495b51aaaf674ac9fbcd1ee83434544979.tar.gz
ports-a60b5f495b51aaaf674ac9fbcd1ee83434544979.zip
compiler: use CHOSEN_COMPILER_TYPE instead of COMPILER_TYPE
CHOSEN_COMPILER_TYPE is the only safe variable to let a port know which typer of compiler has been elected to be used by the framework PR: 199098
-rw-r--r--audio/funktrackergold/Makefile2
-rw-r--r--devel/freebsd-gcc12/Makefile2
-rw-r--r--devel/freebsd-gcc6/Makefile4
-rw-r--r--devel/freebsd-gcc9/Makefile2
-rw-r--r--devel/fuzzylite/Makefile2
-rw-r--r--devel/google-perftools/Makefile2
-rw-r--r--devel/llvm-cheri/Makefile2
-rw-r--r--security/botan2/Makefile2
-rw-r--r--x11-toolkits/wxgtk28/Makefile2
9 files changed, 10 insertions, 10 deletions
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index 8c9d39bd5594..a2ae51dabb95 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE:Mgcc}
+.if ${CHOSEN_COMPILER_TYPE:Mgcc}
CFLAGS+= -fnested-functions
.endif
diff --git a/devel/freebsd-gcc12/Makefile b/devel/freebsd-gcc12/Makefile
index 0157738b60a1..222138952b50 100644
--- a/devel/freebsd-gcc12/Makefile
+++ b/devel/freebsd-gcc12/Makefile
@@ -87,7 +87,7 @@ CONFIGURE_TARGET= ${ARCH}-unknown-${OPSYS:tl}${OSREL}
.endif
.if ${TARGETARCH:Marm*} || ${TARGETARCH} == "aarch64"
-. if ${COMPILER_TYPE} == clang
+. if ${CHOSEN_COMPILER_TYPE} == clang
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512
. endif
.endif
diff --git a/devel/freebsd-gcc6/Makefile b/devel/freebsd-gcc6/Makefile
index 6ba04426c00d..e60672b2ef1b 100644
--- a/devel/freebsd-gcc6/Makefile
+++ b/devel/freebsd-gcc6/Makefile
@@ -1,4 +1,4 @@
-PORTNAME= gcc
+
PORTVERSION= 6.5.0
PORTREVISION= 3
CATEGORIES= devel
@@ -74,7 +74,7 @@ CONFIGURE_TARGET= ${ARCH}-unknown-${OPSYS:tl}${OSREL}
.endif
.if ${TARGETARCH} == "armv6" || ${TARGETARCH} == "aarch64"
-. if ${COMPILER_TYPE} == clang
+. if ${CHOSEN_COMPILER_TYPE} == clang
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512
. endif
.endif
diff --git a/devel/freebsd-gcc9/Makefile b/devel/freebsd-gcc9/Makefile
index ed873a1de38b..1b6b07b3cfa9 100644
--- a/devel/freebsd-gcc9/Makefile
+++ b/devel/freebsd-gcc9/Makefile
@@ -87,7 +87,7 @@ CONFIGURE_TARGET= ${ARCH}-unknown-${OPSYS:tl}${OSREL}
.endif
.if ${TARGETARCH:Marm*} || ${TARGETARCH} == "aarch64"
-. if ${COMPILER_TYPE} == clang
+. if ${CHOSEN_COMPILER_TYPE} == clang
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512
. endif
.endif
diff --git a/devel/fuzzylite/Makefile b/devel/fuzzylite/Makefile
index 3ed0ef671cbc..4fc3ca828816 100644
--- a/devel/fuzzylite/Makefile
+++ b/devel/fuzzylite/Makefile
@@ -20,7 +20,7 @@ PLIST_SUB= SHLIB_VER=${DISTVERSION}
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
CFLAGS+= -Wno-error=varargs
.endif
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index ac25a1c3b919..46589074d60f 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -61,7 +61,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == "clang" && !defined(USE_GCC)
+.if ${CHOSEN_COMPILER_TYPE} == "clang" && !defined(USE_GCC)
# clang cannot disable builtins individually
CXXFLAGS+= -fno-builtin
.endif
diff --git a/devel/llvm-cheri/Makefile b/devel/llvm-cheri/Makefile
index c731a081a9ac..1e67d97fd4e5 100644
--- a/devel/llvm-cheri/Makefile
+++ b/devel/llvm-cheri/Makefile
@@ -196,7 +196,7 @@ post-install-LLD-on:
${LN} -s ld.lld ${STAGEDIR}${LLVM_PREFIX}/bin/ld
post-install-LLDB-on:
-.if ${OPSYS} != "FreeBSD" || ${COMPILER_TYPE} == clang
+.if ${OPSYS} != "FreeBSD" || ${CHOSEN_COMPILER_TYPE} == clang
${RM} ${STAGEDIR}${LLVM_PREFIX}/lib/python*/site-packages/lib
.endif
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index a85ace4811ba..17de941e4d76 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -24,7 +24,7 @@ SHEBANG_FILES= configure.py src/python/botan2.py src/scripts/install.py
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
-CONFIGURE_ARGS= --cc=${COMPILER_TYPE} \
+CONFIGURE_ARGS= --cc=${CHOSEN_COMPILER_TYPE} \
--prefix=${PREFIX:Q} \
--with-boost \
--with-bzip2 \
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index a346e120df66..9f1680e3a467 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -83,7 +83,7 @@ CONFIGURE_ARGS+=--enable-unicode
.include <bsd.port.pre.mk>
# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
CONFIGURE_ARGS+= --disable-precomp-headers
.endif