aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 12:44:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 13:02:18 +0000
commita61ad3cee50716cae16169f9d1ecac143e8d0dfd (patch)
treeb8bdb942f52bb8ea0ae8f8fd029d92db70d248dc
parent4fa5d0e9e712804f7d27e0283014ceb39a6e2156 (diff)
downloadports-a61ad3cee50716cae16169f9d1ecac143e8d0dfd.tar.gz
ports-a61ad3cee50716cae16169f9d1ecac143e8d0dfd.zip
textproc/py-sphinx: Fix a7a3ac5596fdb27fb974c7993002b63994fe001e
- Update version requirement of RUN_DEPENDS - Fix TEST_DEPENDS - Convert to USE_PYTHON=pytest
-rw-r--r--textproc/py-sphinx/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/textproc/py-sphinx/Makefile b/textproc/py-sphinx/Makefile
index c5344cd45e26..0680740bb268 100644
--- a/textproc/py-sphinx/Makefile
+++ b/textproc/py-sphinx/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-applehelp>=0:textproc/py-sphin
${PYTHON_PKGNAMEPREFIX}sphinxcontrib-qthelp>=0:textproc/py-sphinxcontrib-qthelp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Jinja2>=2.3:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pygments>=2.0:textproc/py-pygments@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}docutils>=0.18.1<0.20,1:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.14,1<0.20,1:textproc/py-docutils@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}snowballstemmer>=1.1:textproc/py-snowballstemmer@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Babel>=1.3:devel/py-babel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}alabaster>=0.7<0.8:textproc/py-alabaster@${PY_FLAVOR} \
@@ -33,13 +33,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-applehelp>=0:textproc/py-sphin
${PYTHON_PKGNAMEPREFIX}requests>=2.5.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4-cov>=0:devel/py-pytest4-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typed-ast>=0:devel/py-typed-ast@${PY_FLAVOR} \
cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist distutils concurrent pytest4
+USE_PYTHON= autoplist distutils concurrent pytest
NO_ARCH= yes