aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2017-08-14 19:21:04 +0000
committerChris Rees <crees@FreeBSD.org>2017-08-14 19:21:04 +0000
commita627e78476e2c55413b5db4768eeaa895e41ddc0 (patch)
tree35c699832ed381a89b446a54b3ec95232335c4cb
parent0b5cce930e52ddac57e7cdb1abff15671e16420b (diff)
downloadports-a627e78476e2c55413b5db4768eeaa895e41ddc0.tar.gz
ports-a627e78476e2c55413b5db4768eeaa895e41ddc0.zip
Add -qt5 port.
While here, correct version of transmission meta-port PR: ports/220933 Submitted by: ldbm@privacychain.ch
Notes
Notes: svn path=/head/; revision=447965
-rw-r--r--net-p2p/Makefile1
-rw-r--r--net-p2p/transmission-gtk/Makefile4
-rw-r--r--net-p2p/transmission-qt4/Makefile13
-rw-r--r--net-p2p/transmission-qt4/pkg-descr2
-rw-r--r--net-p2p/transmission-qt5/Makefile54
-rw-r--r--net-p2p/transmission-qt5/pkg-descr13
-rw-r--r--net-p2p/transmission-qt5/pkg-plist8
-rw-r--r--net-p2p/transmission/Makefile2
8 files changed, 89 insertions, 8 deletions
diff --git a/net-p2p/Makefile b/net-p2p/Makefile
index 22d6e0f8fb05..8658bf85804e 100644
--- a/net-p2p/Makefile
+++ b/net-p2p/Makefile
@@ -89,6 +89,7 @@
SUBDIR += transmission-daemon
SUBDIR += transmission-gtk
SUBDIR += transmission-qt4
+ SUBDIR += transmission-qt5
SUBDIR += transmission-remote-gui
SUBDIR += tribler
SUBDIR += twister
diff --git a/net-p2p/transmission-gtk/Makefile b/net-p2p/transmission-gtk/Makefile
index 5325218aa901..8d58e7739239 100644
--- a/net-p2p/transmission-gtk/Makefile
+++ b/net-p2p/transmission-gtk/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 3
+PORTREVISION= 4
PKGNAMESUFFIX= -gtk
MAINTAINER= crees@FreeBSD.org
@@ -18,7 +18,7 @@ MASTERDIR= ${.CURDIR}/../transmission-cli
PLIST= ${.CURDIR}/pkg-plist
SLAVEPORT= gtk
-USE_GNOME= gtk30 intlhack
+USE_GNOME= cairo gtk30 intlhack
USES= gettext pathfix desktop-file-utils
INSTALLS_ICONS= yes
diff --git a/net-p2p/transmission-qt4/Makefile b/net-p2p/transmission-qt4/Makefile
index d28a653e537e..50b51396bec9 100644
--- a/net-p2p/transmission-qt4/Makefile
+++ b/net-p2p/transmission-qt4/Makefile
@@ -1,21 +1,26 @@
# $FreeBSD$
-PORTREVISION= 4
+PORTREVISION= 5
PKGNAMESUFFIX= -qt4
MAINTAINER= crees@FreeBSD.org
-COMMENT= Fast and lightweight QT4 BitTorrent client
+COMMENT= Fast and lightweight Qt4 BitTorrent client
-LIB_DEPENDS= ${GEN_LIB_DEPENDS}
+LIB_DEPENDS= ${GEN_LIB_DEPENDS} \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
RUN_DEPENDS= ${GEN_RUN_DEPENDS}
+CONFLICTS_INSTALL= transmission-qt5-[0-9]*
+
DESCR= ${.CURDIR}/pkg-descr
MASTERDIR= ${.CURDIR}/../transmission-cli
PLIST= ${.CURDIR}/pkg-plist
SLAVEPORT= qt4
QT_NONSTANDARD= yes
-USE_QT4= moc_build qmake_build rcc_build uic_build gui dbus network
+USE_QT4= moc_build qmake_build uic_build rcc_build \
+ corelib gui dbus network xml
USES= compiler:c++11-lib desktop-file-utils
EXTRA_CONF_ARGS=--disable-cli \
diff --git a/net-p2p/transmission-qt4/pkg-descr b/net-p2p/transmission-qt4/pkg-descr
index 1e252e2875e1..9dd906c99b94 100644
--- a/net-p2p/transmission-qt4/pkg-descr
+++ b/net-p2p/transmission-qt4/pkg-descr
@@ -1,4 +1,4 @@
-A fast and lightweight QT4 BitTorrent client, loosely based on the GTK+ client.
+A fast and lightweight Qt4 BitTorrent client, loosely based on the GTK+ client.
This is the only Transmission client that can act as its own self-contained
session (as the GTK+ and Mac clients do), and can also connect to a remote
diff --git a/net-p2p/transmission-qt5/Makefile b/net-p2p/transmission-qt5/Makefile
new file mode 100644
index 000000000000..43b019586679
--- /dev/null
+++ b/net-p2p/transmission-qt5/Makefile
@@ -0,0 +1,54 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -qt5
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Fast and lightweight Qt5 BitTorrent client
+
+LIB_DEPENDS= ${GEN_LIB_DEPENDS} \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+RUN_DEPENDS= ${GEN_RUN_DEPENDS}
+
+CONFLICTS_INSTALL= transmission-qt4-[0-9]*
+
+DESCR= ${.CURDIR}/pkg-descr
+MASTERDIR= ${.CURDIR}/../transmission-cli
+PLIST= ${.CURDIR}/pkg-plist
+SLAVEPORT= qt5
+
+QT_NONSTANDARD= yes
+USE_QT5= buildtools_build qmake_build core dbus gui network widgets
+USES= compiler:c++11-lib desktop-file-utils
+
+EXTRA_CONF_ARGS=--disable-cli \
+ --disable-daemon \
+ --without-gtk \
+ --disable-mac \
+ --disable-nls
+
+post-patch: general-patch
+ @${REINPLACE_CMD} -e 's|/share/man|/man|g ; /PKGCONFIG/s| openssl||g' \
+ ${WRKSRC}/qt/qtr.pro
+ @${ECHO_CMD} 'LIBS += -l${PORT_OPTIONS:M*SSL:tl:S/openssl/crypto/}' \
+ >>${WRKSRC}/qt/qtr.pro
+
+post-build:
+ @(cd ${WRKSRC}/qt && ${QMAKE} ${QMAKE_ARGS} qtr.pro && ${MAKE_CMD})
+
+do-install:
+ @(cd ${WRKSRC}/qt && \
+ ${SETENV} INSTALL_ROOT=${STAGEDIR}${PREFIX} ${MAKE_CMD} install)
+
+post-install: general-install
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/transmission-qt
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/qt/README.txt \
+ ${STAGEDIR}${DOCSDIR}/README-qt5
+ @${INSTALL_DATA} ${WRKSRC}/qt/transmission-qt.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications/
+ @${INSTALL_DATA} ${WRKSRC}/qt/icons/transmission.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/transmission-qt.png
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-p2p/transmission-qt5/pkg-descr b/net-p2p/transmission-qt5/pkg-descr
new file mode 100644
index 000000000000..078dff87eff3
--- /dev/null
+++ b/net-p2p/transmission-qt5/pkg-descr
@@ -0,0 +1,13 @@
+A fast and lightweight Qt5 BitTorrent client, loosely based on the GTK+ client.
+
+This is the only Transmission client that can act as its own self-contained
+session (as the GTK+ and Mac clients do), and can also connect to a remote
+session (as the web client and transmission-remote terminal client do).
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission-qt5/pkg-plist b/net-p2p/transmission-qt5/pkg-plist
new file mode 100644
index 000000000000..b7c26441c004
--- /dev/null
+++ b/net-p2p/transmission-qt5/pkg-plist
@@ -0,0 +1,8 @@
+bin/transmission-qt
+man/man1/transmission-qt.1.gz
+share/applications/transmission-qt.desktop
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README-qt5
+share/pixmaps/transmission-qt.png
diff --git a/net-p2p/transmission/Makefile b/net-p2p/transmission/Makefile
index 04dcee0986ed..839221074a8c 100644
--- a/net-p2p/transmission/Makefile
+++ b/net-p2p/transmission/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= transmission
-PORTVERSION= 2.84
+PORTVERSION= 2.92
CATEGORIES= net-p2p
MAINTAINER= crees@FreeBSD.org