aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-04-11 08:04:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-04-11 08:05:19 +0000
commita669aa247540b97935c083ad2afdacf67321d53a (patch)
tree9a02de92b12331265dcd75e6cd27f2c6368b0d56
parent9a6556206f8019ecd3b7a09da839776227c666f6 (diff)
downloadports-a669aa247540b97935c083ad2afdacf67321d53a.tar.gz
ports-a669aa247540b97935c083ad2afdacf67321d53a.zip
science/py-pygmo2: Update 2.18.0 → 2.19.3
Reported by: portscout
-rw-r--r--science/py-pygmo2/Makefile5
-rw-r--r--science/py-pygmo2/distinfo6
-rw-r--r--science/py-pygmo2/files/patch-CMakeLists.txt6
3 files changed, 9 insertions, 8 deletions
diff --git a/science/py-pygmo2/Makefile b/science/py-pygmo2/Makefile
index 1768f06d6243..25485a04ae10 100644
--- a/science/py-pygmo2/Makefile
+++ b/science/py-pygmo2/Makefile
@@ -1,7 +1,6 @@
PORTNAME= pygmo2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.18.0
-PORTREVISION= 2
+DISTVERSION= 2.19.3
CATEGORIES= science graphics
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,6 +17,7 @@ LIB_DEPENDS= libpagmo.so:science/pagmo2 \
libnlopt.so:math/nlopt
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}cloudpickle>0:devel/py-cloudpickle@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dill>0:devel/py-dill@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR}
@@ -34,6 +34,7 @@ CMAKE_ARGS= -DFREEBSD_PYTHON_DISTVERSION=${PYTHON_DISTVERSION}
CXXFLAGS+= -I${LOCALBASE}/include/coin # see https://github.com/esa/pygmo2/issues/58
do-test: install # tests require sysctl sudo sysctl kern.threads.max_threads_per_proc variable to be at least 15000 ; test taken from azure-pipelines.yml
+ # some tests fail, see https://github.com/esa/pygmo2/issues/135
@${PYTHON_CMD} -c "import pygmo; pygmo.test.run_test_suite(1); pygmo.mp_island.shutdown_pool(); pygmo.mp_bfe.shutdown_pool()"
.include <bsd.port.mk>
diff --git a/science/py-pygmo2/distinfo b/science/py-pygmo2/distinfo
index fcb71603b8fd..39376e1f3ccd 100644
--- a/science/py-pygmo2/distinfo
+++ b/science/py-pygmo2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628134231
-SHA256 (esa-pygmo2-v2.18.0_GH0.tar.gz) = 9f081cc973297894af09f713f889870ac452bfb32b471f9f7ba08a5e0bb9a125
-SIZE (esa-pygmo2-v2.18.0_GH0.tar.gz) = 3021797
+TIMESTAMP = 1681192197
+SHA256 (esa-pygmo2-v2.19.3_GH0.tar.gz) = 40c3bcaaa0938a1acea1c31400f0d015faa38ae82fee8686cae392728e73e96f
+SIZE (esa-pygmo2-v2.19.3_GH0.tar.gz) = 3024188
diff --git a/science/py-pygmo2/files/patch-CMakeLists.txt b/science/py-pygmo2/files/patch-CMakeLists.txt
index b3cf3308cc40..f52fe2fdec04 100644
--- a/science/py-pygmo2/files/patch-CMakeLists.txt
+++ b/science/py-pygmo2/files/patch-CMakeLists.txt
@@ -1,13 +1,13 @@
- Fix the python version to one used by the port.
---- CMakeLists.txt.orig 2021-08-05 03:52:20 UTC
+--- CMakeLists.txt.orig 2023-04-09 15:01:42 UTC
+++ CMakeLists.txt
@@ -137,7 +137,7 @@ if(${pagmo_VERSION} VERSION_LESS ${_PYGMO_MIN_PAGMO_VE
endif()
# python.
--find_package(Python3 REQUIRED COMPONENTS Interpreter Development)
-+find_package(Python3 ${FREEBSD_PYTHON_DISTVERSION} EXACT REQUIRED COMPONENTS Interpreter Development)
+-find_package(Python3 REQUIRED COMPONENTS Interpreter Development.Module)
++find_package(Python3 ${FREEBSD_PYTHON_DISTVERSION} EXACT REQUIRED COMPONENTS Interpreter Development.Module)
message(STATUS "Python3 interpreter: ${Python3_EXECUTABLE}")
message(STATUS "Python3 installation directory: ${Python3_SITEARCH}")
set(PYGMO_INSTALL_PATH "" CACHE STRING "pygmo module installation path")