aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2024-05-01 15:21:16 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2024-05-01 15:21:33 +0000
commita6b5984bb57a3b70112836cd7ccbc8c2fbf337d9 (patch)
treead585e08bd30488a92f33530380ab16e9d2fcf5b
parent1d350c6bc3b9c5c12981600d5aa16e038633179d (diff)
downloadports-a6b5984bb57a3b70112836cd7ccbc8c2fbf337d9.tar.gz
ports-a6b5984bb57a3b70112836cd7ccbc8c2fbf337d9.zip
devel/py-grpcio-tools: update to 1.63.0.
-rw-r--r--devel/py-grpcio-tools/Makefile3
-rw-r--r--devel/py-grpcio-tools/distinfo6
-rw-r--r--devel/py-grpcio-tools/files/patch-setup.py22
3 files changed, 16 insertions, 15 deletions
diff --git a/devel/py-grpcio-tools/Makefile b/devel/py-grpcio-tools/Makefile
index 69c0bb85555c..94ff73e1b354 100644
--- a/devel/py-grpcio-tools/Makefile
+++ b/devel/py-grpcio-tools/Makefile
@@ -1,8 +1,9 @@
PORTNAME= grpcio-tools
-PORTVERSION= 1.62.2
+PORTVERSION= 1.63.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= grpcio_tools-${PORTVERSION}
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Protobuf code generator for gRPC
diff --git a/devel/py-grpcio-tools/distinfo b/devel/py-grpcio-tools/distinfo
index ba1a7127937e..647a1b962d2f 100644
--- a/devel/py-grpcio-tools/distinfo
+++ b/devel/py-grpcio-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1713516977
-SHA256 (grpcio-tools-1.62.2.tar.gz) = 5fd5e1582b678e6b941ee5f5809340be5e0724691df5299aae8226640f94e18f
-SIZE (grpcio-tools-1.62.2.tar.gz) = 4538350
+TIMESTAMP = 1714576305
+SHA256 (grpcio_tools-1.63.0.tar.gz) = 2474cffbc8f29404f0e3a2109c0a0423211ba93fe048b144e734f601ff391fc7
+SIZE (grpcio_tools-1.63.0.tar.gz) = 5026765
diff --git a/devel/py-grpcio-tools/files/patch-setup.py b/devel/py-grpcio-tools/files/patch-setup.py
index cecda56e3f44..b83ec7645346 100644
--- a/devel/py-grpcio-tools/files/patch-setup.py
+++ b/devel/py-grpcio-tools/files/patch-setup.py
@@ -1,15 +1,15 @@
---- setup.py.orig 2024-02-20 20:46:14 UTC
+--- setup.py.orig 2024-04-26 06:29:22 UTC
+++ setup.py
-@@ -145,7 +145,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
- # We need to statically link the C++ Runtime, only the C runtime is
- # available dynamically
- EXTRA_ENV_COMPILE_ARGS += " /MT"
-- elif "linux" in sys.platform or "darwin" in sys.platform:
-+ elif "linux" in sys.platform or "darwin" in sys.platform or "freebsd" in sys.platform:
- # GCC & Clang by defaults uses C17 so only C++14 needs to be specified.
+@@ -178,7 +178,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
+ # Reduce the optimization level from O3 (in many cases) to O1 to
+ # workaround gcc misalignment bug with MOVAPS (internal b/329134877)
+ EXTRA_ENV_COMPILE_ARGS += " -O1"
+- elif "darwin" in sys.platform:
++ elif "darwin" in sys.platform or "freebsd" in sys.platform:
+ # AppleClang by defaults uses C17 so only C++14 needs to be specified.
EXTRA_ENV_COMPILE_ARGS += " -std=c++14"
EXTRA_ENV_COMPILE_ARGS += " -fno-wrapv -frtti"
-@@ -174,7 +174,7 @@ if EXTRA_ENV_LINK_ARGS is None:
+@@ -211,7 +211,7 @@ if EXTRA_ENV_LINK_ARGS is None:
EXTRA_ENV_LINK_ARGS += " -Wl,-exported_symbol,_{}".format(
_EXT_INIT_SYMBOL
)
@@ -18,7 +18,7 @@
EXTRA_ENV_LINK_ARGS += " -lpthread"
if check_linker_need_libatomic():
EXTRA_ENV_LINK_ARGS += " -latomic"
-@@ -211,7 +211,7 @@ if "win32" in sys.platform:
+@@ -248,7 +248,7 @@ if "win32" in sys.platform:
)
if "64bit" in platform.architecture()[0]:
DEFINE_MACROS += (("MS_WIN64", 1),)
@@ -26,4 +26,4 @@
+elif "linux" in sys.platform or "darwin" in sys.platform or "freebsd" in sys.platform:
DEFINE_MACROS += (("HAVE_PTHREAD", 1),)
- # By default, Python3 setuptools(distutils) enforces compatibility of
+