aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-15 19:06:57 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-15 19:06:57 +0000
commita780537845fa39ced0ca9bdb7ebee281283ce8a4 (patch)
tree8ba8549a4281d7a3b65a48593b76102aeeae6453
parent2611f8c27d7038935bc15354f9e083a23c24f0db (diff)
downloadports-a780537845fa39ced0ca9bdb7ebee281283ce8a4.tar.gz
ports-a780537845fa39ced0ca9bdb7ebee281283ce8a4.zip
Support code for reading and manipulating hashed file storage (where
each file and directory is associated with a cryptographic hash, for corruption-resistant storage and fast comparisons). The supported storage formats include darcs hashed pristine, a plain filesystem tree and an indexed plain tree (where the index maintains hashes of the plain files and directories). WWW: http://hackage.haskell.org/package/hashed-storage
Notes
Notes: svn path=/head/; revision=254365
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-hashed-storage/Makefile33
-rw-r--r--devel/hs-hashed-storage/distinfo3
-rw-r--r--devel/hs-hashed-storage/pkg-descr9
-rw-r--r--devel/hs-hashed-storage/pkg-plist28
-rw-r--r--lang/ghc/bsd.hackage.mk1
6 files changed, 75 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dd223f88225c..ec32d09dd932 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -569,6 +569,7 @@
SUBDIR += hs-haddock
SUBDIR += hs-haddock-docs
SUBDIR += hs-happy
+ SUBDIR += hs-hashed-storage
SUBDIR += hs-haskeline
SUBDIR += hs-haskell-src-exts
SUBDIR += hs-hat
diff --git a/devel/hs-hashed-storage/Makefile b/devel/hs-hashed-storage/Makefile
new file mode 100644
index 000000000000..deff1a5b20b6
--- /dev/null
+++ b/devel/hs-hashed-storage/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hs-hashed-storage
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashed-storage
+PORTVERSION= 0.5
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Hashed file storage support code
+
+CABAL_SETUP= Setup.hs
+
+USE_HACKAGE= binary dataenc mmap>=0.5 zlib
+
+OPTIONS= TEST "Build tests" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TEST)
+CONFIGURE_ARGS+= --flags="test"
+EXECUTABLE+= hashed-storage-test
+PLIST_SUB+= MAYBE_TEST=""
+.else
+CONFIGURE_ARGS+= --flags="-test"
+PLIST_SUB+= MAYBE_TEST="@comment "
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-hashed-storage/distinfo b/devel/hs-hashed-storage/distinfo
new file mode 100644
index 000000000000..03bce0acdff5
--- /dev/null
+++ b/devel/hs-hashed-storage/distinfo
@@ -0,0 +1,3 @@
+MD5 (hashed-storage-0.5.tar.gz) = 84eb0ee6838c909ea25100db91d3232b
+SHA256 (hashed-storage-0.5.tar.gz) = d73b621b2b2d10060b5f6ca2388a9f51d3874d77bd1740d3bea4858b471ac487
+SIZE (hashed-storage-0.5.tar.gz) = 55292
diff --git a/devel/hs-hashed-storage/pkg-descr b/devel/hs-hashed-storage/pkg-descr
new file mode 100644
index 000000000000..c6cf79de7361
--- /dev/null
+++ b/devel/hs-hashed-storage/pkg-descr
@@ -0,0 +1,9 @@
+Support code for reading and manipulating hashed file storage (where
+each file and directory is associated with a cryptographic hash, for
+corruption-resistant storage and fast comparisons).
+
+The supported storage formats include darcs hashed pristine, a plain
+filesystem tree and an indexed plain tree (where the index maintains
+hashes of the plain files and directories).
+
+WWW: http://hackage.haskell.org/package/hashed-storage
diff --git a/devel/hs-hashed-storage/pkg-plist b/devel/hs-hashed-storage/pkg-plist
new file mode 100644
index 000000000000..7fd117f25af6
--- /dev/null
+++ b/devel/hs-hashed-storage/pkg-plist
@@ -0,0 +1,28 @@
+@comment $FreeBSD$
+%%MAYBE_TEST%%bin/hashed-storage-test
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled/Posix.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled/SHA256.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/AnchoredPath.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Darcs.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Hash.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Index.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Monad.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Packed.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Plain.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Tree.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed/Utils.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage/Hashed
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Storage
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Bundled
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index a931b3603d65..c8472492e877 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -45,6 +45,7 @@ GLURaw_port= x11-toolkits/hs-GLURaw-ghc
GLUT_port= x11-toolkits/hs-glut-ghc
haddock_port= devel/hs-haddock # executable
happy_port= devel/hs-happy # executable
+hashed-storage_port= devel/hs-hashed-storage
haskeline_port= devel/hs-haskeline
haskell-src-exts_port= devel/hs-haskell-src-exts
HaXml_port= textproc/hs-haxml # executable