aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:36:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-04-26 02:36:52 +0000
commita7adc8b7171f1e74395feb883890592a403f71a3 (patch)
treeaa00b5d80ef2f432f3658dec9a61e4e9dc82b6a3
parent1cf7eb5d508a2e64f5b5b2a416cab10638df3305 (diff)
downloadports-a7adc8b7171f1e74395feb883890592a403f71a3.tar.gz
ports-a7adc8b7171f1e74395feb883890592a403f71a3.zip
- Fix build on -current
- Add LICENSE - Stage support PR: 187762 Submitted by: ports fury
Notes
Notes: svn path=/head/; revision=352217
-rw-r--r--net/easysoap/Makefile24
-rw-r--r--net/easysoap/files/patch-src__SOAPSSLContext.cpp23
-rw-r--r--net/easysoap/pkg-plist1
3 files changed, 33 insertions, 15 deletions
diff --git a/net/easysoap/Makefile b/net/easysoap/Makefile
index 0dad3cb50d2e..0e2df31759d1 100644
--- a/net/easysoap/Makefile
+++ b/net/easysoap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= easysoap
PORTVERSION= 0.8.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/SWANSONG
DISTNAME= EasySoap++-${PORTVERSION}
@@ -11,22 +11,16 @@ DISTNAME= EasySoap++-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ SOAP Library based on expat
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LICENSE= LGPL21
+
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+USE_AUTOTOOLS= libtool
+CONFIGURE_ENV= ac_cv_lib_stdcpp_main=no
USE_LDCONFIG= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
- ${WRKSRC}/configure
-
-post-install:
- @${RM} -f ${PREFIX}/lib/libeasysoap.la
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/easysoap/files/patch-src__SOAPSSLContext.cpp b/net/easysoap/files/patch-src__SOAPSSLContext.cpp
new file mode 100644
index 000000000000..3267d2830360
--- /dev/null
+++ b/net/easysoap/files/patch-src__SOAPSSLContext.cpp
@@ -0,0 +1,23 @@
+--- src/SOAPSSLContext.cpp.orig
++++ src/SOAPSSLContext.cpp
+@@ -143,16 +143,16 @@
+ switch(methodType)
+ {
+ case SOAPSSLContext::SSL_v2:
+- method = SSLv2_client_method();
++ method = const_cast<SSL_METHOD*>(SSLv2_client_method());
+ break;
+ case SOAPSSLContext::SSL_v23:
+- method = SSLv23_client_method();
++ method = const_cast<SSL_METHOD*>(SSLv23_client_method());
+ break;
+ case SOAPSSLContext::SSL_v3:
+- method = SSLv3_client_method();
++ method = const_cast<SSL_METHOD*>(SSLv3_client_method());
+ break;
+ case SOAPSSLContext::TLS_v1:
+- method = TLSv1_client_method();
++ method = const_cast<SSL_METHOD*>(TLSv1_client_method());
+ break;
+ default:
+ break;
diff --git a/net/easysoap/pkg-plist b/net/easysoap/pkg-plist
index 517888b7f749..c19dc7c8df34 100644
--- a/net/easysoap/pkg-plist
+++ b/net/easysoap/pkg-plist
@@ -41,6 +41,7 @@ include/easysoap/es_config.h
include/easysoap/es_msvc.h
include/easysoap/es_mwerks.h
lib/libeasysoap.a
+lib/libeasysoap.la
lib/libeasysoap.so
lib/libeasysoap.so.0
@dirrm include/easysoap