aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-07-08 10:42:04 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-07-08 10:42:04 +0000
commita7d3136dfc458f587807a99d93b877a3613e26b9 (patch)
treeae354c0d479ac76e39dda3d765185469d0536303
parentd608f8c71624f61904fc4660b293de3de3d02d1b (diff)
downloadports-a7d3136dfc458f587807a99d93b877a3613e26b9.tar.gz
ports-a7d3136dfc458f587807a99d93b877a3613e26b9.zip
java/icedtea-web: allow to disable new launchers written in Rust
Even it's a build-time dependency, it's quite heavy nonetheless. Since those new launchers are optional (traditional shell-based versions are still provided), allow users to turn them off. Reported by: Vyacheslav Olkhovchenkov
-rw-r--r--java/icedtea-web/Makefile8
-rw-r--r--java/icedtea-web/pkg-plist6
2 files changed, 8 insertions, 6 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index ee9872f9cdbd..6e3f54bbca34 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -11,7 +11,6 @@ COMMENT= Free Java plug-in and Java Web Start for OpenJDK
LICENSE= GPLv2
BUILD_DEPENDS= zip:archivers/zip \
- rustc:lang/${RUST_DEFAULT} \
bash:shells/bash \
gsed:textproc/gsed \
${HAMCREST_JAR}:java/hamcrest \
@@ -53,12 +52,13 @@ TEST_TARGET= check
# Upstream archive contains files with UTF-8 names
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
-OPTIONS_DEFINE= DOCS PLUGIN RHINO TAGSOUP
-OPTIONS_DEFAULT=PLUGIN
+OPTIONS_DEFINE= DOCS PLUGIN RHINO RUST TAGSOUP
+OPTIONS_DEFAULT=PLUGIN RUST
OPTIONS_SUB= yes
PLUGIN_DESC= Enable the browser plug-in
RHINO_DESC= Add support for Proxy Auto Config files
+RUST_DESC= Build modern launchers written in Rust
TAGSOUP_DESC= Enable cleaning up of malformed JNLP files
DOCS_CONFIGURE_ENABLE= docs
@@ -69,6 +69,8 @@ RHINO_RUN_DEPENDS= ${RHINO_BUILD_DEPENDS}
RHINO_VARS= RHINO_JAR="${JAVASHAREDIR}/rhino/rhino.jar"
RHINO_VARS_OFF= RHINO_JAR=no
+RUST_BUILD_DEPENDS= rustc:lang/${RUST_DEFAULT}
+
TAGSOUP_BUILD_DEPENDS= ${JAVALIBDIR}/tagsoup.jar:textproc/tagsoup
TAGSOUP_RUN_DEPENDS= ${TAGSOUP_BUILD_DEPENDS}
TAGSOUP_VARS= TAGSOUP_JAR="${JAVALIBDIR}/tagsoup.jar"
diff --git a/java/icedtea-web/pkg-plist b/java/icedtea-web/pkg-plist
index 8c7f915aa9d0..d54b05276b79 100644
--- a/java/icedtea-web/pkg-plist
+++ b/java/icedtea-web/pkg-plist
@@ -1,9 +1,9 @@
bin/itw-modularjdk.args
-bin/itweb-javaws
+%%RUST%%bin/itweb-javaws
bin/itweb-javaws.sh
-bin/itweb-policyeditor
+%%RUST%%bin/itweb-policyeditor
bin/itweb-policyeditor.sh
-bin/itweb-settings
+%%RUST%%bin/itweb-settings
bin/itweb-settings.sh
%%PLUGIN%%%%WEBPLUGIN_DIR%%/IcedTeaPlugin.so
etc/bash_completion.d/itweb-settings.bash