aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-03-03 15:50:32 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-03-03 16:24:11 +0000
commita7d32d7eb6a0f53b5ab4d4d4675edc5ff6fb5d78 (patch)
tree3bdc4c8230bd33e3aa26736f747a00e6fb468cda
parent3a0c0e5e8ab7b296830bab5c2c9d89f5199157af (diff)
downloadports-a7d32d7eb6a0f53b5ab4d4d4675edc5ff6fb5d78.tar.gz
ports-a7d32d7eb6a0f53b5ab4d4d4675edc5ff6fb5d78.zip
x11-toolkits/copperspice: use distributed tarballs, not for i386
- Switch to the distributed tarballs, rather than pulling from github. This means NO_WRKSUBDIR, dos2unix, and removing the patches that apply to sources in GH but that are not in the released source tarballs. - Set NOT_FOR_ARCHS to i386, since there's issues in WebKit like ld: error: relocation R_386_PC32 cannot be used against symbol cti_vm_throw; recompile with -fPIC and I'm insufficiently interested in chasing this.
-rw-r--r--editors/diamond/Makefile6
-rw-r--r--misc/copperspice-examples/Makefile14
-rw-r--r--misc/copperspice-examples/distinfo6
-rw-r--r--x11-toolkits/copperspice/Makefile21
-rw-r--r--x11-toolkits/copperspice/distinfo6
-rw-r--r--x11-toolkits/copperspice/files/patch-src_declarative_CMakeLists.txt13
-rw-r--r--x11-toolkits/copperspice/files/patch-src_scripttools_CMakeLists.txt13
-rw-r--r--x11-toolkits/copperspice/files/patch-src_tools_lconvert_CMakeLists.txt18
-rw-r--r--x11-toolkits/copperspice/files/patch-utilities_unicode_CMakeLists.txt15
9 files changed, 40 insertions, 72 deletions
diff --git a/editors/diamond/Makefile b/editors/diamond/Makefile
index e36385cee66a..460e476cae86 100644
--- a/editors/diamond/Makefile
+++ b/editors/diamond/Makefile
@@ -1,9 +1,9 @@
PORTNAME= diamond
DISTVERSION= 1.3.7
-DISTNAME= Diamond-${DISTVERSION}
CATEGORIES= editors
-PKGNAMESUFFIX= -cs
MASTER_SITES= https://download.copperspice.com/${PORTNAME}/source/
+PKGNAMESUFFIX= -cs
+DISTNAME= Diamond-${DISTVERSION}
MAINTAINER= adridg@FreeBSD.org
COMMENT= Compact programmers editor
@@ -11,6 +11,8 @@ COMMENT= Compact programmers editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+NOT_FOR_ARCHS= i386
+
LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell
BUILD_DEPENDS= copperspice>=1.7:x11-toolkits/copperspice
RUN_DEPENDS= copperspice>=1.7:x11-toolkits/copperspice
diff --git a/misc/copperspice-examples/Makefile b/misc/copperspice-examples/Makefile
index bc60c59707cc..d392accee2e3 100644
--- a/misc/copperspice-examples/Makefile
+++ b/misc/copperspice-examples/Makefile
@@ -1,7 +1,10 @@
PORTNAME= copperspice-examples
DISTVERSIONPREFIX= ks-
DISTVERSION= 1.7.3
+PORTREVISION= 1
CATEGORIES= misc
+MASTER_SITES= https://download.copperspice.com/kitchensink/source/
+DISTNAME= KitchenSink-${DISTVERSION}
MAINTAINER= adridg@FreeBSD.org
COMMENT= Example programs for Copperspice
@@ -9,6 +12,8 @@ COMMENT= Example programs for Copperspice
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+NOT_FOR_ARCHS= i386
+
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpulse.so:audio/pulseaudio \
libgstreamer-1.0.so:multimedia/gstreamer1 \
@@ -23,16 +28,15 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
BUILD_DEPENDS= copperspice>=1.7:x11-toolkits/copperspice
RUN_DEPENDS= copperspice>=1.7:x11-toolkits/copperspice
-USES= compiler:c++17-lang cmake gl gnome iconv jpeg pkgconfig ssl xorg
+USES= compiler:c++17-lang cmake dos2unix gl gnome iconv jpeg pkgconfig ssl tar:bz2 xorg
USE_GL= gl
USE_GNOME= cairo glib20 libxml2
USE_GSTREAMER1= yes
USE_XORG= ice sm x11 xau xcb xcursor xext xfixes xi xinerama xrandr xrender
-USE_GITHUB= yes
-GH_ACCOUNT= copperspice
-GH_PROJECT= kitchensink
-
PLIST_FILES= bin/kitchensink
+NO_WRKSUBDIR= yes
+DOS2UNIX_FILES= src/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/misc/copperspice-examples/distinfo b/misc/copperspice-examples/distinfo
index 19d156d76a68..ca8968101ddc 100644
--- a/misc/copperspice-examples/distinfo
+++ b/misc/copperspice-examples/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644188375
-SHA256 (copperspice-kitchensink-ks-1.7.3_GH0.tar.gz) = 5e7f8cab97e6260ad6dc7e1195ef7983bb4ecf88c47047196ad48e8bf7690c3d
-SIZE (copperspice-kitchensink-ks-1.7.3_GH0.tar.gz) = 626928
+TIMESTAMP = 1646305585
+SHA256 (KitchenSink-1.7.3.tar.bz2) = 4de9d0cf9da42dc07daca442c4177ee485bd7dfc23fa1a5eeb303d7affa947cc
+SIZE (KitchenSink-1.7.3.tar.bz2) = 581145
diff --git a/x11-toolkits/copperspice/Makefile b/x11-toolkits/copperspice/Makefile
index ca28ea864e5d..a475ef38b1a1 100644
--- a/x11-toolkits/copperspice/Makefile
+++ b/x11-toolkits/copperspice/Makefile
@@ -1,7 +1,8 @@
PORTNAME= copperspice
-DISTVERSIONPREFIX= cs-
DISTVERSION= 1.7.3
+PORTREVISION= 1
CATEGORIES= x11-toolkits
+MASTER_SITES= https://download.copperspice.com/${PORTNAME}/source/
MAINTAINER= adridg@FreeBSD.org
COMMENT= First class GUI library to unite the C++ community
@@ -9,6 +10,8 @@ COMMENT= First class GUI library to unite the C++ community
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/license/LICENSE.LGPL
+NOT_FOR_ARCHS= i386
+
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpulse.so:audio/pulseaudio \
libgstreamer-1.0.so:multimedia/gstreamer1 \
@@ -21,25 +24,25 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libxkbcommon.so:x11/libxkbcommon \
libfontconfig.so:x11-fonts/fontconfig
-USES= compiler:c++17-lang cmake gl gnome iconv jpeg pkgconfig ssl xorg
+USES= compiler:c++17-lang cmake dos2unix gl gnome iconv jpeg pkgconfig ssl tar:bz2 xorg
USE_GL= gl
USE_GNOME= cairo glib20 libxml2
USE_GSTREAMER1= yes
USE_XORG= ice sm x11 xau xcb xcursor xext xfixes xi xinerama xrandr xrender
-USE_GITHUB= yes
-
-CMAKE_ARGS+= -DCMAKE_INSTALL_BINDIR:PATH='$(LOCALBASE)/lib/copperspice/bin' \
- -DCMAKE_INSTALL_INCLUDEDIR:PATH='$(LOCALBASE)/include/copperspice' \
- -DCMAKE_INSTALL_PREFIX:PATH='$(LOCALBASE)' \
+CMAKE_ARGS+= -DCMAKE_INSTALL_BINDIR:PATH='${LOCALBASE}/lib/copperspice/bin' \
+ -DCMAKE_INSTALL_INCLUDEDIR:PATH='${LOCALBASE}/include/copperspice' \
+ -DCMAKE_INSTALL_PREFIX:PATH='${LOCALBASE}' \
-DTOOLS_SUFFIX:STRING=-cs
+NO_WRKSUBDIR= yes
+
# There is a notional conflict with the Qt ports: those have **versioned**
# tool names, like designer-qt5, lupdate-qt5, to allow co-installation
# of Qt[456] (when we had / have more than one current-version in ports).
#
-# Since CopperSpice doesn't version the binaries, it doesn't conflict
-# with the Qt ports, but does "rudely" occupy the unversioned name.
+# We use -cs for the Copperspice suffix to distinguish from -qt5, and
+# the executables go in a separate directory anyway.
#
# CONFLICTS= qt5-core
diff --git a/x11-toolkits/copperspice/distinfo b/x11-toolkits/copperspice/distinfo
index 4e65f5d36c6b..0d85b285a09b 100644
--- a/x11-toolkits/copperspice/distinfo
+++ b/x11-toolkits/copperspice/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644180687
-SHA256 (copperspice-copperspice-cs-1.7.3_GH0.tar.gz) = c1c1318f04aae0e4af10fffa6d20267768c2b1acc4c339f41609629584f81c39
-SIZE (copperspice-copperspice-cs-1.7.3_GH0.tar.gz) = 35455780
+TIMESTAMP = 1646305690
+SHA256 (copperspice-1.7.3.tar.bz2) = 9aed04de6bd522c84953a03d68107df7aebba7516e5add3520e48b412589cd28
+SIZE (copperspice-1.7.3.tar.bz2) = 18041796
diff --git a/x11-toolkits/copperspice/files/patch-src_declarative_CMakeLists.txt b/x11-toolkits/copperspice/files/patch-src_declarative_CMakeLists.txt
deleted file mode 100644
index 472eedf70715..000000000000
--- a/x11-toolkits/copperspice/files/patch-src_declarative_CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/declarative/CMakeLists.txt.orig 2022-01-14 18:52:21 UTC
-+++ src/declarative/CMakeLists.txt
-@@ -73,8 +73,8 @@ macro_generate_package(
- install(TARGETS CsDeclarative
- EXPORT CopperSpiceLibraryTargets ${INSTALL_TARGETS_DEFAULT_ARGS}
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
- )
-
- install(
diff --git a/x11-toolkits/copperspice/files/patch-src_scripttools_CMakeLists.txt b/x11-toolkits/copperspice/files/patch-src_scripttools_CMakeLists.txt
deleted file mode 100644
index fef284348123..000000000000
--- a/x11-toolkits/copperspice/files/patch-src_scripttools_CMakeLists.txt
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/scripttools/CMakeLists.txt.orig 2022-01-14 18:52:21 UTC
-+++ src/scripttools/CMakeLists.txt
-@@ -62,8 +62,8 @@ install(
- TARGETS CsScriptTools
- EXPORT CopperSpiceLibraryTargets ${INSTALL_TARGETS_DEFAULT_ARGS}
- RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
-- LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-- ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
-+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}${CS_NAMESPACE_DIRECTORY}
- )
-
- install(
diff --git a/x11-toolkits/copperspice/files/patch-src_tools_lconvert_CMakeLists.txt b/x11-toolkits/copperspice/files/patch-src_tools_lconvert_CMakeLists.txt
index 77752954f979..4581871f73c8 100644
--- a/x11-toolkits/copperspice/files/patch-src_tools_lconvert_CMakeLists.txt
+++ b/x11-toolkits/copperspice/files/patch-src_tools_lconvert_CMakeLists.txt
@@ -1,11 +1,11 @@
--- src/tools/lconvert/CMakeLists.txt.orig 2022-01-14 18:52:21 UTC
+++ src/tools/lconvert/CMakeLists.txt
-@@ -39,7 +39,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "DARWIN")
- endif()
-
- if(CMAKE_SYSTEM_NAME MATCHES "(OpenBSD|FreeBSD|NetBSD)")
-- list(APPEND EXTRA_LCONVERT_LDFLAGS '-Wl,-rpath,$ORIGIN/../lib')
-+ list(APPEND EXTRA_LCONVERT_LDFLAGS '-Wl,-rpath,${CS_FULL_LIBDIR}')
- endif()
-
- if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+@@ -39,7 +39,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "DARWIN")
+ endif()
+
+ if(CMAKE_SYSTEM_NAME MATCHES "(OpenBSD|FreeBSD|NetBSD)")
+- list(APPEND EXTRA_LCONVERT_LDFLAGS '-Wl,-rpath,$ORIGIN/../lib')
++ list(APPEND EXTRA_LCONVERT_LDFLAGS '-Wl,-rpath,${CS_FULL_LIBDIR}')
+ endif()
+
+ if(CMAKE_SYSTEM_NAME MATCHES "Linux")
diff --git a/x11-toolkits/copperspice/files/patch-utilities_unicode_CMakeLists.txt b/x11-toolkits/copperspice/files/patch-utilities_unicode_CMakeLists.txt
deleted file mode 100644
index e12f670492fe..000000000000
--- a/x11-toolkits/copperspice/files/patch-utilities_unicode_CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
---- utilities/unicode/CMakeLists.txt.orig 2022-02-18 10:42:10 UTC
-+++ utilities/unicode/CMakeLists.txt
-@@ -34,12 +34,6 @@ if (CMAKE_SYSTEM_NAME MATCHES "Darwin")
- elseif (CMAKE_SYSTEM_NAME MATCHES "(Linux|OpenBSD|FreeBSD|NetBSD|DragonFly)")
- include(GNUInstallDirs)
-
-- # rpath used for rcc and uic when compiling a user application
-- file(RELATIVE_PATH CS_BIN_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_BINDIR}"
-- "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
--
-- set(CMAKE_INSTALL_RPATH "$ORIGIN/${CS_BIN_RPATH}")
--
- elseif (CMAKE_SYSTEM_NAME MATCHES "Windows")
- set(CMAKE_INSTALL_BINDIR bin)
- set(CMAKE_INSTALL_LIBDIR lib)