aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-05-06 05:51:47 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-05-06 05:54:33 +0000
commita7da23da6e6b420c9041018426051b269cef0669 (patch)
treed0455900c8dbbab0213f545465729acc14447dd5
parent6d9bd7171b6b5b3c4d9360be35c46fc2b02f5fff (diff)
downloadports-a7da23da6e6b420c9041018426051b269cef0669.tar.gz
ports-a7da23da6e6b420c9041018426051b269cef0669.zip
lang/rust: Add TRYBROKEN to makesum
-rw-r--r--lang/rust/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index f7ad497453a1..f81c909f94e9 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -224,14 +224,14 @@ do-test:
.if !defined(_RUST_MAKESUM_GUARD)
makesum:
- ${MAKE} -D_RUST_MAKESUM_GUARD makesum ARCH=${ONLY_FOR_ARCHS:O:[1]} DISTINFO_FILE=${DISTINFO_FILE}.tmp
+ ${MAKE} -D_RUST_MAKESUM_GUARD -DTRYBROKEN makesum ARCH=${ONLY_FOR_ARCHS:O:[1]} DISTINFO_FILE=${DISTINFO_FILE}.tmp
.for arch in ${ONLY_FOR_ARCHS:O:[2..-1]}
- ${MAKE} -D_RUST_MAKESUM_GUARD makesum PPC_ABI=ELFv1 ARCH=${arch} DISTINFO_FILE=${DISTINFO_FILE}.${arch}
+ ${MAKE} -D_RUST_MAKESUM_GUARD -DTRYBROKEN makesum PPC_ABI=ELFv1 ARCH=${arch} DISTINFO_FILE=${DISTINFO_FILE}.${arch}
${SED} 1d ${DISTINFO_FILE}.${arch} >> ${DISTINFO_FILE}.tmp
${RM} ${DISTINFO_FILE}.${arch}
.endfor
.if ${ONLY_FOR_ARCHS:Mpowerpc64}
- ${MAKE} -D_RUST_MAKESUM_GUARD makesum PPC_ABI=ELFv2 ARCH=powerpc64 DISTINFO_FILE=${DISTINFO_FILE}.powerpc64-elfv2
+ ${MAKE} -D_RUST_MAKESUM_GUARD -DTRYBROKEN makesum PPC_ABI=ELFv2 ARCH=powerpc64 DISTINFO_FILE=${DISTINFO_FILE}.powerpc64-elfv2
${SED} 1d ${DISTINFO_FILE}.powerpc64-elfv2 >> ${DISTINFO_FILE}.tmp
${RM} ${DISTINFO_FILE}.powerpc64-elfv2
.endif