aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 18:46:18 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 18:53:44 +0000
commita81eae7fadd0c12e3e2d1f79e4113b0e1364311d (patch)
tree028daf2d24f476fb3af4ba9513d3949b491cc8a2
parentbe0a915114dd4a04a85b4641e6484ac3fe7e41eb (diff)
downloadports-a81eae7fadd0c12e3e2d1f79e4113b0e1364311d.tar.gz
ports-a81eae7fadd0c12e3e2d1f79e4113b0e1364311d.zip
devel/codeblocks: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/codeblocks/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/codeblocks/Makefile b/devel/codeblocks/Makefile
index a83c60698a70..7daefb57da4c 100644
--- a/devel/codeblocks/Makefile
+++ b/devel/codeblocks/Makefile
@@ -22,15 +22,18 @@ USES= autoreconf compiler:c++11-lang desktop-file-utils \
fam:gamin gettext-runtime gnome libtool localbase \
pathfix pkgconfig shared-mime-info tar:xz xorg
USE_CXXSTD= c++11
-USE_WX= 3.0+
USE_GNOME= gtk30 cairo
+USE_LDCONFIG= yes
+USE_WX= 3.0+
USE_XORG= x11
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG} --disable-pch \
--with-boost-system=boost_system
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+
PKG_CONFIG_LIBDIR= ${LOCALBASE}/libdata/pkgconfig
INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}