aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-06 15:46:01 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-06 15:46:01 +0000
commita88cf684065b71c1c1e0a5f57e149cb2771d04dc (patch)
tree70e3f6a42669f9ce4c00939d6b5e4d11a0c201dc
parent8169e0cd2793b0afbbc589caee6d7285d6f366d8 (diff)
downloadports-a88cf684065b71c1c1e0a5f57e149cb2771d04dc.tar.gz
ports-a88cf684065b71c1c1e0a5f57e149cb2771d04dc.zip
- USE_AUTOTOOLS contains aclocal but not autoconf which leaves configure
out of date and causes make (build phase) to run autoconf, erasing any configure patches. Then make reruns configure. Instead of adding autoconf to USE_AUTOTOOLS avoid USE_AUTOTOOLS altogether by patching Makefile.in instead of Makefile.am. - Use INSTALL_TARGET=install-strip and USES=pathfix Commit message taken from: tijl
Notes
Notes: svn path=/head/; revision=367445
-rw-r--r--devel/librelp/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/devel/librelp/Makefile b/devel/librelp/Makefile
index f7a37bfbe562..f63675c3a12d 100644
--- a/devel/librelp/Makefile
+++ b/devel/librelp/Makefile
@@ -13,8 +13,9 @@ COMMENT= Reliable event logging protocol library
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
USES= libtool pathfix pkgconfig
-USE_AUTOTOOLS= automake aclocal
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
PLIST_FILES= include/${PORTNAME}.h \
lib/${PORTNAME}.a \
@@ -27,10 +28,5 @@ PORT_VERBS= relp
post-patch:
@${REINPLACE_CMD} -e '/CFLAGS/s| -g||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.am
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librelp.so.0.1.0
.include <bsd.port.mk>