aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-02-05 01:08:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-02-06 20:05:22 +0000
commita895d1ae289fb52d05d3cf251ab8174bb9bcbbf2 (patch)
tree441151baa6c979e939a5e6f15cff3570be34bdf6
parent217d6e838c762700cc0eb0735f41c725ed0cb8f7 (diff)
downloadports-a895d1ae289fb52d05d3cf251ab8174bb9bcbbf2.tar.gz
ports-a895d1ae289fb52d05d3cf251ab8174bb9bcbbf2.zip
x11/windowtolayer: add new port
This program transforms individual Wayland clients, which use the xdg-shell protocol to display windows, into clients that use the wlr-layer-shell protocol to render as a wallpaper. Note that wlr-layer-shell is only supported by some compositors (like KWin, and those based on wlroots.) https://gitlab.freedesktop.org/mstoeckl/windowtolayer
-rw-r--r--x11/Makefile1
-rw-r--r--x11/windowtolayer/Makefile22
-rw-r--r--x11/windowtolayer/Makefile.crates26
-rw-r--r--x11/windowtolayer/distinfo55
-rw-r--r--x11/windowtolayer/pkg-descr5
5 files changed, 109 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a7b9c648acaa..fd8eb036ce68 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -458,6 +458,7 @@
SUBDIR += wev
SUBDIR += wezterm
SUBDIR += wf-shell
+ SUBDIR += windowtolayer
SUBDIR += wl-clipboard
SUBDIR += wl-mirror
SUBDIR += wlogout
diff --git a/x11/windowtolayer/Makefile b/x11/windowtolayer/Makefile
new file mode 100644
index 000000000000..3b2110e6ea69
--- /dev/null
+++ b/x11/windowtolayer/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= windowtolayer
+PORTVERSION= s20240204
+CATEGORIES= x11 wayland
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Any Wayland window as wallpaper
+WWW= https://gitlab.freedesktop.org/mstoeckl/windowtolayer
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cargo
+USE_GITLAB= yes
+GL_SITE= https://gitlab.freedesktop.org
+GL_ACCOUNT= mstoeckl
+GL_TAGNAME= 3a6dedc
+PLIST_FILES= bin/${PORTNAME}
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/x11/windowtolayer/Makefile.crates b/x11/windowtolayer/Makefile.crates
new file mode 100644
index 000000000000..198d6b84d864
--- /dev/null
+++ b/x11/windowtolayer/Makefile.crates
@@ -0,0 +1,26 @@
+CARGO_CRATES= anstream-0.6.7 \
+ anstyle-1.0.4 \
+ anstyle-parse-0.2.3 \
+ anstyle-query-1.0.2 \
+ anstyle-wincon-3.0.2 \
+ autocfg-1.1.0 \
+ bitflags-2.4.1 \
+ cfg-if-1.0.0 \
+ clap-4.4.17 \
+ clap_builder-4.4.17 \
+ clap_lex-0.6.0 \
+ colorchoice-1.0.0 \
+ libc-0.2.152 \
+ memoffset-0.9.0 \
+ nix-0.27.1 \
+ strsim-0.10.0 \
+ utf8parse-0.2.1 \
+ windows-sys-0.52.0 \
+ windows-targets-0.52.0 \
+ windows_aarch64_gnullvm-0.52.0 \
+ windows_aarch64_msvc-0.52.0 \
+ windows_i686_gnu-0.52.0 \
+ windows_i686_msvc-0.52.0 \
+ windows_x86_64_gnu-0.52.0 \
+ windows_x86_64_gnullvm-0.52.0 \
+ windows_x86_64_msvc-0.52.0
diff --git a/x11/windowtolayer/distinfo b/x11/windowtolayer/distinfo
new file mode 100644
index 000000000000..f5a626cdfe2c
--- /dev/null
+++ b/x11/windowtolayer/distinfo
@@ -0,0 +1,55 @@
+TIMESTAMP = 1707095286
+SHA256 (rust/crates/anstream-0.6.7.crate) = 4cd2405b3ac1faab2990b74d728624cd9fd115651fcecc7c2d8daf01376275ba
+SIZE (rust/crates/anstream-0.6.7.crate) = 30063
+SHA256 (rust/crates/anstyle-1.0.4.crate) = 7079075b41f533b8c61d2a4d073c4676e1f8b249ff94a393b0595db304e0dd87
+SIZE (rust/crates/anstyle-1.0.4.crate) = 13998
+SHA256 (rust/crates/anstyle-parse-0.2.3.crate) = c75ac65da39e5fe5ab759307499ddad880d724eed2f6ce5b5e8a26f4f387928c
+SIZE (rust/crates/anstyle-parse-0.2.3.crate) = 24699
+SHA256 (rust/crates/anstyle-query-1.0.2.crate) = e28923312444cdd728e4738b3f9c9cac739500909bb3d3c94b43551b16517648
+SIZE (rust/crates/anstyle-query-1.0.2.crate) = 8739
+SHA256 (rust/crates/anstyle-wincon-3.0.2.crate) = 1cd54b81ec8d6180e24654d0b371ad22fc3dd083b6ff8ba325b72e00c87660a7
+SIZE (rust/crates/anstyle-wincon-3.0.2.crate) = 11272
+SHA256 (rust/crates/autocfg-1.1.0.crate) = d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa
+SIZE (rust/crates/autocfg-1.1.0.crate) = 13272
+SHA256 (rust/crates/bitflags-2.4.1.crate) = 327762f6e5a765692301e5bb513e0d9fef63be86bbc14528052b1cd3e6f03e07
+SIZE (rust/crates/bitflags-2.4.1.crate) = 37043
+SHA256 (rust/crates/cfg-if-1.0.0.crate) = baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd
+SIZE (rust/crates/cfg-if-1.0.0.crate) = 7934
+SHA256 (rust/crates/clap-4.4.17.crate) = 80932e03c33999b9235edb8655bc9df3204adc9887c2f95b50cb1deb9fd54253
+SIZE (rust/crates/clap-4.4.17.crate) = 55526
+SHA256 (rust/crates/clap_builder-4.4.17.crate) = d6c0db58c659eef1c73e444d298c27322a1b52f6927d2ad470c0c0f96fa7b8fa
+SIZE (rust/crates/clap_builder-4.4.17.crate) = 163522
+SHA256 (rust/crates/clap_lex-0.6.0.crate) = 702fc72eb24e5a1e48ce58027a675bc24edd52096d5397d4aea7c6dd9eca0bd1
+SIZE (rust/crates/clap_lex-0.6.0.crate) = 12272
+SHA256 (rust/crates/colorchoice-1.0.0.crate) = acbf1af155f9b9ef647e42cdc158db4b64a1b61f743629225fde6f3e0be2a7c7
+SIZE (rust/crates/colorchoice-1.0.0.crate) = 6857
+SHA256 (rust/crates/libc-0.2.152.crate) = 13e3bf6590cbc649f4d1a3eefc9d5d6eb746f5200ffb04e5e142700b8faa56e7
+SIZE (rust/crates/libc-0.2.152.crate) = 740278
+SHA256 (rust/crates/memoffset-0.9.0.crate) = 5a634b1c61a95585bd15607c6ab0c4e5b226e695ff2800ba0cdccddf208c406c
+SIZE (rust/crates/memoffset-0.9.0.crate) = 9033
+SHA256 (rust/crates/nix-0.27.1.crate) = 2eb04e9c688eff1c89d72b407f168cf79bb9e867a9d3323ed6c01519eb9cc053
+SIZE (rust/crates/nix-0.27.1.crate) = 286494
+SHA256 (rust/crates/strsim-0.10.0.crate) = 73473c0e59e6d5812c5dfe2a064a6444949f089e20eec9a2e5506596494e4623
+SIZE (rust/crates/strsim-0.10.0.crate) = 11355
+SHA256 (rust/crates/utf8parse-0.2.1.crate) = 711b9620af191e0cdc7468a8d14e709c3dcdb115b36f838e601583af800a370a
+SIZE (rust/crates/utf8parse-0.2.1.crate) = 13435
+SHA256 (rust/crates/windows-sys-0.52.0.crate) = 282be5f36a8ce781fad8c8ae18fa3f9beff57ec1b52cb3de0789201425d9a33d
+SIZE (rust/crates/windows-sys-0.52.0.crate) = 2576877
+SHA256 (rust/crates/windows-targets-0.52.0.crate) = 8a18201040b24831fbb9e4eb208f8892e1f50a37feb53cc7ff887feb8f50e7cd
+SIZE (rust/crates/windows-targets-0.52.0.crate) = 6229
+SHA256 (rust/crates/windows_aarch64_gnullvm-0.52.0.crate) = cb7764e35d4db8a7921e09562a0304bf2f93e0a51bfccee0bd0bb0b666b015ea
+SIZE (rust/crates/windows_aarch64_gnullvm-0.52.0.crate) = 430182
+SHA256 (rust/crates/windows_aarch64_msvc-0.52.0.crate) = bbaa0368d4f1d2aaefc55b6fcfee13f41544ddf36801e793edbbfd7d7df075ef
+SIZE (rust/crates/windows_aarch64_msvc-0.52.0.crate) = 821663
+SHA256 (rust/crates/windows_i686_gnu-0.52.0.crate) = a28637cb1fa3560a16915793afb20081aba2c92ee8af57b4d5f28e4b3e7df313
+SIZE (rust/crates/windows_i686_gnu-0.52.0.crate) = 870285
+SHA256 (rust/crates/windows_i686_msvc-0.52.0.crate) = ffe5e8e31046ce6230cc7215707b816e339ff4d4d67c65dffa206fd0f7aa7b9a
+SIZE (rust/crates/windows_i686_msvc-0.52.0.crate) = 888693
+SHA256 (rust/crates/windows_x86_64_gnu-0.52.0.crate) = 3d6fa32db2bc4a2f5abeacf2b69f7992cd09dca97498da74a151a3132c26befd
+SIZE (rust/crates/windows_x86_64_gnu-0.52.0.crate) = 826213
+SHA256 (rust/crates/windows_x86_64_gnullvm-0.52.0.crate) = 1a657e1e9d3f514745a572a6846d3c7aa7dbe1658c056ed9c3344c4109a6949e
+SIZE (rust/crates/windows_x86_64_gnullvm-0.52.0.crate) = 430165
+SHA256 (rust/crates/windows_x86_64_msvc-0.52.0.crate) = dff9641d1cd4be8d1a070daf9e3773c5f67e78b4d9d42263020c057706765c04
+SIZE (rust/crates/windows_x86_64_msvc-0.52.0.crate) = 821600
+SHA256 (windowtolayer-3a6dedc.tar.bz2) = e2f4690066a96987b467a7ceae5ce2d05cc9627ce9d45343dd265eda25ae25b6
+SIZE (windowtolayer-3a6dedc.tar.bz2) = 140063
diff --git a/x11/windowtolayer/pkg-descr b/x11/windowtolayer/pkg-descr
new file mode 100644
index 000000000000..de9f85e73f19
--- /dev/null
+++ b/x11/windowtolayer/pkg-descr
@@ -0,0 +1,5 @@
+This program transforms individual Wayland clients, which use the
+xdg-shell protocol to display windows, into clients that use the
+wlr-layer-shell protocol to render as a wallpaper. Note that
+wlr-layer-shell is only supported by some compositors (like KWin, and
+those based on wlroots.)