aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-18 19:21:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-18 19:25:57 +0000
commita8bc918ae7c32c3e373434e0a412ff7a780b355c (patch)
tree0e1bcf32090dc25e536151c0ae6ff184af852918
parent4a7d84eeeda54968067876722ea6c5077597562c (diff)
downloadports-a8bc918ae7c32c3e373434e0a412ff7a780b355c.tar.gz
ports-a8bc918ae7c32c3e373434e0a412ff7a780b355c.zip
math/blaspp: Fix configure
configure was failing to find the BLAS library because it used its own ad-hoc cmake file that was failing. find_package(BLAS) works. PR: 275162 Reported by: Lorenzo Salvadore <salvadore@freebsd.org>; fallout
-rw-r--r--math/blaspp/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/math/blaspp/Makefile b/math/blaspp/Makefile
index 149b91e48f91..8c8e264b528c 100644
--- a/math/blaspp/Makefile
+++ b/math/blaspp/Makefile
@@ -16,6 +16,7 @@ TEST_DEPENDS= cblas>0:math/cblas
USES= cmake:testing fortran localbase # fails to find openblas w/out USES=fortran for some reason, needs investigation
+CMAKE_ON= use_cmake_find_blas # otherwise blas isn't found by the project's ad-hoc cmake/BLASFinder.cmake file
CMAKE_OFF= build_tests
CMAKE_TESTING_ON= build_tests # tests fail to run, see https://bitbucket.org/icl/blaspp/issues/19/tests-arent-run-with-tester-target-when
CMAKE_TESTING_TARGET= tester