aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-23 10:19:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-23 15:03:05 +0000
commita94953ebabefd6cce7590c5d3479549e35dfc62f (patch)
tree4506211b4b972d5a4f806b64487a8074ebd67d6a
parent290fb053aba28c7b6e53a09a45bd053d2bf33894 (diff)
downloadports-a94953ebabefd6cce7590c5d3479549e35dfc62f.tar.gz
ports-a94953ebabefd6cce7590c5d3479549e35dfc62f.zip
games/gnurobots: fix build, simplify and modernize
- Fix build by depending on correct guile port - Simplify and modernize the port - Switch to USES=localbase
-rw-r--r--games/gnurobots/Makefile37
-rw-r--r--games/gnurobots/files/patch-configure.ac11
-rw-r--r--games/gnurobots/files/patch-src_ui-cmdwin.c16
-rw-r--r--games/gnurobots/pkg-plist2
4 files changed, 44 insertions, 22 deletions
diff --git a/games/gnurobots/Makefile b/games/gnurobots/Makefile
index 1c9b1aa5304f..a59dfa7b1a21 100644
--- a/games/gnurobots/Makefile
+++ b/games/gnurobots/Makefile
@@ -2,13 +2,9 @@
PORTNAME= gnurobots
PORTVERSION= 1.2.0
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= games
-MASTER_SITES= GNU \
- SF/nemysisfreebsdp/${CATEGORIES}/:icons
-DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
-EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU diversion wherein Scheme-coded robots explore a world
@@ -16,33 +12,32 @@ COMMENT= GNU diversion wherein Scheme-coded robots explore a world
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libguile.so:lang/guile
+LIB_DEPENDS= libguile.so:lang/guile1
-USES= gnome pkgconfig readline
+USES= autoreconf gnome localbase:ldflags pkgconfig readline
USE_GNOME= vte
GNU_CONFIGURE= yes
-CFLAGS+= -O0
-CPPFLAGS+= -I${LOCALBASE}/include -w
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
-
PORTDOCS= *
-OPTIONS_DEFINE= DOCS
+CFLAGS+= -O0
SUB_FILES= pkg-install pkg-message
-DESKTOP_ENTRIES="GNU Robots" "" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ""
+DESKTOP_ENTRIES="GNU Robots" \
+ "" \
+ "${PORTNAME}" \
+ "${PORTNAME}" \
+ "Game;ArcadeGame;" \
+ ""
-post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|#include <pty.h>||g' ${WRKSRC}/src/ui-cmdwin.c
- @${REINPLACE_CMD} -E 's,(readline.h|history.h),readline/\1,' ${WRKSRC}/src/ui-cmdwin.c
+OPTIONS_DEFINE= DOCS
post-install:
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_DATA} ${WRKSRC}/xpm/robot.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.xpm
+
+post-install-DOCS-on:
cd ${WRKSRC} && ${COPYTREE_SHARE} "AUTHORS ChangeLog NEWS README THANKS \
doc/Robots-HOWTO doc/contrib" ${STAGEDIR}${DOCSDIR}
diff --git a/games/gnurobots/files/patch-configure.ac b/games/gnurobots/files/patch-configure.ac
new file mode 100644
index 000000000000..4461820cfa5b
--- /dev/null
+++ b/games/gnurobots/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-08-03 19:48:45 UTC
++++ configure.ac
+@@ -91,8 +91,6 @@ You need guile 1.8 to build this program.
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+
+-CFLAGS="-pedantic-errors -Werror -Wall -g"
+-
+ dnl Done.
+ AC_CONFIG_FILES([Makefile
+ contrib/Makefile
diff --git a/games/gnurobots/files/patch-src_ui-cmdwin.c b/games/gnurobots/files/patch-src_ui-cmdwin.c
new file mode 100644
index 000000000000..463cc8545652
--- /dev/null
+++ b/games/gnurobots/files/patch-src_ui-cmdwin.c
@@ -0,0 +1,16 @@
+--- src/ui-cmdwin.c.orig 2008-08-03 14:44:53 UTC
++++ src/ui-cmdwin.c
+@@ -19,11 +19,10 @@
+ #include "ui-cmdwin.h"
+
+ #include <stdlib.h>
+-#include <pty.h>
+
+ #include <vte/vte.h>
+-#include <readline.h>
+-#include <history.h>
++#include <readline/readline.h>
++#include <readline/history.h>
+
+ struct _UICmdWinPrivate
+ {
diff --git a/games/gnurobots/pkg-plist b/games/gnurobots/pkg-plist
index ed2ea074eb8a..028b3343e924 100644
--- a/games/gnurobots/pkg-plist
+++ b/games/gnurobots/pkg-plist
@@ -8,4 +8,4 @@ bin/gnurobots
%%DATADIR%%/scheme/simple.scm
%%DATADIR%%/scheme/stop.scm
%%DATADIR%%/scheme/zap.scm
-share/pixmaps/gnurobots.png
+share/pixmaps/gnurobots.xpm