aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-10-07 11:24:53 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-10-07 11:31:37 +0000
commita95dab961496b5a1b771916b4ffddacbb5c0ff80 (patch)
tree01f7339cc6bba045601428aea32ad9b33554eee4
parent354ce3e6dc82448b43425dcb974241749fa9b0e0 (diff)
downloadports-a95dab961496b5a1b771916b4ffddacbb5c0ff80.tar.gz
ports-a95dab961496b5a1b771916b4ffddacbb5c0ff80.zip
security/linux-bitwarden-cli: Add a new port
The Bitwarden CLI is a powerful, full-featured command-line interface (CLI) tool to access and manage a Bitwarden vault. The CLI is written with TypeScript and Node.js and can be run on Windows, macOS, and Linux distributions. This port is using the Linux binary thanks to the Linux binary compatibility provided by FreeBSD. WWW: https://github.com/bitwarden/cli
-rw-r--r--security/Makefile1
-rw-r--r--security/linux-bitwarden-cli/Makefile34
-rw-r--r--security/linux-bitwarden-cli/distinfo3
-rw-r--r--security/linux-bitwarden-cli/pkg-descr7
4 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ca6e5b123dbc..dc3776f75379 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -338,6 +338,7 @@
SUBDIR += libwhisker
SUBDIR += libyubikey
SUBDIR += libzrtpcppcore
+ SUBDIR += linux-bitwarden-cli
SUBDIR += linux-c7-cyrus-sasl2
SUBDIR += linux-c7-gnutls
SUBDIR += linux-c7-libgcrypt
diff --git a/security/linux-bitwarden-cli/Makefile b/security/linux-bitwarden-cli/Makefile
new file mode 100644
index 000000000000..05e2252b843b
--- /dev/null
+++ b/security/linux-bitwarden-cli/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= bitwarden
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.18.1
+CATEGORIES= security linux
+MASTER_SITES= https://github.com/bitwarden/cli/releases/download/${DISTVERSIONFULL}/
+PKGNAMEPREFIX= linux-
+PKGNAMESUFFIX= -cli
+DISTNAME= bw-linux-${DISTVERSION}
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Bitwarden CLI
+
+LICENSE= GPLv3
+
+USES= linux zip
+
+# install(1) fails with the following messages when stripping:
+# strip: elf_update() failed: Layout constraint violation
+# strip: elf_update() failed: Layout constraint violation
+STRIP=
+
+NO_WRKSUBDIR= yes
+PLIST_FILES= bin/bw
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bw
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bw ${STAGEDIR}${PREFIX}/bin/
+
+do-test:
+ ${SETENV} ${TEST_ENV} ${STAGEDIR}${PREFIX}/bin/bw help >/dev/null
+
+.include <bsd.port.mk>
diff --git a/security/linux-bitwarden-cli/distinfo b/security/linux-bitwarden-cli/distinfo
new file mode 100644
index 000000000000..fdd330831719
--- /dev/null
+++ b/security/linux-bitwarden-cli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633604286
+SHA256 (bw-linux-1.18.1.zip) = e8713b1d0d75f41c5077bbbcb81fbc6536d95cdf919f702fe23a66ecdae979dd
+SIZE (bw-linux-1.18.1.zip) = 21351588
diff --git a/security/linux-bitwarden-cli/pkg-descr b/security/linux-bitwarden-cli/pkg-descr
new file mode 100644
index 000000000000..a1a99882456d
--- /dev/null
+++ b/security/linux-bitwarden-cli/pkg-descr
@@ -0,0 +1,7 @@
+The Bitwarden CLI is a powerful, full-featured command-line interface
+(CLI) tool to access and manage a Bitwarden vault. The CLI is written
+with TypeScript and Node.js and can be run on Windows, macOS, and Linux
+distributions. This port is using the Linux binary thanks to the Linux
+binary compatibility provided by FreeBSD.
+
+WWW: https://github.com/bitwarden/cli