aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-06-22 02:51:00 +0000
committerWen Heping <wen@FreeBSD.org>2023-06-22 02:53:52 +0000
commita96b9596e76ed06c74753857035cabcba724f63f (patch)
treee50f1b800c62babe3487d9167c1ed73f4c148818
parent43e248a61351a10229c13e90dd72801381e1f2ba (diff)
downloadports-a96b9596e76ed06c74753857035cabcba724f63f.tar.gz
ports-a96b9596e76ed06c74753857035cabcba724f63f.zip
print/py-PyMuPDF: New port
PyMuPDF adds Python bindings and abstractions to MuPDF, a lightweight PDF, XPS, and eBook viewer, renderer, and toolkit. Both PyMuPDF and MuPDF are maintained and developed by Artifex Software, Inc. MuPDF can access files in PDF, XPS, OpenXPS, CBZ, EPUB and FB2 (eBooks) formats, and it is known for its top performance and exceptional rendering quality. With PyMuPDF you can access files with extensions like .pdf, .xps, .oxps, .cbz, .fb2 or .epub. In addition, about 10 popular image formats can also be handled like documents: .png, .jpg, .bmp, .tiff, etc.
-rw-r--r--print/Makefile1
-rw-r--r--print/py-PyMuPDF/Makefile20
-rw-r--r--print/py-PyMuPDF/distinfo3
-rw-r--r--print/py-PyMuPDF/pkg-descr11
4 files changed, 35 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 4fef05467e81..c9e88310e4e4 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -170,6 +170,7 @@
SUBDIR += pslib
SUBDIR += pstotext
SUBDIR += psutils
+ SUBDIR += py-PyMuPDF
SUBDIR += py-collidoscope
SUBDIR += py-dehinter
SUBDIR += py-font-v
diff --git a/print/py-PyMuPDF/Makefile b/print/py-PyMuPDF/Makefile
new file mode 100644
index 000000000000..c554e634ac70
--- /dev/null
+++ b/print/py-PyMuPDF/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= PyMuPDF
+PORTVERSION= 1.22.5
+CATEGORIES= print python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Python bindings for the PDF toolkit and renderer MuPDF
+WWW= https://github.com/pymupdf/PyMuPDF
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= bash:shells/bash \
+ swig:devel/swig
+
+USES= gmake python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/print/py-PyMuPDF/distinfo b/print/py-PyMuPDF/distinfo
new file mode 100644
index 000000000000..6afed7c3ad0f
--- /dev/null
+++ b/print/py-PyMuPDF/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1687397187
+SHA256 (PyMuPDF-1.22.5.tar.gz) = 5ec8d5106752297529d0d68d46cfc4ce99914aabd99be843f1599a1842d63fe9
+SIZE (PyMuPDF-1.22.5.tar.gz) = 61638053
diff --git a/print/py-PyMuPDF/pkg-descr b/print/py-PyMuPDF/pkg-descr
new file mode 100644
index 000000000000..89a88a0d7b52
--- /dev/null
+++ b/print/py-PyMuPDF/pkg-descr
@@ -0,0 +1,11 @@
+PyMuPDF adds Python bindings and abstractions to MuPDF, a lightweight
+PDF, XPS, and eBook viewer, renderer, and toolkit. Both PyMuPDF and
+MuPDF are maintained and developed by Artifex Software, Inc.
+
+MuPDF can access files in PDF, XPS, OpenXPS, CBZ, EPUB and FB2 (eBooks)
+formats, and it is known for its top performance and exceptional rendering
+quality.
+
+With PyMuPDF you can access files with extensions like .pdf, .xps, .oxps,
+.cbz, .fb2 or .epub. In addition, about 10 popular image formats can also
+be handled like documents: .png, .jpg, .bmp, .tiff, etc.