aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-23 08:28:55 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-23 08:28:55 +0000
commita9c0d2f56dddf90d6741f1eb9b0ff7c1b7f99e73 (patch)
tree230ca4cc616e513c774e9cecff860c75ddee1a68
parent0f903a718f2d8b889adb47b087ad45270d390547 (diff)
downloadports-a9c0d2f56dddf90d6741f1eb9b0ff7c1b7f99e73.tar.gz
ports-a9c0d2f56dddf90d6741f1eb9b0ff7c1b7f99e73.zip
New port: textproc/fcitx-table-other: Table-based input methods for Fcitx
PR: 216971 Submitted by: Henry Hu <henry.hu.sh@gmail.com>
Notes
Notes: svn path=/head/; revision=470688
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/fcitx-table-other/Makefile21
-rw-r--r--textproc/fcitx-table-other/distinfo3
-rw-r--r--textproc/fcitx-table-other/files/patch-tables__CMakeLists.txt10
-rw-r--r--textproc/fcitx-table-other/pkg-descr5
-rw-r--r--textproc/fcitx-table-other/pkg-plist77
6 files changed, 117 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0bd7f2f32b44..a47159d333e2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -191,6 +191,7 @@
SUBDIR += fa-aspell
SUBDIR += fcitx-m17n
SUBDIR += fcitx-qt5
+ SUBDIR += fcitx-table-other
SUBDIR += fex
SUBDIR += ffe
SUBDIR += fi-aspell
diff --git a/textproc/fcitx-table-other/Makefile b/textproc/fcitx-table-other/Makefile
new file mode 100644
index 000000000000..a0b6cd533032
--- /dev/null
+++ b/textproc/fcitx-table-other/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= fcitx-table-other
+DISTVERSION= 0.2.3
+CATEGORIES= textproc
+MASTER_SITES= http://download.fcitx-im.org/${PORTNAME}/
+DIST_SUBDIR= fcitx
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Table-based input methods for Fcitx
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfcitx-config.so:chinese/fcitx
+
+USES= cmake:outsource gettext tar:xz
+NO_ARCH= yes
+STRIP= # ninja breaks without this: unknown target 'install/strip'
+
+.include <bsd.port.mk>
diff --git a/textproc/fcitx-table-other/distinfo b/textproc/fcitx-table-other/distinfo
new file mode 100644
index 000000000000..7f675e7a6632
--- /dev/null
+++ b/textproc/fcitx-table-other/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527062829
+SHA256 (fcitx/fcitx-table-other-0.2.3.tar.xz) = 9b782ae938f3ce95fbdd020af3bb272a804bb39eee38297ab3b7f49ba55ed889
+SIZE (fcitx/fcitx-table-other-0.2.3.tar.xz) = 233360
diff --git a/textproc/fcitx-table-other/files/patch-tables__CMakeLists.txt b/textproc/fcitx-table-other/files/patch-tables__CMakeLists.txt
new file mode 100644
index 000000000000..63a02339f408
--- /dev/null
+++ b/textproc/fcitx-table-other/files/patch-tables__CMakeLists.txt
@@ -0,0 +1,10 @@
+--- tables/CMakeLists.txt.orig 2017-02-10 04:01:32 UTC
++++ tables/CMakeLists.txt
+@@ -60,5 +60,5 @@ endforeach()
+
+ add_custom_target(table_data ALL DEPENDS ${MB_FILE})
+
+-install(FILES ${CONF_FILE} DESTINATION "${FCITX4_PREFIX}/share/fcitx/table")
+-install(FILES ${MB_FILE} DESTINATION "${FCITX4_PREFIX}/share/fcitx/table")
++install(FILES ${CONF_FILE} DESTINATION "share/fcitx/table")
++install(FILES ${MB_FILE} DESTINATION "share/fcitx/table")
diff --git a/textproc/fcitx-table-other/pkg-descr b/textproc/fcitx-table-other/pkg-descr
new file mode 100644
index 000000000000..0ae6505c6d88
--- /dev/null
+++ b/textproc/fcitx-table-other/pkg-descr
@@ -0,0 +1,5 @@
+fcitx-table-other provides some other tables for Fcitx, fork from
+ibus-table-others, scim-tables. Most of the table in this package is
+non-Chinese table. They are listed under /tables by language.
+
+WWW: https://fcitx-im.org/wiki/Fcitx
diff --git a/textproc/fcitx-table-other/pkg-plist b/textproc/fcitx-table-other/pkg-plist
new file mode 100644
index 000000000000..dbaacd669ea3
--- /dev/null
+++ b/textproc/fcitx-table-other/pkg-plist
@@ -0,0 +1,77 @@
+share/fcitx/imicon/amharic.png
+share/fcitx/imicon/arabic.png
+share/fcitx/imicon/cns11643.png
+share/fcitx/imicon/compose.png
+share/fcitx/imicon/emoji.png
+share/fcitx/imicon/ipa-x-sampa.png
+share/fcitx/imicon/latex.png
+share/fcitx/imicon/malayalam-phonetic.png
+share/fcitx/imicon/rustrad.png
+share/fcitx/imicon/tamil-remington.png
+share/fcitx/imicon/thai.png
+share/fcitx/imicon/translit-ua.png
+share/fcitx/imicon/translit.png
+share/fcitx/imicon/viqr.png
+share/fcitx/imicon/yawerty.png
+share/fcitx/table/amharic.conf
+share/fcitx/table/amharic.mb
+share/fcitx/table/arabic.conf
+share/fcitx/table/arabic.mb
+share/fcitx/table/cns11643.conf
+share/fcitx/table/cns11643.mb
+share/fcitx/table/compose.conf
+share/fcitx/table/compose.mb
+share/fcitx/table/emoji.conf
+share/fcitx/table/emoji.mb
+share/fcitx/table/ipa-x-sampa.conf
+share/fcitx/table/ipa-x-sampa.mb
+share/fcitx/table/latex.conf
+share/fcitx/table/latex.mb
+share/fcitx/table/malayalam-phonetic.conf
+share/fcitx/table/malayalam-phonetic.mb
+share/fcitx/table/rustrad.conf
+share/fcitx/table/rustrad.mb
+share/fcitx/table/tamil-remington.conf
+share/fcitx/table/tamil-remington.mb
+share/fcitx/table/thai.conf
+share/fcitx/table/thai.mb
+share/fcitx/table/translit-ua.conf
+share/fcitx/table/translit-ua.mb
+share/fcitx/table/translit.conf
+share/fcitx/table/translit.mb
+share/fcitx/table/viqr.conf
+share/fcitx/table/viqr.mb
+share/fcitx/table/yawerty.conf
+share/fcitx/table/yawerty.mb
+share/icons/hicolor/32x32/apps/fcitx-thai.png
+share/icons/hicolor/48x48/apps/fcitx-compose.png
+share/icons/hicolor/48x48/apps/fcitx-emoji.png
+share/icons/hicolor/48x48/apps/fcitx-ipa-x-sampa.png
+share/icons/hicolor/48x48/apps/fcitx-latex.png
+share/icons/hicolor/48x48/apps/fcitx-malayalam-phonetic.png
+share/icons/hicolor/48x48/apps/fcitx-rustrad.png
+share/icons/hicolor/48x48/apps/fcitx-tamil-remington.png
+share/icons/hicolor/48x48/apps/fcitx-translit-ua.png
+share/icons/hicolor/48x48/apps/fcitx-translit.png
+share/icons/hicolor/48x48/apps/fcitx-yawerty.png
+share/icons/hicolor/64x64/apps/fcitx-cns11643.png
+share/icons/hicolor/64x64/apps/fcitx-viqr.png
+share/locale/am/LC_MESSAGES/fcitx-table-other.mo
+share/locale/ar/LC_MESSAGES/fcitx-table-other.mo
+share/locale/bn/LC_MESSAGES/fcitx-table-other.mo
+share/locale/de/LC_MESSAGES/fcitx-table-other.mo
+share/locale/gu/LC_MESSAGES/fcitx-table-other.mo
+share/locale/hi/LC_MESSAGES/fcitx-table-other.mo
+share/locale/ja/LC_MESSAGES/fcitx-table-other.mo
+share/locale/kn/LC_MESSAGES/fcitx-table-other.mo
+share/locale/ml/LC_MESSAGES/fcitx-table-other.mo
+share/locale/ne/LC_MESSAGES/fcitx-table-other.mo
+share/locale/pa/LC_MESSAGES/fcitx-table-other.mo
+share/locale/ru/LC_MESSAGES/fcitx-table-other.mo
+share/locale/ta/LC_MESSAGES/fcitx-table-other.mo
+share/locale/te/LC_MESSAGES/fcitx-table-other.mo
+share/locale/th/LC_MESSAGES/fcitx-table-other.mo
+share/locale/uk/LC_MESSAGES/fcitx-table-other.mo
+share/locale/vi/LC_MESSAGES/fcitx-table-other.mo
+share/locale/zh_CN/LC_MESSAGES/fcitx-table-other.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx-table-other.mo