aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2023-04-29 16:17:50 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2023-05-01 17:57:00 +0000
commitaa8e84436551dc60423d0026cc198586fdcd82ea (patch)
treea38963f57c2e908d650d67bf4e40069830f54592
parent91f6e574f41de24fba4e332c390c3f4b3ebca942 (diff)
downloadports-aa8e84436551dc60423d0026cc198586fdcd82ea.tar.gz
ports-aa8e84436551dc60423d0026cc198586fdcd82ea.zip
Mk/bsd.gcc.mk: Add GCC 14
- Add USE_GCC=14, which introduces a dependency on lang/gcc14-devel. - Switch USE_GCC=13 from lang/gcc13-devel to lang/gcc13. Reviewed by: vishwin Approved by: gerald (maintainer) Differential Revision: https://reviews.freebsd.org/D39878
-rw-r--r--Mk/bsd.gcc.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index ef3cb5a436e1..ec8804fa3c09 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -35,7 +35,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by this framework.
#
# When updating this, keep Mk/bsd.default-versions.mk in sync.
-GCCVERSIONS= 4.8 8 9 10 11 12 13
+GCCVERSIONS= 4.8 8 9 10 11 12 13 14
# No configurable parts below this. ####################################
#
@@ -85,7 +85,7 @@ IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
# A concrete version has been selected. Set proper ports dependencies,
# CC, CXX, CPP, and flags.
V:= ${_USE_GCC:S/.//}
-. if ${V} == 13
+. if ${V} == 14
_GCC_PORT:= gcc${V}-devel
. else
_GCC_PORT:= gcc${V}