aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-19 16:04:12 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-08-19 16:04:12 +0000
commitaba5c00978ab2987d929b7bdc233b5ea186ace15 (patch)
tree406b1a1f4d79333d5edb88055428c305adcfd2d9
parent4de391bd32d8c3b6bbe34bcf4b46536157e7212e (diff)
downloadports-aba5c00978ab2987d929b7bdc233b5ea186ace15.tar.gz
ports-aba5c00978ab2987d929b7bdc233b5ea186ace15.zip
devel/upp: add support for powerpc64*
-rw-r--r--devel/upp/Makefile3
-rw-r--r--devel/upp/files/patch-uppsrc_Core_config.h19
2 files changed, 21 insertions, 1 deletions
diff --git a/devel/upp/Makefile b/devel/upp/Makefile
index 66162e005285..eddfabbd7a2e 100644
--- a/devel/upp/Makefile
+++ b/devel/upp/Makefile
@@ -16,7 +16,8 @@ BROKEN_powerpc= Does not compile on ${ARCH}: error Unknown CPU architecture
BROKEN_powerpc64= Does not compile on ${ARCH}: error Unknown CPU architecture
BROKEN_sparc64= Does not compile on ${ARCH}
-USES= compiler:c++14-lang pkgconfig:both tar:xz
+USES= compiler:c++14-lang dos2unix pkgconfig:both tar:xz
+DOS2UNIX_FILES= uppsrc/Core/config.h
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/upp/files/patch-uppsrc_Core_config.h b/devel/upp/files/patch-uppsrc_Core_config.h
new file mode 100644
index 000000000000..475ac86a8fff
--- /dev/null
+++ b/devel/upp/files/patch-uppsrc_Core_config.h
@@ -0,0 +1,19 @@
+--- uppsrc/Core/config.h.orig 2023-08-19 14:40:16 UTC
++++ uppsrc/Core/config.h
+@@ -139,6 +139,16 @@
+ #define _HAVE_NO_STDWSTRING 1
+ //BF toolchain has no support for __thread (TLS), so U++ Heap not possible
+ #define flagUSEMALLOC
++ #elif __powerpc64__
++ #define CPU_64 1
++ #define CPU_UNALIGNED 1
++ #if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++ #define CPU_LE 1
++ #define CPU_LITTLE_ENDIAN 1
++ #else
++ #define CPU_BE 1
++ #define CPU_BIG_ENDIAN 1
++ #endif
+ #else
+ #error Unknown CPU architecture
+ #endif