aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 03:47:11 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2016-01-13 03:47:11 +0000
commitac82ab059117fd64b788e531870d5f4b6d0d8d4f (patch)
tree61fb583c831544e6de5fc0080b9772666399f147
parent3da75467c686058c5ee66b5447231fc1b7720bdf (diff)
downloadports-ac82ab059117fd64b788e531870d5f4b6d0d8d4f.tar.gz
ports-ac82ab059117fd64b788e531870d5f4b6d0d8d4f.zip
- New port math/octave-forge-tisean.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts.
Notes
Notes: svn path=/head/; revision=406003
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-tisean/Makefile30
-rw-r--r--math/octave-forge-tisean/distinfo2
-rw-r--r--math/octave-forge-tisean/pkg-descr11
-rw-r--r--math/octave-forge-tisean/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c0de78dce0e1..5a3873084442 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -389,6 +389,7 @@
SUBDIR += octave-forge-symband
SUBDIR += octave-forge-symbolic
SUBDIR += octave-forge-tcl-octave
+ SUBDIR += octave-forge-tisean
SUBDIR += octave-forge-tsa
SUBDIR += octave-forge-video
SUBDIR += octave-forge-xraylib
diff --git a/math/octave-forge-tisean/Makefile b/math/octave-forge-tisean/Makefile
new file mode 100644
index 000000000000..cd68acc029d9
--- /dev/null
+++ b/math/octave-forge-tisean/Makefile
@@ -0,0 +1,30 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-tisean
+PORTVERSION= 0.2.3
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/signal.tar.gz:${PORTSDIR}/math/octave-forge-signal
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+GNU_CONFIGURE= yes
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-tisean/distinfo b/math/octave-forge-tisean/distinfo
new file mode 100644
index 000000000000..fa98c05dbf80
--- /dev/null
+++ b/math/octave-forge-tisean/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/tisean-0.2.3.tar.gz) = bbc94ea6af663092863a437f88215e84d3a59a60b9f51f6ffd9dbe90606a8259
+SIZE (octave-forge/tisean-0.2.3.tar.gz) = 715494
diff --git a/math/octave-forge-tisean/pkg-descr b/math/octave-forge-tisean/pkg-descr
new file mode 100644
index 000000000000..5cd09e6f081b
--- /dev/null
+++ b/math/octave-forge-tisean/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is tisean.
+
+ Port of TISEAN 3.0.1, which does nonlinear time series analysis. See
+ http://www.mpipks-dresden.mpg.de/~tisean/
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-tisean/pkg-plist b/math/octave-forge-tisean/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-tisean/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty