aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-01-10 16:55:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-01-10 16:55:26 +0000
commitac922c592e54939a66a352d951260ab2c1fd4c05 (patch)
treea1803c12d7ed1ddd17231d7c51bd8ecd19c12c72
parentb48e96822e2e62dc4e55d3c7680ea952dc34c9bb (diff)
downloadports-ac922c592e54939a66a352d951260ab2c1fd4c05.tar.gz
ports-ac922c592e54939a66a352d951260ab2c1fd4c05.zip
Convert g* and i* to USES=sqlite and USES=firebird
Notes
Notes: svn path=/head/; revision=405724
-rw-r--r--games/crossfire-server/Makefile3
-rw-r--r--games/flightgear/Makefile4
-rw-r--r--games/freeciv/Makefile3
-rw-r--r--games/gcompris/Makefile3
-rw-r--r--games/kajongg/Makefile3
-rw-r--r--games/latrine/Makefile3
-rw-r--r--games/lightsoff/Makefile3
-rw-r--r--games/stonesoup/Makefile3
-rw-r--r--games/stratagus/Makefile3
-rw-r--r--games/wyrmgus/Makefile3
-rw-r--r--games/xmoto/Makefile3
-rw-r--r--graphics/colord-gtk/Makefile3
-rw-r--r--graphics/colord/Makefile3
-rw-r--r--graphics/darktable/Makefile3
-rw-r--r--graphics/libchamplain/Makefile3
-rw-r--r--graphics/libchamplain08/Makefile3
-rw-r--r--graphics/osgearth/Makefile3
-rw-r--r--graphics/qgis/Makefile3
-rw-r--r--graphics/rawstudio/Makefile4
-rw-r--r--graphics/shotwell/Makefile4
-rw-r--r--irc/anope/Makefile2
-rw-r--r--irc/inspircd/Makefile3
-rw-r--r--irc/ircd-ratbox-devel/Makefile3
-rw-r--r--irc/ircd-ratbox/Makefile3
-rw-r--r--irc/ratbox-services/Makefile2
25 files changed, 28 insertions, 48 deletions
diff --git a/games/crossfire-server/Makefile b/games/crossfire-server/Makefile
index 5981e9d1aaba..620dd4d56ce4 100644
--- a/games/crossfire-server/Makefile
+++ b/games/crossfire-server/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= gmake libtool localbase perl5 python uidfix
-USE_SQLITE= 3
+USES= gmake libtool localbase perl5 python sqlite uidfix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --with-check=no --localstatedir=/var/games
CONFIGURE_SHELL=${LOCALBASE}/bin/bash
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index feef29f581c1..e1c9ec7dc628 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -30,10 +30,10 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
USE_XORG= ice sm x11 xext xft xi xinerama xt xmu
USE_GL= gl glu glut
-USE_SQLITE= 3
USE_QT5= core buildtools qmake widgets
-USES= alias cpe dos2unix cmake compiler jpeg openal:al,alut tar:bzip2
+USES= alias cpe dos2unix cmake compiler jpeg openal:al,alut sqlite \
+ tar:bzip2
DOS2UNIX_REGEX= .*\.(c|h|cxx|cpp|hxx|hpp)
CMAKE_ARGS+= -DENABLE_JS_SERVER:BOOL=ON \
-DSYSTEM_SQLITE:BOOL=ON \
diff --git a/games/freeciv/Makefile b/games/freeciv/Makefile
index e255991b9a62..f86de1e3d13b 100644
--- a/games/freeciv/Makefile
+++ b/games/freeciv/Makefile
@@ -13,8 +13,7 @@ RUN_DEPENDS= hicolor-icon-theme>=0:${PORTSDIR}/misc/hicolor-icon-theme
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
libcurl.so:${PORTSDIR}/ftp/curl
-USES= gettext gmake iconv libtool pkgconfig tar:bzip2 python
-USE_SQLITE= yes
+USES= gettext gmake iconv libtool pkgconfig tar:bzip2 python sqlite
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/gcompris/Makefile b/games/gcompris/Makefile
index 8acb913fd686..6d5444aa33f0 100644
--- a/games/gcompris/Makefile
+++ b/games/gcompris/Makefile
@@ -22,11 +22,10 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
gnucap:${PORTSDIR}/cad/gnucap
USES= display:configure gettext gmake libtool pathfix pkgconfig \
- python:2 shebangfix tar:bzip2
+ python:2 shebangfix sqlite tar:bzip2
SHEBANG_FILES= boards/voices/*.sh
GNU_CONFIGURE= yes
USE_GSTREAMER= yes
-USE_SQLITE= 3
USE_SDL= mixer
USE_GNOME= intlhack gnomeprefix gtk20 pygtk2 libxml2 librsvg2
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/kajongg/Makefile b/games/kajongg/Makefile
index a1b8be22498c..d6f15f82b006 100644
--- a/games/kajongg/Makefile
+++ b/games/kajongg/Makefile
@@ -10,10 +10,9 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= ${${PORTNAME}_DESC}
-USES= cmake:outsource python tar:xz twisted:run
+USES= cmake:outsource python tar:xz twisted:run sqlite
USE_KDE4= kdelibs kdeprefix pykde4 automoc4
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_SQLITE= 3
USE_TWISTED_RUN= yes
CMAKE_ARGS= -DINSTALL_KAJONGG:BOOL=TRUE
diff --git a/games/latrine/Makefile b/games/latrine/Makefile
index 8b0aa74c7b01..d10b104d8d8f 100644
--- a/games/latrine/Makefile
+++ b/games/latrine/Makefile
@@ -19,9 +19,8 @@ BUILD_DEPENDS= p5-DBI>0:${PORTSDIR}/databases/p5-DBI
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_CSTD= gnu89
-USE_SQLITE= 3
USE_PERL5= build
-USES= gettext gmake ncurses perl5
+USES= gettext gmake ncurses perl5 sqlite
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D_XOPEN_SOURCE_EXTENDED
diff --git a/games/lightsoff/Makefile b/games/lightsoff/Makefile
index 5b4c67f980f7..cf790785961b 100644
--- a/games/lightsoff/Makefile
+++ b/games/lightsoff/Makefile
@@ -16,12 +16,11 @@ LIB_DEPENDS= libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3
PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig tar:xz
+USES= gettext gmake pathfix pkgconfig sqlite tar:xz
USE_GNOME= gtk30 intlhack librsvg2 libxml2:build
INSTALLS_ICONS= yes
USE_XORG= x11
USE_GL= gl
-USE_SQLITE= 3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index 70345eb94a81..68cd0f0c02bb 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -14,9 +14,8 @@ COMMENT= Dungeon Crawl Stone Soup - a fun, free rogue-like game
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../licence.txt
-USE_SQLITE= yes
USES= bison compiler:c++11-lib gmake lua:51 perl5 pkgconfig \
- shebangfix tar:xz
+ shebangfix sqlite tar:xz
USE_PERL5= build
SHEBANG_FILES= util/gen-mi-enum \
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 93345c27e954..27675656e085 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -18,8 +18,7 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
USE_GL= gl glu
USE_SDL= sdl
-USE_SQLITE= 3
-USES= cmake:outsource lua:51 pkgconfig
+USES= cmake:outsource lua:51 pkgconfig sqlite
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="tolua++-${LUA_VER}" \
-DTOLUA++_INCLUDE_DIR:STRING="${LUA_INCDIR}" \
diff --git a/games/wyrmgus/Makefile b/games/wyrmgus/Makefile
index e62534741449..50e56b208a6f 100644
--- a/games/wyrmgus/Makefile
+++ b/games/wyrmgus/Makefile
@@ -21,8 +21,7 @@ GH_PROJECT= Wyrmgus
USE_GL= gl glu
USE_SDL= sdl
-USE_SQLITE= 3
-USES= compiler:c++11-lib cmake:outsource lua:51 pkgconfig
+USES= compiler:c++11-lib cmake:outsource lua:51 pkgconfig sqlite
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="tolua++-${LUA_VER}" \
-DTOLUA++_INCLUDE_DIR:STRING="${LUA_INCDIR}" \
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 3dee737bfa94..2741be4150a1 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -21,9 +21,8 @@ LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= compiler:features dos2unix gmake jpeg lua:51
+USES= compiler:features dos2unix gmake jpeg lua:51 sqlite
USE_GNOME= libxml2
-USE_SQLITE= 3
USE_SDL= sdl mixer ttf net
USE_GL= gl glu
DOS2UNIX_GLOB= *.cpp *.h
diff --git a/graphics/colord-gtk/Makefile b/graphics/colord-gtk/Makefile
index 4ab5859825c8..da8372fce2d1 100644
--- a/graphics/colord-gtk/Makefile
+++ b/graphics/colord-gtk/Makefile
@@ -16,8 +16,7 @@ LIB_DEPENDS= libcolord.so:${PORTSDIR}/graphics/colord \
liblcms2.so:${PORTSDIR}/graphics/lcms2
USE_GNOME= gtk30 intlhack introspection:build
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_SQLITE= 3
+USES= gettext gmake libtool pathfix pkgconfig sqlite tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-gtk-doc-html=no
diff --git a/graphics/colord/Makefile b/graphics/colord/Makefile
index f5ec247eec2b..8713dc825305 100644
--- a/graphics/colord/Makefile
+++ b/graphics/colord/Makefile
@@ -18,9 +18,8 @@ RUN_DEPENDS= spotread:${PORTSDIR}/graphics/argyllcms
USERS= colord
GROUPS= colord
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake libtool pathfix pkgconfig sqlite tar:xz
USE_GNOME= glib20 intlhack introspection:build
-USE_SQLITE= 3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 2bb77cbae3ba..8a20259d4310 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -21,9 +21,8 @@ ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE instructions
USES= compiler:c++11-lib cmake:outsource desktop-file-utils \
- ninja pkgconfig tar:xz
+ ninja pkgconfig sqlite tar:xz
USE_GNOME= gtk20 intltool librsvg2
-USE_SQLITE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib -lintl
diff --git a/graphics/libchamplain/Makefile b/graphics/libchamplain/Makefile
index 3663d1b0f9ac..933cc341fd4d 100644
--- a/graphics/libchamplain/Makefile
+++ b/graphics/libchamplain/Makefile
@@ -12,10 +12,9 @@ COMMENT= C library aimed to provide a Gtk+ widget to display rasterized maps and
LIB_DEPENDS= libclutter-gtk-1.0.so:${PORTSDIR}/graphics/clutter-gtk3 \
libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
-USES= gmake libtool pathfix pkgconfig tar:xz
+USES= gmake libtool pathfix pkgconfig sqlite tar:xz
USE_GNOME= gtk30 introspection:build
USE_GL= gl
-USE_SQLITE= 3
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/libchamplain08/Makefile b/graphics/libchamplain08/Makefile
index 7bf626c84ef5..041a37470f44 100644
--- a/graphics/libchamplain08/Makefile
+++ b/graphics/libchamplain08/Makefile
@@ -14,9 +14,8 @@ COMMENT= C library provides a Gtk+ widget to display rasterized maps/markers
LIB_DEPENDS= libclutter-gtk-0.10.so:${PORTSDIR}/graphics/clutter-gtk \
libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
-USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= gmake libtool:keepla pathfix pkgconfig sqlite tar:bzip2
USE_GNOME= gnomeprefix gtk20 introspection:build,run
-USE_SQLITE= 3
USE_GL= gl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/graphics/osgearth/Makefile b/graphics/osgearth/Makefile
index fcd9844ce038..5cd9fda7b392 100644
--- a/graphics/osgearth/Makefile
+++ b/graphics/osgearth/Makefile
@@ -21,8 +21,7 @@ USE_GITHUB= yes
GH_ACCOUNT= gwaldron
USE_LDCONFIG= YES
-USE_SQLITE= 3
-USES= cmake gmake pkgconfig
+USES= cmake gmake pkgconfig sqlite
PLIST_SUB= OSGVERSION=3.2.1
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:PATH=${LOCALBASE}/include \
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index df5548230da1..21ba1c12d078 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -25,8 +25,7 @@ USE_GITHUB= yes
GH_PROJECT= ${PORTNAME:tu}
GH_TAGNAME= B403532
-USES= cpe bison cmake execinfo fortran gmake python
-USE_SQLITE= yes
+USES= cpe bison cmake execinfo fortran gmake sqlite python
USE_QT4= gui svg xml network sql designer testlib linguist_build \
qmake_build moc_build rcc_build uic_build
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
index d5d1a7a9d45b..8462fe46260d 100644
--- a/graphics/rawstudio/Makefile
+++ b/graphics/rawstudio/Makefile
@@ -22,10 +22,10 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
-USES= desktop-file-utils gettext gmake jpeg libtool pathfix pkgconfig
+USES= desktop-file-utils gettext gmake jpeg libtool pathfix pkgconfig \
+ sqlite
GNU_CONFIGURE= yes
USE_GNOME= gtk20 libxml2 gconf2
-USE_SQLITE= 3
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index bb0463972bfc..3bde349e9831 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -27,9 +27,9 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libraw.so:${PORTSDIR}/graphics/libraw \
librest-0.7.so:${PORTSDIR}/devel/librest
-USES= shebangfix gettext desktop-file-utils gmake pkgconfig tar:xz
+USES= shebangfix gettext desktop-file-utils gmake pkgconfig sqlite \
+ tar:xz
USE_GNOME= dconf gtk30 gnomedocutils
-USE_SQLITE= 3
USE_GSTREAMER1= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --disable-icon-update
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index d35d7fe164ba..8ac913f2a56d 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -83,7 +83,7 @@ PLIST_SUB+= SASL="@comment "
.if ${PORT_OPTIONS:MSQLITE}
PLIST_SUB+= SQLITE=""
-USE_SQLITE= yes
+USES+= sqlite
.else
PLIST_SUB+= SQLITE="@comment "
.endif
diff --git a/irc/inspircd/Makefile b/irc/inspircd/Makefile
index e29561f2972b..44053b32750f 100644
--- a/irc/inspircd/Makefile
+++ b/irc/inspircd/Makefile
@@ -96,8 +96,7 @@ PLIST_SUB+= PGSQL="@comment "
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USES+= pkgconfig
-USE_SQLITE= 3
+USES+= pkgconfig sqlite
EXTRAS:=${EXTRAS},m_sqlite3.cpp
PLIST_SUB+= SQLITE=""
.else
diff --git a/irc/ircd-ratbox-devel/Makefile b/irc/ircd-ratbox-devel/Makefile
index 0e451087c556..e655ebb15554 100644
--- a/irc/ircd-ratbox-devel/Makefile
+++ b/irc/ircd-ratbox-devel/Makefile
@@ -16,9 +16,8 @@ LICENSE= GPLv2
CONFLICTS= ircd-ratbox-[0-9]* charybdis-[0-9]*
-USES= libtool perl5 tar:bzip2
+USES= libtool perl5 sqlite tar:bzip2
USE_RC_SUBR= ircd-ratbox
-USE_SQLITE= 3
USE_PERL5= build
USE_LDCONFIG= ${PREFIX}/lib/ircd-ratbox
diff --git a/irc/ircd-ratbox/Makefile b/irc/ircd-ratbox/Makefile
index a0eec2d6d810..4ec75e3c8133 100644
--- a/irc/ircd-ratbox/Makefile
+++ b/irc/ircd-ratbox/Makefile
@@ -15,10 +15,9 @@ LICENSE= GPLv2
CONFLICTS= ircd-ratbox-devel-[0-9]* charybdis-[0-9]*
-USES= cpe libtool tar:bzip2
+USES= cpe libtool SQLITE tar:bzip2
CPE_VENDOR= ratbox
USE_RC_SUBR= ircd-ratbox
-USE_SQLITE= 3
USE_LDCONFIG= ${PREFIX}/lib/ircd-ratbox
MAKE_JOBS_UNSAFE= yes
diff --git a/irc/ratbox-services/Makefile b/irc/ratbox-services/Makefile
index 21ddeebd0ffe..b6e5c690658c 100644
--- a/irc/ratbox-services/Makefile
+++ b/irc/ratbox-services/Makefile
@@ -109,7 +109,7 @@ CONFIGURE_ARGS+= --disable-memoserv
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= 3
+USES+= sqlite
CONFIGURE_ARGS+= --enable-sqlite3=${LOCALBASE}
.endif