aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-07-11 05:18:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-09-02 23:27:46 +0000
commitad1d79583b285d7a320f7a8b844bc568142670e0 (patch)
tree94a8d2aeb004eaf4f14e23db2df0717a73a5b4b3
parentecbb1b3e7a457b9a3098245fdb22f61ae75a9832 (diff)
downloadports-ad1d79583b285d7a320f7a8b844bc568142670e0.tar.gz
ports-ad1d79583b285d7a320f7a8b844bc568142670e0.zip
games/punchy: unbreak build on i386
fatal runtime error: Rust cannot catch foreign exceptions thread '<unnamed>' panicked at '/wrkdirs/usr/ports/lang/rust/work/rustc-1.70.0-src/compiler/rustc_codegen_ssa/src/back/write.rs:1535:21: worker thread panicked', compiler/rustc_middle/src/util/bug.rs:36:26 (signal: 6, SIGABRT: process abort signal) Reported by: pkg-fallout
-rw-r--r--games/punchy/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/games/punchy/Makefile b/games/punchy/Makefile
index 6dbb69a40957..bdce929c35f4 100644
--- a/games/punchy/Makefile
+++ b/games/punchy/Makefile
@@ -29,6 +29,12 @@ BINARY_ALIAS+= python=${PYTHON_CMD}
CARGO_ENV+= V8_FROM_SOURCE=1 CLANG_BASE_PATH="/usr" GN_ARGS='${GN_ARGS}'
GN_ARGS+= use_custom_libcxx=false
+.if ${MACHINE_ARCH} == i386
+# https://github.com/rust-lang/rust/issues/85598
+LTO_UNSAFE= yes
+CARGO_ENV+= CARGO_PROFILE_RELEASE_LTO=false
+.endif
+
post-patch:
# Search assets under PREFIX instead of current directory
@${REINPLACE_CMD} 's,assets",../${DATADIR_REL}/&,' \