aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-04-13 10:16:11 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-04-13 10:17:32 +0000
commitad4faa6d3c97eb019e634d7cdb1cae8460934a84 (patch)
tree880fbea1306bd64b79665c70e3df8bf0a67310d8
parent23e199b8a5cd6bf5172e963795fecfb116df36d1 (diff)
downloadports-ad4faa6d3c97eb019e634d7cdb1cae8460934a84.tar.gz
ports-ad4faa6d3c97eb019e634d7cdb1cae8460934a84.zip
lang/php81: Update version 8.1.27=>8.1.28
-rw-r--r--devel/php81-intl/Makefile1
-rw-r--r--lang/php81/Makefile64
-rw-r--r--lang/php81/distinfo6
3 files changed, 34 insertions, 37 deletions
diff --git a/devel/php81-intl/Makefile b/devel/php81-intl/Makefile
index 9b26b350679d..1ccc80b52ca4 100644
--- a/devel/php81-intl/Makefile
+++ b/devel/php81-intl/Makefile
@@ -1,4 +1,3 @@
-PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php81
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 5e614b7d0118..346a0360ec9e 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -1,6 +1,6 @@
PORTNAME= php81
-DISTVERSION= 8.1.27
-PORTREVISION?= 1
+DISTVERSION= 8.1.28
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
@@ -24,15 +24,15 @@ CONFLICTS_INSTALL?= php[0-9][0-9]${PKGNAMESUFFIX}
LIB_DEPENDS= libargon2.so:security/libargon2 \
libpcre2-8.so:devel/pcre2
-GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
-CONFIGURE_ARGS+= --disable-all \
- --program-prefix="" \
- --with-config-file-scan-dir=${PREFIX}/etc/php \
- --with-layout=GNU \
- --with-libxml \
- --with-openssl \
- --with-password-argon2=${LOCALBASE}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= \
+ --disable-all \
+ --program-prefix="" \
+ --with-config-file-scan-dir=${PREFIX}/etc/php \
+ --with-layout=GNU \
+ --with-libxml \
+ --with-openssl \
+ --with-password-argon2=${LOCALBASE}
USES+= autoreconf:build ssl
USE_GNOME= libxml2
@@ -41,9 +41,9 @@ LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
# PR230207 Allow relocations against read-only segments (override lld default)
LDFLAGS_i386+= -Wl,-z,notext
-OPTIONS_DEFINE+= CGI CLI DEBUG DTRACE EMBED FPM IPV6 LINKTHR \
+OPTIONS_DEFINE+=CGI CLI DEBUG DTRACE EMBED FPM IPV6 LINKTHR \
MYSQLND PCRE PHPDBG ZTS
-OPTIONS_DEFAULT= CGI CLI DTRACE EMBED FPM LINKTHR MYSQLND PCRE
+OPTIONS_DEFAULT= CGI CLI DTRACE EMBED FPM LINKTHR MYSQLND PCRE
OPTIONS_EXCLUDE_DragonFly= DTRACE
# ld(1) fails to link probes: Relocations in generic ELF (EM: 0)
OPTIONS_EXCLUDE_aarch64= DTRACE
@@ -92,7 +92,7 @@ PHPDBG_VARS= PHP_SAPI+=phpdbg
ZTS_CONFIGURE_ON= --enable-zts
ZTS_CONFIGURE_ENV= pthreads_working="yes"
-DESTDIRNAME= INSTALL_ROOT
+DESTDIRNAME= INSTALL_ROOT
.if defined(PKGNAMEPREFIX)
USES+= apache
@@ -153,19 +153,20 @@ post-install:
${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
post-install-CGI-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/php-cgi
-
-post-install-PHPDBG-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/phpdbg
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/php-cgi
post-install-CLI-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/php
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/php
+
+post-install-EMBED-on:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libphp.so
post-install-FPM-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/php-fpm
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/php-fpm
+
+post-install-PHPDBG-on:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/phpdbg
-post-install-EMBED-on:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libphp.so
.else
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
@@ -256,9 +257,9 @@ USE_GNOME= libxml2
.endif
.if ${PHP_MODNAME} == "enchant"
-LIB_DEPENDS+= libenchant-2.so:textproc/enchant2
-CONFIGURE_ARGS+= --with-enchant=${LOCALBASE}
-USES+= pkgconfig
+LIB_DEPENDS+= libenchant-2.so:textproc/enchant2
+CONFIGURE_ARGS+=--with-enchant=${LOCALBASE}
+USES+= pkgconfig
.endif
.if ${PHP_MODNAME} == "exif"
@@ -361,8 +362,7 @@ BUILD_DEPENDS= re2c:devel/re2c
.endif
.if ${PHP_MODNAME} == "ldap"
-CONFIGURE_ARGS+= --with-ldap-sasl=${LOCALBASE} \
- --with-ldap=${LOCALBASE}
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE} --with-ldap-sasl=${LOCALBASE}
USES+= ldap
.endif
@@ -393,8 +393,7 @@ MYSQLND_USES_OFF= mysql
.if ${PHP_MODNAME} == "odbc"
LIB_DEPENDS+= libodbc.so:databases/unixODBC
-CONFIGURE_ARGS+= --enable-odbc \
- --with-unixODBC=${LOCALBASE}
+CONFIGURE_ARGS+= --enable-odbc --with-unixODBC=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "opcache"
@@ -487,8 +486,8 @@ CONFIGURE_ARGS+= --with-pspell=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "readline"
-CONFIGURE_ARGS+= --with-libedit
-USES+= libedit
+CONFIGURE_ARGS+=--with-libedit
+USES+= libedit
.endif
.if ${PHP_MODNAME} == "session"
@@ -604,8 +603,7 @@ USE_PHP= dom:build xml:build
.if ${PHP_MODNAME} == "zip"
LIB_DEPENDS+= libzip.so:archivers/libzip
-CONFIGURE_ARGS+= --with-zip \
- --with-zlib-dir=/usr
+CONFIGURE_ARGS+= --with-zip --with-zlib-dir=/usr
USES+= pkgconfig
.endif
diff --git a/lang/php81/distinfo b/lang/php81/distinfo
index 02839706ac95..c0beb444ed21 100644
--- a/lang/php81/distinfo
+++ b/lang/php81/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1703153725
-SHA256 (php-8.1.27.tar.xz) = 479e65c3f05714d4aace1370e617d78e49e996ec7a7579a5be47535be61f0658
-SIZE (php-8.1.27.tar.xz) = 11915228
+TIMESTAMP = 1713000963
+SHA256 (php-8.1.28.tar.xz) = 95d0b2e9466108fd750dab5c30a09e5c67f5ad2cb3b1ffb3625a038a755ad080
+SIZE (php-8.1.28.tar.xz) = 11848504