aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-16 18:36:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-07-16 18:36:15 +0000
commitad7289ae0d3a6c7075e031ce251ad76782eb6dee (patch)
treeaa274cae110bc84a1e9d6b0cc57ee3c1e99254b0
parent7d75638dd9f8666e78cf44f4e8234ef41c14107b (diff)
downloadports-ad7289ae0d3a6c7075e031ce251ad76782eb6dee.tar.gz
ports-ad7289ae0d3a6c7075e031ce251ad76782eb6dee.zip
devel/googletest: Update to 1.15.0
- Update MASTER_SITES: use upstream release tarball - Use USES=pathfix to fix .pc installation - Bump PORTREVISION of dependent ports for shlib change Changes: https://github.com/google/googletest/releases
-rw-r--r--astro/phd2/Makefile2
-rw-r--r--benchmarks/apib/Makefile2
-rw-r--r--databases/arrow/Makefile2
-rw-r--r--devel/android-tools/Makefile2
-rw-r--r--devel/ayatana-ido/Makefile1
-rw-r--r--devel/binaryen/Makefile1
-rw-r--r--devel/googletest/Makefile10
-rw-r--r--devel/googletest/distinfo6
-rw-r--r--devel/libayatana-indicator/Makefile2
-rw-r--r--devel/opentelemetry-cpp/Makefile1
-rw-r--r--graphics/brunsli/Makefile2
-rw-r--r--graphics/exiv2/Makefile1
-rw-r--r--graphics/partio/Makefile2
-rw-r--r--lang/cling/Makefile2
-rw-r--r--math/verdict/Makefile2
-rw-r--r--multimedia/kodi/Makefile2
-rw-r--r--net-im/tdlib-purple/Makefile2
-rw-r--r--net-p2p/ethash/Makefile2
-rw-r--r--science/orthanc/Makefile1
-rw-r--r--x11-fonts/ots/Makefile2
20 files changed, 25 insertions, 22 deletions
diff --git a/astro/phd2/Makefile b/astro/phd2/Makefile
index a5413ccac55c..4aa54e37ad6f 100644
--- a/astro/phd2/Makefile
+++ b/astro/phd2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= phd2
DISTVERSIONPREFIX=v
DISTVERSION= 2.6.10
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= astro
MAINTAINER= acm@FreeBSD.org
diff --git a/benchmarks/apib/Makefile b/benchmarks/apib/Makefile
index 87a61ba740b4..f992eddfaa7a 100644
--- a/benchmarks/apib/Makefile
+++ b/benchmarks/apib/Makefile
@@ -2,7 +2,7 @@ PORTNAME= apib
DISTVERSIONPREFIX= ${PORTNAME:tu}_
DISTVERSION= 1_2_1
DISTVERSIONSUFFIX= _RC1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= benchmarks www
MAINTAINER= danfe@FreeBSD.org
diff --git a/databases/arrow/Makefile b/databases/arrow/Makefile
index 29d8c3dac089..948624c85b6e 100644
--- a/databases/arrow/Makefile
+++ b/databases/arrow/Makefile
@@ -1,6 +1,6 @@
PORTNAME= arrow
DISTVERSION= 15.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= APACHE/${PORTNAME}/${PORTNAME}-${DISTVERSION} \
https://github.com/apache/orc/archive/rel/:orc
diff --git a/devel/android-tools/Makefile b/devel/android-tools/Makefile
index 59cf21284629..b974dd892e57 100644
--- a/devel/android-tools/Makefile
+++ b/devel/android-tools/Makefile
@@ -1,6 +1,6 @@
PORTNAME= android-tools
PORTVERSION= 31.0.3p2.0
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= devel
MASTER_SITES= GH
diff --git a/devel/ayatana-ido/Makefile b/devel/ayatana-ido/Makefile
index bf7242e74bbc..b7f14597a4cf 100644
--- a/devel/ayatana-ido/Makefile
+++ b/devel/ayatana-ido/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ayatana-ido
PORTVERSION= 0.10.2
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= jgh@FreeBSD.org
diff --git a/devel/binaryen/Makefile b/devel/binaryen/Makefile
index 1af0b8b1e6d9..dfd20489d3cb 100644
--- a/devel/binaryen/Makefile
+++ b/devel/binaryen/Makefile
@@ -1,6 +1,7 @@
PORTNAME= binaryen
DISTVERSIONPREFIX= version_
DISTVERSION= 118
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= eduardo@FreeBSD.org
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index 64cc036fc874..976976af712f 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -1,7 +1,7 @@
PORTNAME= googletest
-PORTVERSION= 1.14.0
-DISTVERSIONPREFIX= v
+PORTVERSION= 1.15.0
CATEGORIES= devel
+MASTER_SITES= https://github.com/google/googletest/releases/download/v${PORTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Framework for writing C++ tests on a variety of platforms
@@ -11,7 +11,7 @@ WWW= https://google.github.io/googletest/ \
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cmake:testing compiler:c++14-lang python:test
+USES= cmake:testing compiler:c++14-lang pathfix python:test
CMAKE_OFF= GTEST_HAS_ABSL \
gmock_build_tests \
@@ -23,11 +23,9 @@ CMAKE_ON= BUILD_GMOCK \
BUILD_SHARED_LIBS \
INSTALL_GTEST
CMAKE_TESTING_ON= gmock_build_tests gtest_build_tests
+PATHFIX_CMAKELISTSTXT= internal_utils.cmake
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
-USE_GITHUB= yes
-GH_ACCOUNT= google
-
.include <bsd.port.mk>
diff --git a/devel/googletest/distinfo b/devel/googletest/distinfo
index 9a862da3c4f8..0e5a95bbbc8f 100644
--- a/devel/googletest/distinfo
+++ b/devel/googletest/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1691069587
-SHA256 (google-googletest-v1.14.0_GH0.tar.gz) = 8ad598c73ad796e0d8280b082cebd82a630d73e73cd3c70057938a6501bba5d7
-SIZE (google-googletest-v1.14.0_GH0.tar.gz) = 867764
+TIMESTAMP = 1721148484
+SHA256 (googletest-1.15.0.tar.gz) = 7315acb6bf10e99f332c8a43f00d5fbb1ee6ca48c52f6b936991b216c586aaad
+SIZE (googletest-1.15.0.tar.gz) = 872487
diff --git a/devel/libayatana-indicator/Makefile b/devel/libayatana-indicator/Makefile
index 241bc662ffa7..dcf41902fabd 100644
--- a/devel/libayatana-indicator/Makefile
+++ b/devel/libayatana-indicator/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libayatana-indicator
PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MAINTAINER= jgh@FreeBSD.org
diff --git a/devel/opentelemetry-cpp/Makefile b/devel/opentelemetry-cpp/Makefile
index 44ae46247591..b375c0627c6f 100644
--- a/devel/opentelemetry-cpp/Makefile
+++ b/devel/opentelemetry-cpp/Makefile
@@ -1,6 +1,7 @@
PORTNAME= opentelemetry-cpp
PORTVERSION= 1.14.2
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= osa@FreeBSD.org
diff --git a/graphics/brunsli/Makefile b/graphics/brunsli/Makefile
index c7d12484ff92..cdcf83d9b2f1 100644
--- a/graphics/brunsli/Makefile
+++ b/graphics/brunsli/Makefile
@@ -1,7 +1,7 @@
PORTNAME= brunsli
PORTVERSION= 0.1
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MAINTAINER= sunpoet@FreeBSD.org
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 89c2901944db..ac1e9418e9fa 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -1,6 +1,7 @@
PORTNAME= exiv2
DISTVERSIONPREFIX= v
DISTVERSION= 0.28.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
diff --git a/graphics/partio/Makefile b/graphics/partio/Makefile
index 3faf0bfddbdf..01cecefb7912 100644
--- a/graphics/partio/Makefile
+++ b/graphics/partio/Makefile
@@ -1,6 +1,6 @@
PORTNAME= partio
PORTVERSION= 1.14.6
-PORTREVISION= 2
+PORTREVISION= 3
DISTVERSIONPREFIX= v
CATEGORIES= graphics math
diff --git a/lang/cling/Makefile b/lang/cling/Makefile
index ea826e28404e..4953fbd66790 100644
--- a/lang/cling/Makefile
+++ b/lang/cling/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cling
DISTVERSION= 0.5-2018-08-13
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= lang devel
MASTER_SITES= https://root.cern.ch/download/cling/
DISTNAME= ${PORTNAME}_${DISTVERSION:C/^[0-9]\.[0-9]-//}_sources
diff --git a/math/verdict/Makefile b/math/verdict/Makefile
index 17c8669eb415..e00a2e529d00 100644
--- a/math/verdict/Makefile
+++ b/math/verdict/Makefile
@@ -1,6 +1,6 @@
PORTNAME= verdict
PORTVERSION= 1.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= thierry@FreeBSD.org
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index 2a0193947479..95e28f809fcb 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kodi
DISTVERSION= 21.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia java
MASTER_SITES= http://mirrors.kodi.tv/build-deps/sources/
DISTFILES= apache-groovy-binary-${GROOVY_VERSION}.zip \
diff --git a/net-im/tdlib-purple/Makefile b/net-im/tdlib-purple/Makefile
index 8643ac0b42d1..246dc9e814fe 100644
--- a/net-im/tdlib-purple/Makefile
+++ b/net-im/tdlib-purple/Makefile
@@ -1,7 +1,7 @@
PORTNAME= tdlib-purple
DISTVERSIONPREFIX= v
DISTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
PATCH_SITES= https://github.com/ars3niy/tdlib-purple/commit/
diff --git a/net-p2p/ethash/Makefile b/net-p2p/ethash/Makefile
index f7e9cf4a994f..69ecfff5c604 100644
--- a/net-p2p/ethash/Makefile
+++ b/net-p2p/ethash/Makefile
@@ -1,7 +1,7 @@
PORTNAME= ethash
PORTVERSION= 1.0.1
DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-p2p
MAINTAINER= bofh@FreeBSD.org
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 17b96314a9f5..d881fedb7fd7 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -1,5 +1,6 @@
PORTNAME= orthanc
DISTVERSION= 1.12.3
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= https://orthanc.uclouvain.be/downloads/sources/orthanc/
DISTNAME= Orthanc-${PORTVERSION}
diff --git a/x11-fonts/ots/Makefile b/x11-fonts/ots/Makefile
index 872940441846..b1b3f4827dbd 100644
--- a/x11-fonts/ots/Makefile
+++ b/x11-fonts/ots/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ots
PORTVERSION= 9.1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-fonts
MASTER_SITES= https://github.com/khaledhosny/ots/releases/download/v${PORTVERSION}/