aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-05-26 20:38:49 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-05-26 20:38:49 +0000
commitadd90dd319be1d4e500d5a1fc89f648ef45d6af8 (patch)
tree5296c17af9e0f98777120d8d08a8bc295a1b6000
parent047242b410208c78bebccfd002d545cb0c7bc1aa (diff)
downloadports-add90dd319be1d4e500d5a1fc89f648ef45d6af8.tar.gz
ports-add90dd319be1d4e500d5a1fc89f648ef45d6af8.zip
BROKEN with gcc 4.2
Notes
Notes: svn path=/head/; revision=191937
-rw-r--r--arabic/katoob/Makefile4
-rw-r--r--biology/crimap/Makefile8
-rw-r--r--devel/clint/Makefile4
-rw-r--r--devel/codeworker/Makefile4
-rw-r--r--editors/cooledit/Makefile8
-rw-r--r--editors/dedit/Makefile8
-rw-r--r--games/aqbubble/Makefile4
-rw-r--r--games/atr3d/Makefile8
-rw-r--r--mail/crashecho/Makefile9
-rw-r--r--net/cap/Makefile4
-rw-r--r--net/crescendo/Makefile8
-rw-r--r--news/diablo/Makefile8
-rw-r--r--ports-mgmt/barry/Makefile8
-rw-r--r--sysutils/di/Makefile8
-rw-r--r--www/cgichk/Makefile8
15 files changed, 91 insertions, 10 deletions
diff --git a/arabic/katoob/Makefile b/arabic/katoob/Makefile
index 7de450ba76a3..3e7a1ff68d1a 100644
--- a/arabic/katoob/Makefile
+++ b/arabic/katoob/Makefile
@@ -27,6 +27,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if ${HAVE_GNOME:Mgtksourceview}!="" || defined(WITH_HIGHLIGHTING)
CONFIGURE_ARGS+= "--enable-highlight"
USE_GNOME+= gtksourceview
diff --git a/biology/crimap/Makefile b/biology/crimap/Makefile
index a3428748d787..beccaef2cb94 100644
--- a/biology/crimap/Makefile
+++ b/biology/crimap/Makefile
@@ -21,6 +21,12 @@ PROGRAMS= crimap
EXAMPLES= chr7a.gen demo.dat
EXIT_PATCH= e_ped.c get_log.c our_allo.c our_orde.c
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
.for file in ${EXIT_PATCH}
@${REINPLACE_CMD} -e 's|exit\ *()|exit(0)|' ${WRKSRC}/${file}
@@ -44,4 +50,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/clint/Makefile b/devel/clint/Makefile
index f9531eebe942..8268734c790b 100644
--- a/devel/clint/Makefile
+++ b/devel/clint/Makefile
@@ -27,6 +27,10 @@ INFO= clint
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
diff --git a/devel/codeworker/Makefile b/devel/codeworker/Makefile
index 8024a4a1f118..2741c75bcb0d 100644
--- a/devel/codeworker/Makefile
+++ b/devel/codeworker/Makefile
@@ -30,6 +30,10 @@ PLIST_FILES= bin/codeworker
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if ${OSVERSION} < 500035
CFLAGS+= -fpermissive
.endif
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 2201f1f52b77..2fa80b39f44f 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -35,7 +35,13 @@ CFLAGS+= -DHAVE_MBRTOWC
CONFIGURE_ARGS+= --enable-NeXT-look
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|po pixmap man|po man|g' ${WRKSRC}/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/dedit/Makefile b/editors/dedit/Makefile
index cb5e58ddb228..e7cd33edd9d9 100644
--- a/editors/dedit/Makefile
+++ b/editors/dedit/Makefile
@@ -27,6 +27,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= dedit.1
MANLANG= "" ja
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
pre-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|\(\$$(datadir)/\)gnome/|\1|g ; \
@@ -35,4 +41,4 @@ pre-patch:
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/dedit.ja.1 ${MANPREFIX}/man/ja/man1/dedit.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/aqbubble/Makefile b/games/aqbubble/Makefile
index 7eda0c1c734a..20b4c7fe8bbb 100644
--- a/games/aqbubble/Makefile
+++ b/games/aqbubble/Makefile
@@ -29,6 +29,10 @@ OPTIONS= NLS "Native Language Support" on
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index b64915a4b6ea..f7ad993ad489 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -38,6 +38,12 @@ USE_AUTOTOOLS= automake:19 autoconf:259
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
pre-patch:
@${PERL} -pi.orig -e 's|^aclocal|${ACLOCAL}|; \
s|^autoconf|${AUTOCONF}|; s|^automake|${AUTOMAKE}|' \
@@ -55,4 +61,4 @@ post-configure:
's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/crashecho/Makefile b/mail/crashecho/Makefile
index 550a3e495efd..fd24df3855e5 100644
--- a/mail/crashecho/Makefile
+++ b/mail/crashecho/Makefile
@@ -35,10 +35,17 @@ MAN1= crashecho.1 \
crashwrite.1
MAN5= crashecho.conf.5
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
cd ${WRKDIR} && tar zxf ${PORTNAME}-${PORTVERSION}.tar.gz
post-install:
${MKDIR} ${PREFIX}/etc/ftn
${INSTALL_DATA} ${WRKSRC}/doc/crashecho.conf ${PREFIX}/etc/ftn/crashecho.conf.sample
-.include <bsd.port.mk>
+
+.include <bsd.port.post.mk>
diff --git a/net/cap/Makefile b/net/cap/Makefile
index db3f4b535254..25797a62762b 100644
--- a/net/cap/Makefile
+++ b/net/cap/Makefile
@@ -62,6 +62,10 @@ READMES= applications/papif applications/lwsrv applications/aufs \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
pre-patch:
@(cd ${WRKSRC}; \
for f in ../cap60.patch* ; do ${PATCH} -s -p < $$f ; done)
diff --git a/net/crescendo/Makefile b/net/crescendo/Makefile
index 76ba5c3c4794..41a278c22a89 100644
--- a/net/crescendo/Makefile
+++ b/net/crescendo/Makefile
@@ -32,6 +32,12 @@ MODIFY= Makefile.in data/Makefile.in
USE_XLIB= yes
USE_GNOME= gnomelibs
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
@@ -52,4 +58,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/news/diablo/Makefile b/news/diablo/Makefile
index 77259b4f2c40..0ba473e62a6e 100644
--- a/news/diablo/Makefile
+++ b/news/diablo/Makefile
@@ -25,6 +25,12 @@ MAN8= dicmd.8 didump.8 dexpireover.8 dfeedinfo.8 dgrpctl.8 \
doverctl.8 drequeue.8 dhisexpire.8
PORTDOCS= COPYRIGHT INSTALL README.READER README.SERVER RELEASE_NOTES
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
@${CP} ${SCRIPTDIR}/diablo.sh-sample ${WRKDIR}
@@ -57,4 +63,4 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${RM} -rf ${PREFIX}/news/man
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ports-mgmt/barry/Makefile b/ports-mgmt/barry/Makefile
index 4570fc74280d..a3beb54c1894 100644
--- a/ports-mgmt/barry/Makefile
+++ b/ports-mgmt/barry/Makefile
@@ -24,6 +24,12 @@ USE_AUTOTOOLS= libtool:15
INSTALLS_ICONS= yes
USE_GETTEXT= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name "*.h" -and -not -name "linklocator.h" | \
${XARGS} ${REINPLACE_CMD} -e 's/^};/}/g'
@@ -32,4 +38,4 @@ post-patch:
pre-install:
@${MKDIR} ${DESTDIR}${PREFIX}/share/applnk/Utilities
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/di/Makefile b/sysutils/di/Makefile
index 917d0ba44826..01063fca1211 100644
--- a/sysutils/di/Makefile
+++ b/sysutils/di/Makefile
@@ -18,6 +18,12 @@ USE_GETTEXT= yes
MAN1= di.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
do-configure:
(cd ${WRKSRC}; \
CC="${CC}" CFLAGS="${CFLAGS}" \
@@ -52,4 +58,4 @@ do-install:
${RM} -f $$j.mo; \
done)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/cgichk/Makefile b/www/cgichk/Makefile
index 2ed0cc4d3b18..8230e1e172f9 100644
--- a/www/cgichk/Makefile
+++ b/www/cgichk/Makefile
@@ -18,6 +18,12 @@ COMMENT= A web site vulnerability scanner
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= cgichk
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s/^(CC|CFLAGS).+//g" ${WRKSRC}/Makefile
${REINPLACE_CMD} -e \
@@ -31,4 +37,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>