aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-05 12:41:34 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-05 17:54:19 +0000
commitae0a635327629b218f6af11fb3421c310a292a38 (patch)
treec398f50355aa8ac25d1dad4949531c2025d870bd
parent0dee612caeb239a62735b363d8067903098c96ae (diff)
downloadports-ae0a635327629b218f6af11fb3421c310a292a38.tar.gz
ports-ae0a635327629b218f6af11fb3421c310a292a38.zip
editors/libreoffice: Fix build with QT5 on i386
Fix these errors by adding -Wno-c++11-narrowing: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.4.0.3/vcl/unx/generic/window/salframe.cxx:650:39: error: non-constant-expression cannot be narrowed from type 'unsigned int' to 'tools::Long' (aka 'long') in initializer list [-Wc++11-narrowing] maGeometry.setPosSize({ x, y }, { w, h }); ^ Approved by: office (fluffy), tcberner (mentor)
-rw-r--r--editors/libreoffice/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 0712aec63964..1ddde06ec79b 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -344,7 +344,8 @@ LLD_UNSAFE= yes
.endif
.if ${CHOSEN_COMPILER_TYPE} == clang
-CXXFLAGS_WARN= -Woverloaded-virtual -Wno-unused-parameter -Wno-unused-local-typedefs
+CXXFLAGS_WARN= -Woverloaded-virtual -Wno-c++11-narrowing \
+ -Wno-unused-parameter -Wno-unused-local-typedefs
.else
CXXFLAGS_WARN= -Wshadow -Woverloaded-virtual
.endif