aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:18:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-11 03:22:46 +0000
commitae464f5e341bfab038de834329f6f1a3e394a392 (patch)
treeaa935fabe053084665df9d0383e2cddac89b3541
parentfffe63984b2758f65b079ab4717b479cc5cfb914 (diff)
downloadports-ae464f5e341bfab038de834329f6f1a3e394a392.tar.gz
ports-ae464f5e341bfab038de834329f6f1a3e394a392.zip
devel/bloaty: Fix build with abseil 20230125.0+ and re2 20230601+
-rw-r--r--devel/bloaty/Makefile6
-rw-r--r--devel/bloaty/distinfo2
-rw-r--r--devel/bloaty/files/patch-CMakeLists.txt49
3 files changed, 52 insertions, 5 deletions
diff --git a/devel/bloaty/Makefile b/devel/bloaty/Makefile
index dfb186d99fa3..cba3676a4267 100644
--- a/devel/bloaty/Makefile
+++ b/devel/bloaty/Makefile
@@ -15,12 +15,12 @@ LIB_DEPENDS= libre2.so:devel/re2 \
libcapstone.so:devel/capstone \
libprotobuf.so:devel/protobuf
-USES= cmake compiler:c++11-lang pkgconfig
+USES= cmake compiler:c++17-lang pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= google
-GH_TUPLE= abseil:abseil-cpp:bea85b5:abseil/third_party/abseil-cpp \
- nico:demumble:01098ea:demumble/third_party/demumble
+GH_TUPLE= nico:demumble:01098ea:demumble/third_party/demumble
+CMAKE_ARGS= -DCMAKE_CXX_STANDARD=17
CMAKE_OFF= BLOATY_ENABLE_CMAKETARGETS BLOATY_ENABLE_BUILDID
PLIST_FILES= bin/bloaty
diff --git a/devel/bloaty/distinfo b/devel/bloaty/distinfo
index b79f54ce0099..01d36197f98b 100644
--- a/devel/bloaty/distinfo
+++ b/devel/bloaty/distinfo
@@ -1,7 +1,5 @@
TIMESTAMP = 1594942101
SHA256 (google-bloaty-v1.1_GH0.tar.gz) = 682640678a748d043eea65df48831f807d39a1e761eacc461c756256f7ec6a26
SIZE (google-bloaty-v1.1_GH0.tar.gz) = 3389162
-SHA256 (abseil-abseil-cpp-bea85b5_GH0.tar.gz) = 22e6d91961b2c4568b345fbbcd8a8f350265b8aa60449f9f4e3681e377ce43c3
-SIZE (abseil-abseil-cpp-bea85b5_GH0.tar.gz) = 1025885
SHA256 (nico-demumble-01098ea_GH0.tar.gz) = 8483238a47a68ba5feb0a28e60598e77751857732f1928c3768e08f77ca673b0
SIZE (nico-demumble-01098ea_GH0.tar.gz) = 49945
diff --git a/devel/bloaty/files/patch-CMakeLists.txt b/devel/bloaty/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5c0d67e0da6a
--- /dev/null
+++ b/devel/bloaty/files/patch-CMakeLists.txt
@@ -0,0 +1,49 @@
+--- CMakeLists.txt.orig 2020-05-24 04:36:23 UTC
++++ CMakeLists.txt
+@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.5)
+ cmake_policy(SET CMP0048 NEW)
+ project (Bloaty VERSION 1.0)
+ project (Bloaty VERSION 1.1)
+-set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD 17)
+
+ # Options we define for users.
+ option(BLOATY_ENABLE_ASAN "Enable address sanitizer." OFF)
+@@ -89,11 +89,10 @@ endif(UNIX)
+
+ include_directories(.)
+ include_directories(src)
+-include_directories(third_party/abseil-cpp)
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/src")
+
+ # Baseline build flags.
+-set(CMAKE_CXX_FLAGS "-std=c++11 -W -Wall -Wno-sign-compare")
++set(CMAKE_CXX_FLAGS "-std=c++17 -W -Wall -Wno-sign-compare")
+ set(CMAKE_CXX_FLAGS_DEBUG "-g1")
+ set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g1")
+@@ -159,24 +158,6 @@ add_library(libbloaty
+ src/macho.cc
+ src/range_map.cc
+ src/webassembly.cc
+- # Until Abseil has a proper CMake build system
+- third_party/abseil-cpp/absl/base/internal/raw_logging.cc # Grrrr...
+- third_party/abseil-cpp/absl/base/internal/throw_delegate.cc
+- third_party/abseil-cpp/absl/numeric/int128.cc
+- third_party/abseil-cpp/absl/strings/ascii.cc
+- third_party/abseil-cpp/absl/strings/charconv.cc
+- third_party/abseil-cpp/absl/strings/escaping.cc
+- third_party/abseil-cpp/absl/strings/internal/charconv_bigint.cc
+- third_party/abseil-cpp/absl/strings/internal/charconv_parse.cc
+- third_party/abseil-cpp/absl/strings/internal/memutil.cc
+- third_party/abseil-cpp/absl/strings/internal/utf8.cc
+- third_party/abseil-cpp/absl/strings/match.cc
+- third_party/abseil-cpp/absl/strings/numbers.cc
+- third_party/abseil-cpp/absl/strings/str_cat.cc
+- third_party/abseil-cpp/absl/strings/string_view.cc
+- third_party/abseil-cpp/absl/strings/str_split.cc
+- third_party/abseil-cpp/absl/strings/substitute.cc
+- third_party/abseil-cpp/absl/types/bad_optional_access.cc
+ # One source file, no special build system needed.
+ third_party/demumble/third_party/libcxxabi/cxa_demangle.cpp
+ )