aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@freebsd.org>2023-06-03 20:01:38 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 20:18:11 +0000
commitaeb0a1d7f144b70da53e58bbdcdf52fe60396887 (patch)
tree11a69778f18a311ff664250c5247d6e1839d9ea6
parent4af25c28b3b9e805c6cc3428fad27d6becef6706 (diff)
downloadports-aeb0a1d7f144b70da53e58bbdcdf52fe60396887.tar.gz
ports-aeb0a1d7f144b70da53e58bbdcdf52fe60396887.zip
sysutils/tmate: Add BACKSPACE option
- Add LICENSE PR: 248511
-rw-r--r--sysutils/tmate/Makefile14
-rw-r--r--sysutils/tmate/files/extra-patch-tty-keys.c11
2 files changed, 23 insertions, 2 deletions
diff --git a/sysutils/tmate/Makefile b/sysutils/tmate/Makefile
index 1028030a4bb3..84320eb9e3f3 100644
--- a/sysutils/tmate/Makefile
+++ b/sysutils/tmate/Makefile
@@ -1,12 +1,15 @@
PORTNAME= tmate
PORTVERSION= 2.4.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MAINTAINER= bofh@FreeBSD.org
COMMENT= Instant terminal sharing
WWW= https://tmate.io/
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libevent.so:devel/libevent \
libmsgpackc.so:devel/msgpack-c \
libssh.so:security/libssh
@@ -14,11 +17,18 @@ LIB_DEPENDS= libevent.so:devel/libevent \
USES= autoreconf compiler:c11 ncurses pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= tmate-io
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
+
LDFLAGS+= -lexecinfo
PLIST_FILES= bin/tmate man/man1/tmate.1.gz
+OPTIONS_DEFINE= BACKSPACE
+
+BACKSPACE_DESC= Build with tty/keys patch
+
+BACKSPACE_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-tty-keys.c
+
.include <bsd.port.mk>
diff --git a/sysutils/tmate/files/extra-patch-tty-keys.c b/sysutils/tmate/files/extra-patch-tty-keys.c
new file mode 100644
index 000000000000..ac106ab4e1d8
--- /dev/null
+++ b/sysutils/tmate/files/extra-patch-tty-keys.c
@@ -0,0 +1,11 @@
+--- tty-keys.c.orig 2023-06-02 17:59:27 UTC
++++ tty-keys.c
+@@ -572,8 +572,6 @@ first_key:
+ * used. termios should have a better idea.
+ */
+ bspace = tty->tio.c_cc[VERASE];
+- if (bspace != _POSIX_VDISABLE && key == bspace)
+- key = KEYC_BSPACE;
+
+ goto complete_key;
+