aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2022-12-27 03:36:06 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2022-12-27 03:36:06 +0000
commitaeccccd1cfe5936c2505bc0e3bf8071ff4394b39 (patch)
tree07521a2dcf2ddc4f20a446208865bebf79a18264
parent153d3db0667476bdd46f552a437f1130bce0e68f (diff)
downloadports-aeccccd1cfe5936c2505bc0e3bf8071ff4394b39.tar.gz
ports-aeccccd1cfe5936c2505bc0e3bf8071ff4394b39.zip
security/gokey: New port: Simple password manager writen in Go
PR: 268587
-rw-r--r--security/Makefile1
-rw-r--r--security/gokey/Makefile27
-rw-r--r--security/gokey/distinfo5
-rw-r--r--security/gokey/pkg-descr13
4 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7bd983bb100b..ce4f11333893 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -180,6 +180,7 @@
SUBDIR += gnutls
SUBDIR += go-cve-dictionary
SUBDIR += gokart
+ SUBDIR += gokey
SUBDIR += gonepass
SUBDIR += gopass
SUBDIR += gorilla
diff --git a/security/gokey/Makefile b/security/gokey/Makefile
new file mode 100644
index 000000000000..6ff956ac043d
--- /dev/null
+++ b/security/gokey/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= gokey
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.1.2
+CATEGORIES= security
+
+MAINTAINER= 0xdutra@gmail.com
+COMMENT= Simple password manager write in Go
+WWW= https://github.com/cloudflare/gokey
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+GO_MODULE= github.com/cloudflare/gokey
+GO_TARGET= ./cmd/gokey
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/gokey/distinfo b/security/gokey/distinfo
new file mode 100644
index 000000000000..1e2228ed6ca8
--- /dev/null
+++ b/security/gokey/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1672107735
+SHA256 (go/security_gokey/gokey-v0.1.2/v0.1.2.mod) = 950a88925784603d0a9b5af156afc7233601d33ddc237d01d6978f1c2f53e310
+SIZE (go/security_gokey/gokey-v0.1.2/v0.1.2.mod) = 167
+SHA256 (go/security_gokey/gokey-v0.1.2/v0.1.2.zip) = 44c0e33ce53a39d2c1aadb457478faacc46204e2a60c171d48c4c943d38df639
+SIZE (go/security_gokey/gokey-v0.1.2/v0.1.2.zip) = 25411
diff --git a/security/gokey/pkg-descr b/security/gokey/pkg-descr
new file mode 100644
index 000000000000..26e89655131e
--- /dev/null
+++ b/security/gokey/pkg-descr
@@ -0,0 +1,13 @@
+gokey is a password manager, which does not require a password vault.
+
+Supported password/key types:
+ - pass: default, generates a password
+ - seed: generates a seed file, which can be used with -s option later
+ - raw: generates 32 random bytes (can be used as a symmetric key)
+ - ec256: generates ECC P-256 private key
+ - ec384: generates ECC P-384 private key
+ - ec521: generates ECC P-521 private key
+ - rsa2048: generates 2048-bit RSA private key
+ - rsa4096: generates 4096-bit RSA private key
+ - x25519: generates x25519 (also known as curve25519) ECC private key
+ - ed25519: generates ed25519 ECC private key