aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-06 19:52:54 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-06 20:45:25 +0000
commitaee41bf6b83bfd73152e2ceacc33cd5dae919ce2 (patch)
treecd4b3e41284f28ad104ed2155117cc18ff80c112
parent2f606f4670908db51a48b2d9ee29685916f4490b (diff)
downloadports-aee41bf6b83bfd73152e2ceacc33cd5dae919ce2.tar.gz
ports-aee41bf6b83bfd73152e2ceacc33cd5dae919ce2.zip
science/molscript: Fix build with llvm15
Approved by: portmgr (blanket)
-rw-r--r--science/molscript/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/molscript/Makefile b/science/molscript/Makefile
index 89b93d83db32..c3762268b2b2 100644
--- a/science/molscript/Makefile
+++ b/science/molscript/Makefile
@@ -36,6 +36,12 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
do-install:
.for e in ${PROGS}
${INSTALL_PROGRAM} ${WRKSRC}/../${e} ${STAGEDIR}${PREFIX}/bin
@@ -44,4 +50,4 @@ do-install:
do-install-DOCS-on:
cd ${WRKSRC}/../docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>