aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Wagin <dmitry.wagin@ya.ru>2022-12-06 23:38:10 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2022-12-06 23:38:10 +0000
commitaeef2f0228a23fb036a08a4d9448af71dd499766 (patch)
treeb80682f808411e45d56d9b81c48c946efd26d7af
parent2ce895840ff4149a390688bbd6a1aa7bd8a18328 (diff)
downloadports-aeef2f0228a23fb036a08a4d9448af71dd499766.tar.gz
ports-aeef2f0228a23fb036a08a4d9448af71dd499766.zip
devel/jetbrains-pty4j: New Port
Pseudo terminal support for devel/jetbrains-*. WWW: https://github.com/JetBrains/pty4j PR: 268152
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jetbrains-pty4j/Makefile53
-rw-r--r--devel/jetbrains-pty4j/distinfo3
-rw-r--r--devel/jetbrains-pty4j/pkg-descr1
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index df3d3be8c4c0..524dad708371 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -999,6 +999,7 @@
SUBDIR += jetbrains-clion
SUBDIR += jetbrains-goland
SUBDIR += jetbrains-phpstorm
+ SUBDIR += jetbrains-pty4j
SUBDIR += jetbrains-webstorm
SUBDIR += jgoodies-looks
SUBDIR += jiic
diff --git a/devel/jetbrains-pty4j/Makefile b/devel/jetbrains-pty4j/Makefile
new file mode 100644
index 000000000000..381e5b0db108
--- /dev/null
+++ b/devel/jetbrains-pty4j/Makefile
@@ -0,0 +1,53 @@
+PORTNAME= pty4j
+PORTVERSION= 0.12.10
+CATEGORIES= devel java
+PKGNAMEPREFIX= jetbrains-
+DIST_SUBDIR= jetbrains
+
+MAINTAINER= dmitry.wagin@ya.ru
+COMMENT= Pty4J's native library
+WWW= https://github.com/JetBrains/pty4j
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= JetBrains
+GH_PROJECT= pty4j
+GH_TAGNAME= aa7f15307744d5d33a44bd72b42513327c879fd3
+
+.include <bsd.port.options.mk>
+
+# The directory we need to install Pty4J's native library in depends
+# on the install target's architecture. We rebuild libpty.so instead
+# of using one of the bundled ones which are FreeBSD 10.x only.
+.if ${ARCH} == "amd64"
+PTY4J_ARCH= x86-64
+.elif ${ARCH} == "i386"
+PTY4J_ARCH= x86
+.else
+PTY4J_ARCH=
+.endif
+
+.if ${PTY4J_ARCH} != ""
+# Despite what the name might suggest using the linux_x86_64 target
+# will always build libpty.so for the native platform.
+BUILD_WRKSRC= ${WRKSRC}/native
+MAKEFILE= Makefile_freebsd
+ALL_TARGET= linux_x86_64
+PLIST_FILES+= lib/pty4j/freebsd/${PTY4J_ARCH}/libpty.so
+.else
+# If native Pty4J support is missing.
+NO_BUILD= yes
+.endif
+
+do-install:
+.if ${PTY4J_ARCH} != ""
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/pty4j/freebsd/${PTY4J_ARCH}
+# See above why we always use freebsd/x86-64/ here
+ ${INSTALL_LIB} ${WRKSRC}/os/freebsd/x86-64/libpty.so ${STAGEDIR}${PREFIX}/lib/pty4j/freebsd/${PTY4J_ARCH}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/jetbrains-pty4j/distinfo b/devel/jetbrains-pty4j/distinfo
new file mode 100644
index 000000000000..97ca3c4ba809
--- /dev/null
+++ b/devel/jetbrains-pty4j/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1670074422
+SHA256 (jetbrains/JetBrains-pty4j-0.12.10-aa7f15307744d5d33a44bd72b42513327c879fd3_GH0.tar.gz) = 386a5057f4d5b33139f83bd8ed57a703714fa71c649ab750f8a9839b5133c306
+SIZE (jetbrains/JetBrains-pty4j-0.12.10-aa7f15307744d5d33a44bd72b42513327c879fd3_GH0.tar.gz) = 1586412
diff --git a/devel/jetbrains-pty4j/pkg-descr b/devel/jetbrains-pty4j/pkg-descr
new file mode 100644
index 000000000000..c3584fd8d036
--- /dev/null
+++ b/devel/jetbrains-pty4j/pkg-descr
@@ -0,0 +1 @@
+Pty4J - Pseudo terminal(PTY) implementation in Java.