aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2024-04-03 16:14:38 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2024-04-03 16:15:09 +0000
commitaf0c266d9d85450d495b820bfce370a5147a629e (patch)
tree04c757d7179333839f9fdb0ac44f71150ca29ff3
parentc51f7874eb12e219df92fa3a12c344066d959f61 (diff)
downloadports-af0c266d9d85450d495b820bfce370a5147a629e.tar.gz
ports-af0c266d9d85450d495b820bfce370a5147a629e.zip
security/boringssl: update to the recent snapshot
-rw-r--r--security/boringssl/Makefile5
-rw-r--r--security/boringssl/distinfo6
-rw-r--r--security/boringssl/files/patch-CMakeLists.txt7
-rw-r--r--security/boringssl/files/patch-crypto_CMakeLists.txt8
4 files changed, 9 insertions, 17 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index 71abd16d7c42..16541016089d 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -1,6 +1,5 @@
PORTNAME= boringssl
-PORTVERSION= 0.0.0.0.2024.03.22.01
-PORTREVISION= 1
+PORTVERSION= 0.0.0.0.2024.04.01.01
CATEGORIES= security
MASTER_SITES+= https://proxy.golang.org/:gomods
DISTFILES+= golang.org/x/crypto/@v/v0.17.0.zip:gomods \
@@ -29,7 +28,7 @@ CPE_VENDOR= google
USE_GITHUB= yes
GH_ACCOUNT= google
-GH_TAGNAME= 231510c
+GH_TAGNAME= 077d4d2
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=1
CFLAGS_i386= -msse2
diff --git a/security/boringssl/distinfo b/security/boringssl/distinfo
index 96af871e0052..e936a1265269 100644
--- a/security/boringssl/distinfo
+++ b/security/boringssl/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1711202760
+TIMESTAMP = 1712076130
SHA256 (golang.org/x/crypto/@v/v0.17.0.zip) = 97ea91df712ac1ca39c122480489be532b437bf4aeb5d781465cb1cf39824083
SIZE (golang.org/x/crypto/@v/v0.17.0.zip) = 1798689
SHA256 (golang.org/x/crypto/@v/v0.17.0.mod) = dc40867bef3ca5179569cc2f8742bb618b8cc684b0d25a753250e81d6dc29442
@@ -15,5 +15,5 @@ SHA256 (golang.org/x/term/@v/v0.15.0.zip) = cb7fff77d2925dc0e4f5ac0ced38d1068382
SIZE (golang.org/x/term/@v/v0.15.0.zip) = 19883
SHA256 (golang.org/x/term/@v/v0.15.0.mod) = 4b86976f8c4efb87bbcbec283cbfb395a28177b4b8b83420b49d95728eb7a2f8
SIZE (golang.org/x/term/@v/v0.15.0.mod) = 68
-SHA256 (google-boringssl-0.0.0.0.2024.03.22.01-231510c_GH0.tar.gz) = a8a75d7c75ff152cfec8eff70c88b431ea083c0778795800214293c4011d04a6
-SIZE (google-boringssl-0.0.0.0.2024.03.22.01-231510c_GH0.tar.gz) = 36788739
+SHA256 (google-boringssl-0.0.0.0.2024.04.01.01-077d4d2_GH0.tar.gz) = ae11481a80634787e5e6d6d73f4b9a62a23f31a338f68896ada5bd5170de47ee
+SIZE (google-boringssl-0.0.0.0.2024.04.01.01-077d4d2_GH0.tar.gz) = 36794695
diff --git a/security/boringssl/files/patch-CMakeLists.txt b/security/boringssl/files/patch-CMakeLists.txt
index c54f8fa02fad..4e3e522d5f6f 100644
--- a/security/boringssl/files/patch-CMakeLists.txt
+++ b/security/boringssl/files/patch-CMakeLists.txt
@@ -1,10 +1,11 @@
---- CMakeLists.txt.orig 2024-03-23 14:15:05 UTC
+--- CMakeLists.txt.orig 2024-04-01 22:15:28 UTC
+++ CMakeLists.txt
-@@ -522,6 +522,7 @@ add_library(ssl ${SSL_SOURCES})
- install_if_enabled(TARGETS ssl EXPORT OpenSSLTargets ${INSTALL_DESTINATION_DEFAULT})
+@@ -610,6 +610,8 @@ add_library(ssl ${SSL_SOURCES})
+ # here.
set_property(TARGET ssl PROPERTY EXPORT_NAME SSL)
target_link_libraries(ssl crypto)
+SET_TARGET_PROPERTIES(ssl PROPERTIES SOVERSION 1)
++SET_TARGET_PROPERTIES(crypto PROPERTIES SOVERSION 1)
add_library(decrepit ${DECREPIT_SOURCES})
target_link_libraries(decrepit crypto ssl)
diff --git a/security/boringssl/files/patch-crypto_CMakeLists.txt b/security/boringssl/files/patch-crypto_CMakeLists.txt
deleted file mode 100644
index d123e69b80a9..000000000000
--- a/security/boringssl/files/patch-crypto_CMakeLists.txt
+++ /dev/null
@@ -1,8 +0,0 @@
---- crypto/CMakeLists.txt.orig 2024-03-23 00:06:50 UTC
-+++ crypto/CMakeLists.txt
-@@ -375,3 +375,5 @@ endif()
- if(USE_CUSTOM_LIBCXX)
- target_link_libraries(crypto libcxx)
- endif()
-+
-+SET_TARGET_PROPERTIES(crypto PROPERTIES SOVERSION 1)