aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-12 10:36:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-12 10:36:16 +0000
commitafb5d0b5f2a5db65f0a157dbd8622019ede8a001 (patch)
tree1b011bf7378ed0cc0d17c243ba56df1cc281df84
parent83c6c2647b553bfb08f97a1ccecf604026ead670 (diff)
downloadports-afb5d0b5f2a5db65f0a157dbd8622019ede8a001.tar.gz
ports-afb5d0b5f2a5db65f0a157dbd8622019ede8a001.zip
- chase celt library bump
Notes
Notes: svn path=/head/; revision=272602
-rw-r--r--audio/jack/Makefile4
-rw-r--r--audio/jack/files/patch-drivers__netjack__netjack_packet.c23
-rw-r--r--audio/mangler/Makefile4
-rw-r--r--audio/mumble/Makefile6
-rw-r--r--net/opal3/Makefile4
-rw-r--r--net/opal3/files/patch-plugins-audio-celt-celtcodec.c29
6 files changed, 56 insertions, 14 deletions
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index cd86227c542f..bba5903e06e4 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jackit
PORTVERSION= 0.118.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://jackaudio.org/downloads/
DISTNAME= jack-audio-connection-kit-${PORTVERSION}
@@ -18,7 +18,7 @@ COMMENT= A low-latency audio server
LIB_DEPENDS= portaudio.0:${PORTSDIR}/audio/portaudio \
sndfile.1:${PORTSDIR}/audio/libsndfile \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
- celt.0:${PORTSDIR}/audio/celt
+ celt0.2:${PORTSDIR}/audio/celt
LATEST_LINK= jack
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}" LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/audio/jack/files/patch-drivers__netjack__netjack_packet.c b/audio/jack/files/patch-drivers__netjack__netjack_packet.c
new file mode 100644
index 000000000000..6bdd5ee876d0
--- /dev/null
+++ b/audio/jack/files/patch-drivers__netjack__netjack_packet.c
@@ -0,0 +1,23 @@
+--- ./drivers/netjack/netjack_packet.c.orig 2009-11-12 22:09:39.000000000 +0100
++++ ./drivers/netjack/netjack_packet.c 2011-04-12 11:31:54.221162522 +0200
+@@ -1427,9 +1427,9 @@
+
+ CELTDecoder *decoder = src_node->data;
+ if( !packet_payload )
+- celt_decode_float( decoder, NULL, net_period_down, buf );
++ celt_decode_float( decoder, NULL, net_period_down, buf, 1);
+ else
+- celt_decode_float( decoder, packet_bufX, net_period_down, buf );
++ celt_decode_float( decoder, packet_bufX, net_period_down, buf, 1);
+
+ src_node = jack_slist_next (src_node);
+ }
+@@ -1471,7 +1471,7 @@
+ float *floatbuf = alloca (sizeof(float) * nframes );
+ memcpy( floatbuf, buf, nframes*sizeof(float) );
+ CELTEncoder *encoder = src_node->data;
+- encoded_bytes = celt_encode_float( encoder, floatbuf, NULL, packet_bufX, net_period_up );
++ encoded_bytes = celt_encode_float( encoder, floatbuf, 1, packet_bufX, net_period_up );
+ if( encoded_bytes != net_period_up )
+ printf( "something in celt changed. netjack needs to be changed to handle this.\n" );
+ src_node = jack_slist_next( src_node );
diff --git a/audio/mangler/Makefile b/audio/mangler/Makefile
index cb4add816f76..2ee362355de4 100644
--- a/audio/mangler/Makefile
+++ b/audio/mangler/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mangler
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.mangler.org/downloads/
MAINTAINER= janik@hikarihq.com
COMMENT= A Ventrilo VOIP combatible client
-LIB_DEPENDS= celt.0:${PORTSDIR}/audio/celt \
+LIB_DEPENDS= celt0.2:${PORTSDIR}/audio/celt \
speex.1:${PORTSDIR}/audio/speex \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index fd8f3ac41847..f34c8d8352ca 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -61,7 +61,7 @@ PLIST_SUB+= BUNDLECELT=""
.else
CONFIG+= no-bundled-celt
PLIST_SUB+= BUNDLECELT="@comment "
-LIB_DEPENDS+= celt.0:${PORTSDIR}/audio/celt
+LIB_DEPENDS+= celt0.2:${PORTSDIR}/audio/celt
.endif
.if defined(WITHOUT_BONJOUR)
@@ -79,6 +79,10 @@ PLIST_SUB+= MUMBLE11X=""
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/overlay_gl/overlay_gl.pro
+ # Fix with celt 0.11
+.if !defined(WITHOUT_SYSCELT)
+ @${REINPLACE_CMD} -e 's/CELT_SET_VBR_RATE/CELT_SET_BITRATE/g' ${WRKSRC}/src/mumble/AudioInput.cpp
+.endif
do-configure:
.if defined(WITHOUT_SYSCELT)
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 3b95a389bc7a..2372972e3020 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opal3
PORTVERSION= 3.6.6
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= net
MASTER_SITES= SF/opalvoip/v3.6%20Lalande/Stable%205
DISTNAME= opal-${PORTVERSION}
@@ -98,7 +98,7 @@ CONFIGURE_ARGS+= --disable-java
.endif
.if defined(WITH_CELT)
-LIB_DEPENDS+= celt.0:${PORTSDIR}/audio/celt
+LIB_DEPENDS+= celt0.2:${PORTSDIR}/audio/celt
CONFIGURE_ARGS+= --enable-celt
PLIST_SUB+= CELT=""
.else
diff --git a/net/opal3/files/patch-plugins-audio-celt-celtcodec.c b/net/opal3/files/patch-plugins-audio-celt-celtcodec.c
index 9094b5b10118..823bca9cfb3c 100644
--- a/net/opal3/files/patch-plugins-audio-celt-celtcodec.c
+++ b/net/opal3/files/patch-plugins-audio-celt-celtcodec.c
@@ -1,6 +1,6 @@
---- plugins/audio/celt/celtcodec.c.orig 2009-09-22 02:57:45.000000000 +0200
-+++ plugins/audio/celt/celtcodec.c 2009-11-13 22:00:39.000000000 +0100
-@@ -52,7 +52,7 @@ static int init_mode(CELTContext *celt,
+--- ./plugins/audio/celt/celtcodec.c.orig 2009-09-22 02:57:45.000000000 +0200
++++ ./plugins/audio/celt/celtcodec.c 2011-04-12 12:26:00.485668577 +0200
+@@ -52,12 +52,12 @@
{
int error = 0;
@@ -9,7 +9,13 @@
if (celt->mode == NULL) {
return FALSE;
}
-@@ -74,7 +74,7 @@ static void * celt_create_encoder(const
+
+- celt_mode_info(celt->mode, CELT_GET_FRAME_SIZE, &celt->frame_size);
++ celt->frame_size = 960; /* default from tools/celtenc.c */
+ celt->bytes_per_packet = (codec->bitsPerSec * celt->frame_size/codec->sampleRate + 4) / 8;
+
+ return TRUE;
+@@ -74,7 +74,7 @@
return NULL;
}
@@ -18,7 +24,7 @@
if (celt->encoder_state == NULL ) {
celt_mode_destroy(celt->mode);
free(celt);
-@@ -96,7 +96,7 @@ static void * celt_create_decoder(const
+@@ -96,7 +96,7 @@
return NULL;
}
@@ -27,15 +33,24 @@
if (celt->decoder_state == NULL ) {
celt_mode_destroy(celt->mode);
free(celt);
-@@ -143,9 +143,9 @@ static int celt_codec_encoder(const stru
+@@ -143,9 +143,9 @@
return FALSE;
#ifdef HAVE_CELT_0_5_0_OR_LATER
- byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
-+ byteCount = celt_encode(celt->encoder_state, (celt_int16 *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
++ byteCount = celt_encode(celt->encoder_state, (celt_int16 *)fromPtr, celt->frame_size, (char *)toPtr, celt->bytes_per_packet);
#else
- byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, (char *)toPtr, celt->bytes_per_packet);
+ byteCount = celt_encode(celt->encoder_state, (celt_int16 *)fromPtr, (char *)toPtr, celt->bytes_per_packet);
#endif
if (byteCount < 0) {
return 0;
+@@ -173,7 +173,7 @@
+ if (*fromLen == 0)
+ return FALSE;
+
+- if (celt_decode(celt->decoder_state, (char *)fromPtr, *fromLen, (short *)toPtr) < 0) {
++ if (celt_decode(celt->decoder_state, (char *)fromPtr, *fromLen, (short *)toPtr, celt->frame_size) < 0) {
+ return 0;
+ }
+