aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2025-03-15 18:03:38 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2025-03-15 18:10:44 +0000
commitafc5ed77e98cf4770b898780fec65d4253e83b94 (patch)
treef81b361187cbc6f4f9c028d54278c3ed59351ae8
parentded7047347322aaaa01453280ffdf1358ddcc9ed (diff)
lang/ghc*: Remove BUILD_DEPEND on compat12x
compat12x is only needed for ghc810 and ghc92 so remove the build depend for lang/ghc and lang/ghc94 Reviewed by: arrowd
-rw-r--r--lang/ghc/Makefile5
-rw-r--r--lang/ghc810/Makefile5
-rw-r--r--lang/ghc92/Makefile5
3 files changed, 10 insertions, 5 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 73d1b7b5e094..5b61a79f7de4 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -171,11 +171,6 @@ PLIST= ${.CURDIR}/../ghc92/pkg-plist
. endif
.endif
-# This version of ncurses is needed by bootstrap compiler
-.if empty(PORT_OPTIONS:MBOOT)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
-.endif
-
.if empty(PORT_OPTIONS:MBOOT)
DISTFILES+= ghc-${BOOT_GHC_VERSION}-boot-${ARCH}-freebsd${EXTRACT_SUFX}:boot
.endif # MBOOT
diff --git a/lang/ghc810/Makefile b/lang/ghc810/Makefile
index 2f1d8244f292..b46269817b14 100644
--- a/lang/ghc810/Makefile
+++ b/lang/ghc810/Makefile
@@ -30,3 +30,8 @@ PATCHDIR= ${.CURDIR}/files
PLIST= ${.CURDIR}/pkg-plist
.include "${MASTERDIR}/Makefile"
+
+# This version of ncurses is needed by bootstrap compiler
+.if empty(PORT_OPTIONS:MBOOT)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
+.endif
diff --git a/lang/ghc92/Makefile b/lang/ghc92/Makefile
index 473c3601c0a9..1b38789da16f 100644
--- a/lang/ghc92/Makefile
+++ b/lang/ghc92/Makefile
@@ -26,3 +26,8 @@ PATCHDIR= ${.CURDIR}/files
# PLIST for this port is set in the master one
.include "${MASTERDIR}/Makefile"
+
+# This version of ncurses is needed by bootstrap compiler
+.if empty(PORT_OPTIONS:MBOOT)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libncursesw.so.8:misc/compat12x
+.endif