aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-07-24 13:24:19 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-07-24 13:24:19 +0000
commitafee9d5cd365a4ef10c99ef86e5358e76a5d37f2 (patch)
tree742c081587c75393def2a3e12385f2d77313a180
parente99d0fcadae3c680e8b044d0f84d81f0885b227e (diff)
downloadports-afee9d5cd365a4ef10c99ef86e5358e76a5d37f2.tar.gz
ports-afee9d5cd365a4ef10c99ef86e5358e76a5d37f2.zip
- Respect LOCALBASE
Notes
Notes: svn path=/head/; revision=362795
-rw-r--r--textproc/zorba/Makefile1
-rw-r--r--textproc/zorba/files/patch-CMakeLists.txt2
2 files changed, 2 insertions, 1 deletions
diff --git a/textproc/zorba/Makefile b/textproc/zorba/Makefile
index 454cd50be753..9ffbdc85a0a1 100644
--- a/textproc/zorba/Makefile
+++ b/textproc/zorba/Makefile
@@ -35,6 +35,7 @@ USES= cmake:outsource iconv compiler:c++11-lib
CXXFLAGS+= -I${LOCALBASE}/include -O1 # compiler hangs with -O2 on CURRENT
LDFLAGS+= -L${LOCALBASE}/lib
CMAKE_ARGS= -DCMAKE_REQUIRED_FLAGS:STRING="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ -DLOCALBASE:STRING=${LOCALBASE} \
-DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
diff --git a/textproc/zorba/files/patch-CMakeLists.txt b/textproc/zorba/files/patch-CMakeLists.txt
index c4f0db746ca7..bfde98f6f704 100644
--- a/textproc/zorba/files/patch-CMakeLists.txt
+++ b/textproc/zorba/files/patch-CMakeLists.txt
@@ -18,7 +18,7 @@
+# execinfo
+#
+IF(FREEBSD)
-+ SET(requiredlibs ${requiredlibs} "/usr/local/lib/libexecinfo.so")
++ SET(requiredlibs ${requiredlibs} "${LOCALBASE}/lib/libexecinfo.so")
+ENDIF(FREEBSD)
+
+#