aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2016-02-18 13:24:14 +0000
committerStefan Eßer <se@FreeBSD.org>2016-02-18 13:24:14 +0000
commitaff3b8152937e73d2dbed4a4e9667fcc5c15bae7 (patch)
treedd579b6eb4a71d72653805131e581ea2e6166f72
parentb5498a3d45351af5551eb51b5706747058db0431 (diff)
downloadports-aff3b8152937e73d2dbed4a4e9667fcc5c15bae7.tar.gz
ports-aff3b8152937e73d2dbed4a4e9667fcc5c15bae7.zip
This is the adaptation of PlayOnLinux to FreeBSD. The purpose of this
program is to simplify installation of MS Windows software to run under the Windows emulator "Wine". The name indicates, that the program was initially developed to support easy installation of Windows games on Linux. The range of supported applications has long been extended to cover a wide range of windows applications including Microsoft Office. PlayOnFreeBSD behaves significantly different than PlayOnLinux in a number of aspects, e.g. which version of Wine to use (only a single version is normally installed on FreeBSD, but PlayOnLinux tries to run each Windows application in a Wine environment that has previously been reported to give good results and installs missing Wine versions in the user's home directory). Reviewed by: antoine
Notes
Notes: svn path=/head/; revision=409105
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/playonbsd/Makefile58
-rw-r--r--emulators/playonbsd/distinfo2
-rw-r--r--emulators/playonbsd/files/patch-lib_scripts.lib39
-rw-r--r--emulators/playonbsd/files/patch-lib_setupwindow.lib19
-rw-r--r--emulators/playonbsd/files/patch-lib_variables16
-rw-r--r--emulators/playonbsd/files/patch-lib_wine.lib100
-rw-r--r--emulators/playonbsd/files/patch-python_mainwindow.py13
-rw-r--r--emulators/playonbsd/files/playonbsd.sh.in3
-rw-r--r--emulators/playonbsd/pkg-descr5
-rw-r--r--emulators/playonbsd/pkg-plist408
11 files changed, 664 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 15e0f9fc91f8..9254d53ad3e3 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -111,6 +111,7 @@
SUBDIR += pcsxr
SUBDIR += pearpc
SUBDIR += pipelight
+ SUBDIR += playonbsd
SUBDIR += ppsspp
SUBDIR += py-gns3-converter
SUBDIR += q4wine
diff --git a/emulators/playonbsd/Makefile b/emulators/playonbsd/Makefile
new file mode 100644
index 000000000000..ad36076135a9
--- /dev/null
+++ b/emulators/playonbsd/Makefile
@@ -0,0 +1,58 @@
+# Created by: Stefan Esser <se@StefanEsser.FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= playonbsd
+PORTVERSION= 4.2.8
+CATEGORIES= emulators games
+
+MAINTAINER= se@FreeBSD.org
+COMMENT= Easily install and run Windows software for use with wine
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip \
+ bash:${PORTSDIR}/shells/bash \
+ glxinfo:${PORTSDIR}/graphics/mesa-demos \
+ gpg:${PORTSDIR}/security/gnupg \
+ gsed:${PORTSDIR}/textproc/gsed \
+ sudo:${PORTSDIR}/security/sudo \
+ xdg-open:${PORTSDIR}/devel/xdg-utils \
+ xterm:${PORTSDIR}/x11/xterm
+
+OPTIONS_DEFINE= GECKO MONO
+OPTIONS_DEFAULT= GECKO MONO
+GECKO_DESC= Wine-gecko HTML rendering support
+MONO_RUN_DEPENDS= wine-mono-devel>=4.5.6:${PORTSDIR}/emulators/wine-mono-devel
+GECKO_RUN_DEPENDS= wine-gecko>=2.21:${PORTSDIR}/emulators/wine-gecko
+
+ONLY_FOR_ARCHS= amd64 i386
+
+USES= python:run
+USE_PERL= yes
+USE_WX= 2.8+
+WX_COMPS= python:run
+
+USE_GITHUB= yes
+GH_ACCOUNT= PlayOnLinux
+GH_PROJECT= POL-POM-4
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == amd64
+RUN_DEPENDS+= wine:${PORTSDIR}/emulators/i386-wine-devel
+.else
+RUN_DEPENDS+= wine:${PORTSDIR}/emulators/wine
+.endif
+
+NO_BUILD= true
+SUB_FILES= playonbsd.sh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's:/usr/local/:${LOCALBASE}/:' ${WRKSRC}/lib/wine.lib
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/lib/playonbsd/ "-perm -0100 ! -name *.orig"
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/playonbsd/ "! -perm 0100 ! -name *.orig"
+ ${INSTALL_SCRIPT} ${WRKDIR}/playonbsd.sh ${STAGEDIR}${PREFIX}/bin/playonbsd
+
+.include <bsd.port.post.mk>
diff --git a/emulators/playonbsd/distinfo b/emulators/playonbsd/distinfo
new file mode 100644
index 000000000000..98dcc024eec5
--- /dev/null
+++ b/emulators/playonbsd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PlayOnLinux-POL-POM-4-4.2.8_GH0.tar.gz) = 746cd72267c42b9c910c2977c5de92ec3e591b72dec382c5a706e353238cd6a3
+SIZE (PlayOnLinux-POL-POM-4-4.2.8_GH0.tar.gz) = 3168626
diff --git a/emulators/playonbsd/files/patch-lib_scripts.lib b/emulators/playonbsd/files/patch-lib_scripts.lib
new file mode 100644
index 000000000000..e04969c38347
--- /dev/null
+++ b/emulators/playonbsd/files/patch-lib_scripts.lib
@@ -0,0 +1,39 @@
+--- lib/scripts.lib.orig 2015-05-12 22:33:57 UTC
++++ lib/scripts.lib
+@@ -382,7 +382,7 @@ POL_Shortcut()
+ # Menus
+ if [ ! "$(POL_Config_Read NO_MENU_ICON)" = "TRUE" ]; then
+ # Do nothing on Mac OS
+- if [ -n "$Categories" -a "$POL_OS" = "Linux" ] || [ -n "$Categories" -a "$POL_OS" = "BSD" ]; then
++ if [ -n "$Categories" -a "$POL_OS" = "Linux" ] || [ -n "$Categories" -a "$POL_OS" = "FreeBSD" ]; then
+ LOCALAPPS="$HOME/.local/share/applications"
+ make_desktop_shortcut "$iconPath" "$ICON_FILENAME" "$LOCALAPPS" "$PLAYONLINUX/playonlinux --run \"$ICON_FILENAME\"" "$binary_name" "$Categories" "playonlinux-"
+ fi
+@@ -992,9 +992,8 @@ POL_Shortcut_AddProfileLink()
+ }
+ POL_LoadVar_Distro ()
+ {
+- if [ "$POL_OS" = "Linux" ] || [ "$POL_OS" == "FreeBSD" ]; then
+- export DISTRO="$(lsb_release -d | cut -d':' -f2 | tr -d \\t)"
+- else
++ case "$POL_OS" in
++ Mac)
+ main_kernel="$(uname -r | cut -d '.' -f 1)"
+ second_kernel="$(uname -r | cut -d '.' -f 2)"
+
+@@ -1005,7 +1004,14 @@ POL_LoadVar_Distro ()
+ [ "$main_kernel" = "12" ] && MacOS="Mountain Lion"
+
+ export DISTRO="$MacOS 10.$(( main_kernel - 4)).$second_kernel ($(uname -r))"
+- fi
++ ;;
++ Linux)
++ export DISTRO="$(lsb_release -d | cut -d':' -f2 | tr -d \\t)"
++ ;;
++ FreeBSD)
++ export DISTRO="$(uname -sr) ($(uname -p))"
++ ;;
++ esac
+ }
+ POL_Shortcut_MakeDesktopShortcut()
+ {
diff --git a/emulators/playonbsd/files/patch-lib_setupwindow.lib b/emulators/playonbsd/files/patch-lib_setupwindow.lib
new file mode 100644
index 000000000000..da42117bbd10
--- /dev/null
+++ b/emulators/playonbsd/files/patch-lib_setupwindow.lib
@@ -0,0 +1,19 @@
+--- lib/setupwindow.lib.orig 2015-05-12 22:33:57 UTC
++++ lib/setupwindow.lib
+@@ -36,7 +36,7 @@ ncs()
+ }
+ ncns()
+ {
+- if [ "$POL_OS" = "Mac" -o "$(POL_Config_Read FORCE_LEGACY_NETCAT)" = "TRUE" ]; then
++ if [ "$POL_OS" != "Linux" -o "$(POL_Config_Read FORCE_LEGACY_NETCAT)" = "TRUE" ]; then
+ nc "$@"
+ else
+ nc -q -1 "$@" 2> /dev/null || nc "$@"
+@@ -178,6 +178,7 @@ POL_SetupWindow_download ()
+ # If provided, make sure the filename is absolute to avoid any misinterpretation from server
+
+ [ -n "$4" ] && FILENAME="$4" || FILENAME="$PWD/"
++echo "$POL_COOKIE POL_SetupWindow_download $$ $(POL_Untab "$1") $(POL_Untab "$2") $3 $(POL_Untab "$FILENAME")" \| ncns "$POL_HOST $POL_PORT" > /tmp/x.log
+ Result="$(echo "$POL_COOKIE POL_SetupWindow_download $$ $(POL_Untab "$1") $(POL_Untab "$2") $3 $(POL_Untab "$FILENAME")" | ncns "$POL_HOST" "$POL_PORT")"
+ # FIXME: Result should send 'fail' if the download has failed. Maybe we could catch it
+ }
diff --git a/emulators/playonbsd/files/patch-lib_variables b/emulators/playonbsd/files/patch-lib_variables
new file mode 100644
index 000000000000..bd63ff658b2b
--- /dev/null
+++ b/emulators/playonbsd/files/patch-lib_variables
@@ -0,0 +1,16 @@
+--- lib/variables.orig 2015-05-12 22:33:57 UTC
++++ lib/variables
+@@ -65,8 +65,11 @@ else
+ eval_gettext() { printf "$@"; }
+ fi
+
+-which shasum > /dev/null 2> /dev/null || shasum () { sha1sum "$@"; }
+-
++which shasum > /dev/null 2> /dev/null || \
++ which sha1sum > /dev/null 2> /dev/null && \
++ shasum () { sha1sum "$@"; } || \
++ shasum () { sha1 "$@"; }
++which md5sum > /dev/null 2> /dev/null || md5sum () { md5 "$@"; }
+
+ if [ "$POL_OS" == "Linux" ]
+ then
diff --git a/emulators/playonbsd/files/patch-lib_wine.lib b/emulators/playonbsd/files/patch-lib_wine.lib
new file mode 100644
index 000000000000..455fa07bd00f
--- /dev/null
+++ b/emulators/playonbsd/files/patch-lib_wine.lib
@@ -0,0 +1,100 @@
+--- lib/wine.lib.orig 2015-05-12 22:33:57 UTC
++++ lib/wine.lib
+@@ -31,7 +31,7 @@ POL_Wine_GetRegValue()
+
+ [ -z "$WINEPREFIX" ] && POL_Debug_Fatal "WINEPREFIX not set"
+ local value
+- [ -e "$WINEPREFIX/user.reg" ] && value="$(grep "$1" "$WINEPREFIX/user.reg" | head -n 1 | tr -d '"' | cut -d= -f2)"
++ [ -e "$WINEPREFIX/user.reg" ] && value="$(grep "$1" "$WINEPREFIX/user.reg" | head -n 1 | tr -d \" | cut -d= -f2)"
+ POL_Debug_Message "Getting registry value $1. Return: $value"
+ echo -n "${value:-default}"
+ }
+@@ -409,12 +409,19 @@ POL_DetectVideoCards () {
+ # Detect known videocards
+ POL_Debug_Message "Gettings GPU informations"
+ case "$POL_OS" in
+- Linux|FreeBSD)
++ Linux)
+ [ -x /usr/sbin/lspci ] && LSPCI=/usr/sbin/lspci || LSPCI=lspci
+ # Device Name|Vendor ID|Device ID\n...
+ # [0300] = VGA compatible controller, [0302] = 3D controller
+ VGA_DEVICES=`$LSPCI -nn | perl -ne 'if (/\[030[02]\]/) { s/.*\]: (.*) \[([0-9a-f]{4}):([0-9a-f]{4})\].*/\1|\2|\3/; print }'`
+ ;;
++ FreeBSD)
++ # Device Name|Vendor ID|Device ID\n...
++ # [0300] = VGA compatible controller, [0302] = 3D controller
++ # Insert "unk" as dummy vendor name for now
++ VGA_DEVICES=`/usr/sbin/pciconf -l | \
++ perl -ne 'if (/^vga/) { s/^.*chip=0x([0-9a-f]{4})([0-9a-f]{4}).*/unk|\2|\1/; print }'`
++ ;;
+ Mac)
+ # Device Name|Vendor ID|Device ID\n...
+ VGA_DEVICES=`system_profiler SPDisplaysDataType | perl -ne 's/^\s+//; if(/Chipset Model:/) { chomp; s/^[^:]*: //; print "$_|" } elsif(/Vendor:/) { chomp; s/.*\(0x(.*)\)/\1/; print "$1|" } elsif (/Device ID:/) { s/^[^:]*: 0x//; print }'`
+@@ -559,7 +566,7 @@ POL_Wine ()
+ fi
+
+
+- if [ "$POL_OS" = "Linux" ] || [ "$POL_OS" = "Mac" ];
++ if [ "$POL_OS" = "Linux" ] || [ "$POL_OS" = "Mac" ] || [ "POL_OS" = "FreeBSD" ];
+ then
+ if [ "$LOGFILE" = "/dev/null" ]; then
+ $BEFORE_WINE $(POL_Config_Read BEFORE_WINE) wine "$@" 2> >(grep -v menubuilder --line-buffered | tee -a "$WINEPREFIX/playonlinux.log" >&2) > >(tee -a "$WINEPREFIX/playonlinux.log")
+@@ -653,6 +660,22 @@ POL_Wine_VersionSignature()
+ fi
+ echo "$WINESIG"
+ }
++POL_Wine_LinkFreeBSD()
++{
++ WINEDIR=$1
++ ARCH=$2
++ WINEVERSION=$3
++ mkdir -p "$WINEDIR/$WINEVERSION"
++ ln -s /usr/local/bin "$WINEDIR/$WINEVERSION/lib"
++ if [ -d /usr/local/lib32 ] ; then
++ ln -s /usr/local/lib32 "$WINEDIR/$WINEVERSION/lib"
++ else
++ ln -s /usr/local/lib "$WINEDIR/$WINEVERSION/lib"
++ fi
++ mkdir -p "$WINEDIR/$WINEVERSION/share"
++ ln -s /usr/local/share/wine/gecko/*.msi "$WINEDIR/$WINEVERSION/share/wine/gecko/" #wine_gecko-$WINEVERSION-$ARCH.msi"
++ ln -s /usr/local/share/wine/mono/*.msi "$WINEDIR/$WINEVERSION/share/wine/mono/" #wine_mono-$WINEVERSION-$ARCH.msi"
++}
+ POL_Wine_InstallVersion()
+ {
+ # Install a wineversion
+@@ -667,6 +690,10 @@ POL_Wine_InstallVersion()
+ OLDPATH="$PWD"
+ WINE_SECTION="$ARCH_PREFIX-$POL_ARCH"
+ WINEDIR="$POL_USER_ROOT/wine/$WINE_SECTION"
++ if [ "$POL_OS" = "FreeBSD" ] ; then
++ POL_Wine_LinkFreeBSD $WINEDIR $POL_ARCH $POL_WINEVERSION
++ return
++ fi
+ touch "$WINEDIR/installing"
+ if [ ! -e "$WINEDIR/$POL_WINEVERSION" ]
+ then
+@@ -676,6 +703,7 @@ POL_Wine_InstallVersion()
+ POL_Debug_Warning "Wine $1 amd64 does not exist. Switching to x86"
+ POL_System_SetArch "x86"
+ POL_Wine_InstallVersion "$1"
++ return
+ else
+ if [ "$WINE_ADDRESS" = "" ]
+ then
+@@ -706,7 +734,6 @@ POL_Wine_InstallVersion()
+ fi
+ fi
+ rm "$WINEDIR/installing"
+-
+ }
+ POL_Wine_InstallCDROM()
+ {
+@@ -743,6 +770,8 @@ POL_Wine_Install_resources()
+ [ "$POL_OS" = "FreeBSD" ] && wos="freebsd"
+ [ "$POL_OS" = "Mac" ] && wos="darwin"
+
++ [ "$POL_OS" = "FreeBSD" ] && return # mono and wine-gecko are automatically installed on FreeBSD
++
+ if [ ! -L "$POL_USER_ROOT/wine/$wos-$arch/$wine_version/share/wine/$resource" ]
+ then
+ POL_Debug_Message "Linking $resource"
diff --git a/emulators/playonbsd/files/patch-python_mainwindow.py b/emulators/playonbsd/files/patch-python_mainwindow.py
new file mode 100644
index 000000000000..26b5c75f84e6
--- /dev/null
+++ b/emulators/playonbsd/files/patch-python_mainwindow.py
@@ -0,0 +1,13 @@
+--- python/mainwindow.py.orig 2015-05-12 22:33:57 UTC
++++ python/mainwindow.py
+@@ -63,8 +63,8 @@ class POLWeb(threading.Thread):
+ def LastVersion(self):
+ if(os.environ["POL_OS"] == "Mac"):
+ fichier_online="version_mac"
+- elif(os.environ["POL_OS"] == "FreeBSD"):
+- fichier_online="version_freebsd"
++# elif(os.environ["POL_OS"] == "FreeBSD"):
++# fichier_online="version_freebsd"
+ else:
+ fichier_online="version2"
+ return os.popen(os.environ["POL_WGET"]+' "'+os.environ["SITE"]+'/'+fichier_online+'.php?v='+os.environ["VERSION"]+'" -T 30 -O-','r').read()
diff --git a/emulators/playonbsd/files/playonbsd.sh.in b/emulators/playonbsd/files/playonbsd.sh.in
new file mode 100644
index 000000000000..6696af664b30
--- /dev/null
+++ b/emulators/playonbsd/files/playonbsd.sh.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+PATH=$PATH:%%PREFIX%%/lib/playonbsd
+exec %%PREFIX%%/bin/bash %%PREFIX%%/lib/playonbsd/playonfreebsd
diff --git a/emulators/playonbsd/pkg-descr b/emulators/playonbsd/pkg-descr
new file mode 100644
index 000000000000..8af704f5f293
--- /dev/null
+++ b/emulators/playonbsd/pkg-descr
@@ -0,0 +1,5 @@
+This is a port of PlayOnLinux to FreeBSD. It allows you to easily install
+and use numerous games and apps designed to run with Microsoft Windows.
+The Windows emulation is provided by Wine.
+
+WWW: http://www.playonlinux.com/
diff --git a/emulators/playonbsd/pkg-plist b/emulators/playonbsd/pkg-plist
new file mode 100644
index 000000000000..1705a2ad6686
--- /dev/null
+++ b/emulators/playonbsd/pkg-plist
@@ -0,0 +1,408 @@
+bin/playonbsd
+lib/playonbsd/CHANGELOG.md
+lib/playonbsd/LICENCE
+lib/playonbsd/README.md
+lib/playonbsd/TRANSLATORS
+lib/playonbsd/bash/POL_Command
+lib/playonbsd/bash/bash_wrapper
+lib/playonbsd/bash/bug_report
+lib/playonbsd/bash/check_fs
+lib/playonbsd/bash/check_gl
+lib/playonbsd/bash/create_prefix
+lib/playonbsd/bash/document_reader
+lib/playonbsd/bash/expert/Executer
+lib/playonbsd/bash/expert/PolShell
+lib/playonbsd/bash/find_python
+lib/playonbsd/bash/install
+lib/playonbsd/bash/install_wver
+lib/playonbsd/bash/installpolpackages
+lib/playonbsd/bash/killall
+lib/playonbsd/bash/make_shortcut
+lib/playonbsd/bash/manual_install
+lib/playonbsd/bash/playonlinux-pkg
+lib/playonbsd/bash/playonlinux-shell
+lib/playonbsd/bash/playonlinux-url_handler
+lib/playonbsd/bash/pol_update_list
+lib/playonbsd/bash/polconfigurator
+lib/playonbsd/bash/polshell
+lib/playonbsd/bash/read_pc_cd
+lib/playonbsd/bash/run_app
+lib/playonbsd/bash/run_exe
+lib/playonbsd/bash/startup
+lib/playonbsd/bash/startup_after_server
+lib/playonbsd/bash/uninstall
+lib/playonbsd/bash/update_git
+lib/playonbsd/bash/winebash
+lib/playonbsd/bin/check_dd_amd64.bz2
+lib/playonbsd/bin/check_dd_x86.bz2
+lib/playonbsd/etc/24-0.gif
+lib/playonbsd/etc/PlayOnLinux.desktop
+lib/playonbsd/etc/PlayOnLinux.directory
+lib/playonbsd/etc/install/applications-accessories.png
+lib/playonbsd/etc/install/applications-development.png
+lib/playonbsd/etc/install/applications-fonts.png
+lib/playonbsd/etc/install/applications-games.png
+lib/playonbsd/etc/install/applications-graphics.png
+lib/playonbsd/etc/install/applications-internet.png
+lib/playonbsd/etc/install/applications-multimedia.png
+lib/playonbsd/etc/install/applications-office.png
+lib/playonbsd/etc/install/applications-other.png
+lib/playonbsd/etc/install/applications-system.png
+lib/playonbsd/etc/install/applications-testing.png
+lib/playonbsd/etc/install/edu.png
+lib/playonbsd/etc/install/emblem-favorite.png
+lib/playonbsd/etc/install/face-smile.png
+lib/playonbsd/etc/install/founder.png
+lib/playonbsd/etc/install/gnome-control-center.png
+lib/playonbsd/etc/install/h-star.png
+lib/playonbsd/etc/install/preferences-desktop-peripherals.png
+lib/playonbsd/etc/install/preferences-desktop.png
+lib/playonbsd/etc/install/spacer.png
+lib/playonbsd/etc/install/spacer16.png
+lib/playonbsd/etc/install/star.png
+lib/playonbsd/etc/install/view-refresh.png
+lib/playonbsd/etc/install/wine-in-use.png
+lib/playonbsd/etc/install/wine-packages.png
+lib/playonbsd/etc/install/wine-unused.png
+lib/playonbsd/etc/install/wine-warning.png
+lib/playonbsd/etc/install/wine.png
+lib/playonbsd/etc/onglet/application-x-executable.png
+lib/playonbsd/etc/onglet/applications-system.png
+lib/playonbsd/etc/onglet/input-gaming.png
+lib/playonbsd/etc/onglet/internet-group-chat.png
+lib/playonbsd/etc/onglet/internet-web-browser.png
+lib/playonbsd/etc/onglet/package-x-generic.png
+lib/playonbsd/etc/onglet/preferences-desktop-locale.png
+lib/playonbsd/etc/onglet/preferences-desktop-theme.png
+lib/playonbsd/etc/onglet/system-users.png
+lib/playonbsd/etc/onglet/user-desktop.png
+lib/playonbsd/etc/onglet/wine.png
+lib/playonbsd/etc/playonlinux-Programmes.menu
+lib/playonbsd/etc/playonlinux.gpg
+lib/playonbsd/etc/playonlinux.png
+lib/playonbsd/etc/playonlinux15.png
+lib/playonbsd/etc/playonlinux16.png
+lib/playonbsd/etc/playonlinux22.png
+lib/playonbsd/etc/playonlinux32.png
+lib/playonbsd/etc/playonmac.icns
+lib/playonbsd/etc/pol_bash
+lib/playonbsd/etc/setups/autorun/left.jpg
+lib/playonbsd/etc/setups/autorun/top.png
+lib/playonbsd/etc/setups/default/left.jpg
+lib/playonbsd/etc/setups/default/playonmac.jpg
+lib/playonbsd/etc/setups/default/top.png
+lib/playonbsd/etc/setups/delete/left.jpg
+lib/playonbsd/etc/setups/delete/top.png
+lib/playonbsd/etc/setups/exec/left.jpg
+lib/playonbsd/etc/setups/exec/top.png
+lib/playonbsd/etc/setups/fonts/left.jpg
+lib/playonbsd/etc/setups/fonts/top.png
+lib/playonbsd/etc/setups/update/top.png
+lib/playonbsd/etc/setups/wineserver/left.jpg
+lib/playonbsd/etc/setups/wineserver/top.png
+lib/playonbsd/etc/star.png
+lib/playonbsd/etc/terminal.applescript
+lib/playonbsd/lang/locale/ar/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ast/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/bg/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/bn/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/bs/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ca/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/cs/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/da/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/de/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/el/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/en_GB/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/es/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/et/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/fi/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/fr/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/gl/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/he/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/hi/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/hr/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/hu/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/id/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/it/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ja/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/jv/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ko/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/lt/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ms/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/nb/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/nl/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/oc/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/pl/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/pt/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/pt_BR/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ro/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/ru/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/si/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/sk/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/sl/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/sr/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/sr@latin/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/sv/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/te/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/th/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/tr/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/uk/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/zh_CN/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/locale/zh_TW/LC_MESSAGES/pol.mo
+lib/playonbsd/lang/po/ar.po
+lib/playonbsd/lang/po/ast.po
+lib/playonbsd/lang/po/bg.po
+lib/playonbsd/lang/po/bn.po
+lib/playonbsd/lang/po/bs.po
+lib/playonbsd/lang/po/ca.po
+lib/playonbsd/lang/po/cs.po
+lib/playonbsd/lang/po/da.po
+lib/playonbsd/lang/po/de.po
+lib/playonbsd/lang/po/el.po
+lib/playonbsd/lang/po/en_GB.po
+lib/playonbsd/lang/po/es.po
+lib/playonbsd/lang/po/et.po
+lib/playonbsd/lang/po/fi.po
+lib/playonbsd/lang/po/fr.po
+lib/playonbsd/lang/po/gl.po
+lib/playonbsd/lang/po/he.po
+lib/playonbsd/lang/po/hi.po
+lib/playonbsd/lang/po/hr.po
+lib/playonbsd/lang/po/hu.po
+lib/playonbsd/lang/po/id.po
+lib/playonbsd/lang/po/it.po
+lib/playonbsd/lang/po/ja.po
+lib/playonbsd/lang/po/jv.po
+lib/playonbsd/lang/po/ko.po
+lib/playonbsd/lang/po/lt.po
+lib/playonbsd/lang/po/ms.po
+lib/playonbsd/lang/po/nb.po
+lib/playonbsd/lang/po/nl.po
+lib/playonbsd/lang/po/oc.po
+lib/playonbsd/lang/po/pl.po
+lib/playonbsd/lang/po/pol.pot
+lib/playonbsd/lang/po/pt.po
+lib/playonbsd/lang/po/pt_BR.po
+lib/playonbsd/lang/po/ro.po
+lib/playonbsd/lang/po/ru.po
+lib/playonbsd/lang/po/si.po
+lib/playonbsd/lang/po/sk.po
+lib/playonbsd/lang/po/sl.po
+lib/playonbsd/lang/po/sr.po
+lib/playonbsd/lang/po/sr@latin.po
+lib/playonbsd/lang/po/sv.po
+lib/playonbsd/lang/po/te.po
+lib/playonbsd/lang/po/th.po
+lib/playonbsd/lang/po/tr.po
+lib/playonbsd/lang/po/uk.po
+lib/playonbsd/lang/po/zh_CN.po
+lib/playonbsd/lang/po/zh_TW.po
+lib/playonbsd/lib/debug.lib
+lib/playonbsd/lib/deprecated.lib
+lib/playonbsd/lib/dosbox.lib
+lib/playonbsd/lib/playonlinux.lib
+lib/playonbsd/lib/plugins.lib
+lib/playonbsd/lib/scripts.lib
+lib/playonbsd/lib/setupwindow.lib
+lib/playonbsd/lib/sources
+lib/playonbsd/lib/variables
+lib/playonbsd/lib/website.lib
+lib/playonbsd/lib/wine.lib
+lib/playonbsd/playonfreebsd
+lib/playonbsd/playonlinux
+lib/playonbsd/playonlinux-bash
+lib/playonbsd/playonlinux-pkg
+lib/playonbsd/playonlinux-shell
+lib/playonbsd/playonlinux-url_handler
+lib/playonbsd/playonmac
+lib/playonbsd/plugins/Capture_2.4.3.pol
+lib/playonbsd/plugins/ScreenCap_0.0.4.pol
+lib/playonbsd/plugins/plugins.lst
+lib/playonbsd/plugins/polvault_4.0.4_all.pol
+lib/playonbsd/plugins/pot.strings
+lib/playonbsd/python/check_python.py
+lib/playonbsd/python/configure.py
+lib/playonbsd/python/debug.py
+lib/playonbsd/python/gui_server.py
+lib/playonbsd/python/guiv3.py
+lib/playonbsd/python/install.py
+lib/playonbsd/python/lib/Variables.py
+lib/playonbsd/python/lib/__init__.py
+lib/playonbsd/python/lib/lng.py
+lib/playonbsd/python/lib/playonlinux.py
+lib/playonbsd/python/lib/wine.py
+lib/playonbsd/python/mainwindow.py
+lib/playonbsd/python/options.py
+lib/playonbsd/python/sp.py
+lib/playonbsd/python/wine_versions.py
+lib/playonbsd/python/wrapper.py
+lib/playonbsd/resources/images/configure/cmd.png
+lib/playonbsd/resources/images/configure/console.png
+lib/playonbsd/resources/images/configure/emblem-system.png
+lib/playonbsd/resources/images/configure/killall.png
+lib/playonbsd/resources/images/configure/monitor.png
+lib/playonbsd/resources/images/configure/reboot.png
+lib/playonbsd/resources/images/configure/regedit.png
+lib/playonbsd/resources/images/configure/registry.png
+lib/playonbsd/resources/images/configure/stop.png
+lib/playonbsd/resources/images/configure/taskmgr.png
+lib/playonbsd/resources/images/configure/update.png
+lib/playonbsd/resources/images/configure/wine-uninstaller.png
+lib/playonbsd/resources/images/configure/wine-winecfg.png
+lib/playonbsd/resources/images/configure/wineboot.png
+lib/playonbsd/resources/images/configure/winecfg.png
+lib/playonbsd/resources/images/emotes/face-angel.png
+lib/playonbsd/resources/images/emotes/face-crying.png
+lib/playonbsd/resources/images/emotes/face-devilish.png
+lib/playonbsd/resources/images/emotes/face-glasses.png
+lib/playonbsd/resources/images/emotes/face-grin.png
+lib/playonbsd/resources/images/emotes/face-kiss.png
+lib/playonbsd/resources/images/emotes/face-monkey.png
+lib/playonbsd/resources/images/emotes/face-plain.png
+lib/playonbsd/resources/images/emotes/face-sad.png
+lib/playonbsd/resources/images/emotes/face-smile-big.png
+lib/playonbsd/resources/images/emotes/face-smile.png
+lib/playonbsd/resources/images/emotes/face-surprise.png
+lib/playonbsd/resources/images/emotes/face-wink.png
+lib/playonbsd/resources/images/icones/add.png
+lib/playonbsd/resources/images/icones/browse.png
+lib/playonbsd/resources/images/icones/cdrom.png
+lib/playonbsd/resources/images/icones/document-new.png
+lib/playonbsd/resources/images/icones/download.png
+lib/playonbsd/resources/images/icones/finish.png
+lib/playonbsd/resources/images/icones/generic.png
+lib/playonbsd/resources/images/icones/list-add.png
+lib/playonbsd/resources/images/icones/new.png
+lib/playonbsd/resources/images/icones/virtual_drive.png
+lib/playonbsd/resources/images/icones/virtual_drive_32.png
+lib/playonbsd/resources/images/icones/virtual_drive_64.png
+lib/playonbsd/resources/images/install/32/applications-accessories.png
+lib/playonbsd/resources/images/install/32/applications-development.png
+lib/playonbsd/resources/images/install/32/applications-fonts.png
+lib/playonbsd/resources/images/install/32/applications-games.png
+lib/playonbsd/resources/images/install/32/applications-graphics.png
+lib/playonbsd/resources/images/install/32/applications-internet.png
+lib/playonbsd/resources/images/install/32/applications-multimedia.png
+lib/playonbsd/resources/images/install/32/applications-office.png
+lib/playonbsd/resources/images/install/32/applications-other.png
+lib/playonbsd/resources/images/install/32/applications-science.png
+lib/playonbsd/resources/images/install/32/applications-system.png
+lib/playonbsd/resources/images/install/32/emblem-favorite.png
+lib/playonbsd/resources/images/install/32/gnome-control-center.png
+lib/playonbsd/resources/images/install/32/preferences-desktop.png
+lib/playonbsd/resources/images/install/32/view-refresh.png
+lib/playonbsd/resources/images/install/applications-accessories.png
+lib/playonbsd/resources/images/install/applications-development.png
+lib/playonbsd/resources/images/install/applications-fonts.png
+lib/playonbsd/resources/images/install/applications-games.png
+lib/playonbsd/resources/images/install/applications-graphics.png
+lib/playonbsd/resources/images/install/applications-internet.png
+lib/playonbsd/resources/images/install/applications-multimedia.png
+lib/playonbsd/resources/images/install/applications-office.png
+lib/playonbsd/resources/images/install/applications-other.png
+lib/playonbsd/resources/images/install/applications-system.png
+lib/playonbsd/resources/images/install/applications-testing.png
+lib/playonbsd/resources/images/install/edu.png
+lib/playonbsd/resources/images/install/emblem-favorite.png
+lib/playonbsd/resources/images/install/face-smile.png
+lib/playonbsd/resources/images/install/founder.png
+lib/playonbsd/resources/images/install/gnome-control-center.png
+lib/playonbsd/resources/images/install/h-star.png
+lib/playonbsd/resources/images/install/preferences-desktop-peripherals.png
+lib/playonbsd/resources/images/install/preferences-desktop.png
+lib/playonbsd/resources/images/install/preferences-system.png
+lib/playonbsd/resources/images/install/spacer.png
+lib/playonbsd/resources/images/install/spacer16.png
+lib/playonbsd/resources/images/install/star.png
+lib/playonbsd/resources/images/install/view-refresh.png
+lib/playonbsd/resources/images/install/wait.gif
+lib/playonbsd/resources/images/install/wait_mini.gif
+lib/playonbsd/resources/images/install/wine-packages.png
+lib/playonbsd/resources/images/install/wine-warning.png
+lib/playonbsd/resources/images/install/wine.png
+lib/playonbsd/resources/images/menu/add.png
+lib/playonbsd/resources/images/menu/bug.png
+lib/playonbsd/resources/images/menu/call-start.png
+lib/playonbsd/resources/images/menu/cdrom.png
+lib/playonbsd/resources/images/menu/change_icon.png
+lib/playonbsd/resources/images/menu/delete.png
+lib/playonbsd/resources/images/menu/dialog-ok.png
+lib/playonbsd/resources/images/menu/extensions.png
+lib/playonbsd/resources/images/menu/folder-wine.png
+lib/playonbsd/resources/images/menu/internet.png
+lib/playonbsd/resources/images/menu/manual.png
+lib/playonbsd/resources/images/menu/media-playback-start.png
+lib/playonbsd/resources/images/menu/media-playback-stop.png
+lib/playonbsd/resources/images/menu/options.png
+lib/playonbsd/resources/images/menu/people.png
+lib/playonbsd/resources/images/menu/people_.png
+lib/playonbsd/resources/images/menu/playonlinux_online.png
+lib/playonbsd/resources/images/menu/polshell.png
+lib/playonbsd/resources/images/menu/polvault.png
+lib/playonbsd/resources/images/menu/prefix-manager.png
+lib/playonbsd/resources/images/menu/regedit.png
+lib/playonbsd/resources/images/menu/repository.png
+lib/playonbsd/resources/images/menu/run.png
+lib/playonbsd/resources/images/menu/settings.png
+lib/playonbsd/resources/images/menu/shortcut.png
+lib/playonbsd/resources/images/menu/star.png
+lib/playonbsd/resources/images/menu/update_git.png
+lib/playonbsd/resources/images/menu/virtual_drive_32.png
+lib/playonbsd/resources/images/menu/virtual_drive_64.png
+lib/playonbsd/resources/images/menu/window-close.png
+lib/playonbsd/resources/images/menu/wine.png
+lib/playonbsd/resources/images/menu/winecfg.png
+lib/playonbsd/resources/images/menu/wineserver.png
+lib/playonbsd/resources/images/pol_min.png
+lib/playonbsd/resources/images/setups/about.png
+lib/playonbsd/resources/images/setups/autorun/left.jpg
+lib/playonbsd/resources/images/setups/autorun/top.png
+lib/playonbsd/resources/images/setups/bug.png
+lib/playonbsd/resources/images/setups/default/playonlinux.jpg
+lib/playonbsd/resources/images/setups/default/playonmac.jpg
+lib/playonbsd/resources/images/setups/default/top.png
+lib/playonbsd/resources/images/setups/delete/left.jpg
+lib/playonbsd/resources/images/setups/delete/left_old.jpg
+lib/playonbsd/resources/images/setups/delete/top.png
+lib/playonbsd/resources/images/setups/exec/left.jpg
+lib/playonbsd/resources/images/setups/exec/top.png
+lib/playonbsd/resources/images/setups/face-sad.png
+lib/playonbsd/resources/images/setups/fonts/left.jpg
+lib/playonbsd/resources/images/setups/fonts/top.png
+lib/playonbsd/resources/images/setups/update/top.png
+lib/playonbsd/resources/images/setups/wait.gif
+lib/playonbsd/resources/images/setups/wait.png
+lib/playonbsd/resources/images/setups/wait/1.png
+lib/playonbsd/resources/images/setups/wait/10.png
+lib/playonbsd/resources/images/setups/wait/11.png
+lib/playonbsd/resources/images/setups/wait/12.png
+lib/playonbsd/resources/images/setups/wait/2.png
+lib/playonbsd/resources/images/setups/wait/3.png
+lib/playonbsd/resources/images/setups/wait/4.png
+lib/playonbsd/resources/images/setups/wait/5.png
+lib/playonbsd/resources/images/setups/wait/6.png
+lib/playonbsd/resources/images/setups/wait/7.png
+lib/playonbsd/resources/images/setups/wait/8.png
+lib/playonbsd/resources/images/setups/wait/9.png
+lib/playonbsd/resources/images/setups/wineserver/left.jpg
+lib/playonbsd/resources/images/setups/wineserver/top.png
+lib/playonbsd/resources/images/toolbar/48/configure.png
+lib/playonbsd/resources/images/toolbar/48/delete.png
+lib/playonbsd/resources/images/toolbar/48/emblem-downloads.png
+lib/playonbsd/resources/images/toolbar/48/install.png
+lib/playonbsd/resources/images/toolbar/48/package.png
+lib/playonbsd/resources/images/toolbar/48/run.png
+lib/playonbsd/resources/images/toolbar/48/stop.png
+lib/playonbsd/resources/images/toolbar/configure.png
+lib/playonbsd/resources/images/toolbar/delete.png
+lib/playonbsd/resources/images/toolbar/emblem-downloads.png
+lib/playonbsd/resources/images/toolbar/install.png
+lib/playonbsd/resources/images/toolbar/messenger.png
+lib/playonbsd/resources/images/toolbar/package.png
+lib/playonbsd/resources/images/toolbar/play.png
+lib/playonbsd/resources/images/toolbar/run.png
+lib/playonbsd/resources/images/toolbar/stop.png
+lib/playonbsd/resources/sounds/irc.wav
+lib/playonbsd/src/check_direct_rendering.c
+lib/playonbsd/tests/bash/test-versionlower
+lib/playonbsd/tests/python/test_versionlower.py