aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 23:24:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 23:24:00 +0000
commitb05569d9996095af3ebbcc2278beadcda16d5829 (patch)
tree558c170cc1ab5ff2c0c671188c267253290a3a6f
parentfa0ab7ce902745c2da89c264c288ae961c265612 (diff)
downloadports-b05569d9996095af3ebbcc2278beadcda16d5829.tar.gz
ports-b05569d9996095af3ebbcc2278beadcda16d5829.zip
This Module decrypts all kind of Cisco encrypted hashes
also referred to as type 7 passwords. Further you can encrypt any given string into a encrypted hash that will be accepted by any Cisco device as an encrypted type 7 password. WWW: http://search.cpan.org/dist/Cisco-Hash/ PR: ports/120498 Submitted by: Tsung-Han Yeh <snowfly at yuntech.edu.tw>
Notes
Notes: svn path=/head/; revision=207423
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Cisco-Hash/Makefile21
-rw-r--r--security/p5-Cisco-Hash/distinfo3
-rw-r--r--security/p5-Cisco-Hash/pkg-descr6
-rw-r--r--security/p5-Cisco-Hash/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 547219e1f011..6ee1f9ad6aa8 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -358,6 +358,7 @@
SUBDIR += p5-Authen-TypeKey
SUBDIR += p5-Business-PayPal-EWP
SUBDIR += p5-CSP
+ SUBDIR += p5-Cisco-Hash
SUBDIR += p5-Crypt-Anubis
SUBDIR += p5-Crypt-AppleTwoFish
SUBDIR += p5-Crypt-Blowfish
diff --git a/security/p5-Cisco-Hash/Makefile b/security/p5-Cisco-Hash/Makefile
new file mode 100644
index 000000000000..4de2ade332c7
--- /dev/null
+++ b/security/p5-Cisco-Hash/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Cisco-Hash
+# Date created: 2008-02-10
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cisco-Hash
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= De- and encrypts Cisco type 7 hashes
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Cisco::Hash.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Cisco-Hash/distinfo b/security/p5-Cisco-Hash/distinfo
new file mode 100644
index 000000000000..c57d0ebc5b8a
--- /dev/null
+++ b/security/p5-Cisco-Hash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cisco-Hash-0.02.tar.gz) = 5c04ca821a57a17ae8ab7deb7dbdf103
+SHA256 (Cisco-Hash-0.02.tar.gz) = 927d1b3147749efcf3120920646c73d41f64b7c608fb2b38e9600de5b3a8a37e
+SIZE (Cisco-Hash-0.02.tar.gz) = 2717
diff --git a/security/p5-Cisco-Hash/pkg-descr b/security/p5-Cisco-Hash/pkg-descr
new file mode 100644
index 000000000000..2a624e94a27c
--- /dev/null
+++ b/security/p5-Cisco-Hash/pkg-descr
@@ -0,0 +1,6 @@
+This Module decrypts all kind of Cisco encrypted hashes
+also referred to as type 7 passwords. Further you can
+encrypt any given string into a encrypted hash that will
+be accepted by any Cisco device as an encrypted type 7 password.
+
+WWW: http://search.cpan.org/dist/Cisco-Hash/
diff --git a/security/p5-Cisco-Hash/pkg-plist b/security/p5-Cisco-Hash/pkg-plist
new file mode 100644
index 000000000000..056bd208c90d
--- /dev/null
+++ b/security/p5-Cisco-Hash/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Cisco/Hash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/Hash/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/Hash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco
+@dirrmtry %%SITE_PERL%%/Cisco