aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-13 11:57:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-13 11:57:28 +0000
commitb06d7d6b1ebcb998f1b9266012febfe0bbd7875d (patch)
tree79a4edf508df2a29d5854785b1f1b04b4f39e0e7
parent3e7557533c9d84e42ee4a302b6da4adb7110aab8 (diff)
downloadports-b06d7d6b1ebcb998f1b9266012febfe0bbd7875d.tar.gz
ports-b06d7d6b1ebcb998f1b9266012febfe0bbd7875d.zip
graphics/py-rasterio: Update to 1.3.10
-rw-r--r--graphics/py-rasterio/Makefile16
-rw-r--r--graphics/py-rasterio/distinfo6
-rw-r--r--graphics/py-rasterio/files/patch-pyproject.toml16
3 files changed, 31 insertions, 7 deletions
diff --git a/graphics/py-rasterio/Makefile b/graphics/py-rasterio/Makefile
index edb6ad383fac..4898aa3367c1 100644
--- a/graphics/py-rasterio/Makefile
+++ b/graphics/py-rasterio/Makefile
@@ -1,5 +1,5 @@
PORTNAME= rasterio
-PORTVERSION= 1.3.9
+PORTVERSION= 1.3.10
CATEGORIES= graphics python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,9 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= gdal>=3.1:graphics/gdal \
- ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= gdal>=3.1:graphics/gdal \
${PYTHON_PKGNAMEPREFIX}affine>=0:math/py-affine@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}attrs>=0:devel/py-attrs@${PY_FLAVOR} \
@@ -25,7 +27,7 @@ RUN_DEPENDS= gdal>=3.1:graphics/gdal \
${PYTHON_PKGNAMEPREFIX}snuggs>=1.4.1:math/py-snuggs@${PY_FLAVOR}
USES= compiler:c++11-lang python
-USE_PYTHON= autoplist concurrent cython distutils
+USE_PYTHON= autoplist concurrent cython pep517
OPTIONS_DEFINE= PLOT S3
PLOT_DESC= Plotting support
@@ -37,4 +39,10 @@ S3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>=1.2.4:www/py-boto3@${PY_FLAVOR}
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=0:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-rasterio/distinfo b/graphics/py-rasterio/distinfo
index a01ca8ef9c3f..4acd8c11bc43 100644
--- a/graphics/py-rasterio/distinfo
+++ b/graphics/py-rasterio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698341053
-SHA256 (rasterio-1.3.9.tar.gz) = fc6d0d290492fa1a5068711cfebb21cc936968891b7ed9da0690c8a7388885c5
-SIZE (rasterio-1.3.9.tar.gz) = 411741
+TIMESTAMP = 1713001140
+SHA256 (rasterio-1.3.10.tar.gz) = ce182c735b4f9e8735d90600607ecab15ef895eb8aa660bf665751529477e326
+SIZE (rasterio-1.3.10.tar.gz) = 412856
diff --git a/graphics/py-rasterio/files/patch-pyproject.toml b/graphics/py-rasterio/files/patch-pyproject.toml
new file mode 100644
index 000000000000..65af1762fb06
--- /dev/null
+++ b/graphics/py-rasterio/files/patch-pyproject.toml
@@ -0,0 +1,16 @@
+--- pyproject.toml.orig 2024-04-10 14:59:49 UTC
++++ pyproject.toml
+@@ -1,10 +1,9 @@ requires = [
+ [build-system]
+ requires = [
+- "setuptools>=67.8",
++ "setuptools>=61",
+ "wheel",
+- "cython~=3.0.2",
+- "numpy==2.0.0rc1; python_version >= '3.9'",
+- "oldest-supported-numpy; python_version < '3.9'"
++ "cython",
++ "numpy",
+ ]
+
+ build-backend = "setuptools.build_meta"