aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2023-06-26 08:16:09 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2023-06-26 08:16:09 +0000
commitb07a268172931ffc436988a57e9aec2f22523f39 (patch)
tree445310ddaab3a521fe7d2c5420a41f9cb3c19ed0
parent77842029d172412f3a832b577defc4f90c56221a (diff)
downloadports-b07a268172931ffc436988a57e9aec2f22523f39.tar.gz
ports-b07a268172931ffc436988a57e9aec2f22523f39.zip
net/py-pyfixbuf: fix build with llvm 16
-rw-r--r--net/py-pyfixbuf/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/py-pyfixbuf/Makefile b/net/py-pyfixbuf/Makefile
index 50cd2ea98a22..605517425ac9 100644
--- a/net/py-pyfixbuf/Makefile
+++ b/net/py-pyfixbuf/Makefile
@@ -16,7 +16,13 @@ LICENSE_PERMS_GPLR= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libfixbuf.so:net/libfixbuf
-USES= pkgconfig python:3.6+
+USES= compiler pkgconfig python
USE_PYTHON= distutils autoplist
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CPPFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
+.include <bsd.port.post.mk>