aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 16:56:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-01-11 18:43:49 +0000
commitb08d9d47c2d600a0bc694f1828a2ec8535082fbf (patch)
tree3b7101c3510dedfc0438038112cf069aa7880c40
parent2c7fd167ef29eb66efbfd8d7ff7894e1aea268d6 (diff)
www/rubygem-jsbundling-rails: Add rubygem-jsbundling-rails 1.0.0
Use esbuild, rollup.js, or Webpack to bundle your JavaScript, then deliver it via the asset pipeline in Rails. This gem provides installers to get you going with the bundler of your choice in a new Rails application, and a convention to use app/assets/builds to hold your bundled output as artifacts that are not checked into source control (the installer adds this directory to .gitignore by default). You develop using this approach by running the bundler in watch mode in a terminal with yarn build --watch (and your Rails server in another, if you're not using something like puma-dev). You can also use ./bin/dev, which will start both the Rails server and the JS build watcher (along with a CSS build watcher, if you're also using cssbundling-rails). WWW: https://github.com/rails/jsbundling-rails
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-jsbundling-rails/Makefile21
-rw-r--r--www/rubygem-jsbundling-rails/distinfo3
-rw-r--r--www/rubygem-jsbundling-rails/pkg-descr14
4 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb4cf69e9a57..7955422d10db 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1968,6 +1968,7 @@
SUBDIR += rubygem-jquery-turbolinks
SUBDIR += rubygem-jquery-ui-rails-rails4
SUBDIR += rubygem-jruby-rack
+ SUBDIR += rubygem-jsbundling-rails
SUBDIR += rubygem-jsobfu
SUBDIR += rubygem-json-jwt
SUBDIR += rubygem-jwt
diff --git a/www/rubygem-jsbundling-rails/Makefile b/www/rubygem-jsbundling-rails/Makefile
new file mode 100644
index 000000000000..1650a017aab7
--- /dev/null
+++ b/www/rubygem-jsbundling-rails/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= jsbundling-rails
+PORTVERSION= 1.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Bundle and transpile JavaScript in Rails with esbuild, rollup.js, or Webpack
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-railties70>=6.0.0:www/rubygem-railties70
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-jsbundling-rails/distinfo b/www/rubygem-jsbundling-rails/distinfo
new file mode 100644
index 000000000000..116f07b72d42
--- /dev/null
+++ b/www/rubygem-jsbundling-rails/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1641045744
+SHA256 (rubygem/jsbundling-rails-1.0.0.gem) = 82db201c5da82530d94ac8d797d4dffc24a51b4a53ac9f13eae0680d21f9aab7
+SIZE (rubygem/jsbundling-rails-1.0.0.gem) = 9216
diff --git a/www/rubygem-jsbundling-rails/pkg-descr b/www/rubygem-jsbundling-rails/pkg-descr
new file mode 100644
index 000000000000..8c5dfdc5ced3
--- /dev/null
+++ b/www/rubygem-jsbundling-rails/pkg-descr
@@ -0,0 +1,14 @@
+Use esbuild, rollup.js, or Webpack to bundle your JavaScript, then deliver it
+via the asset pipeline in Rails. This gem provides installers to get you going
+with the bundler of your choice in a new Rails application, and a convention to
+use app/assets/builds to hold your bundled output as artifacts that are not
+checked into source control (the installer adds this directory to .gitignore by
+default).
+
+You develop using this approach by running the bundler in watch mode in a
+terminal with yarn build --watch (and your Rails server in another, if you're
+not using something like puma-dev). You can also use ./bin/dev, which will start
+both the Rails server and the JS build watcher (along with a CSS build watcher,
+if you're also using cssbundling-rails).
+
+WWW: https://github.com/rails/jsbundling-rails