aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 05:41:31 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-27 05:41:31 +0000
commitb08e1a20aeb371ce63c0ecc456ef2489791e32c6 (patch)
treeace3f46cf6744e7d820d4b4d492a638e40bb081e
parent70a062d6311ada2f53dcc920a52c1ff512dded6b (diff)
downloadports-b08e1a20aeb371ce63c0ecc456ef2489791e32c6.tar.gz
ports-b08e1a20aeb371ce63c0ecc456ef2489791e32c6.zip
A set of perl modules that allows you to enhance logging capabilities
PR: ports/27589 Submitted by: Jesse McConnell <jesse_mcconnell@hotmail.com>
Notes
Notes: svn path=/head/; revision=43104
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Agent/Makefile42
-rw-r--r--devel/p5-Log-Agent/distinfo1
-rw-r--r--devel/p5-Log-Agent/pkg-comment1
-rw-r--r--devel/p5-Log-Agent/pkg-descr20
-rw-r--r--devel/p5-Log-Agent/pkg-plist60
6 files changed, 125 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 44092722a0bd..5e0f2ac17180 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -320,6 +320,7 @@
SUBDIR += p5-Locale-PGetText
SUBDIR += p5-Locale-gettext
SUBDIR += p5-LockFile-Simple
+ SUBDIR += p5-Log-Agent
SUBDIR += p5-Log-Dispatch
SUBDIR += p5-Mac-FileSpec-Unixish
SUBDIR += p5-Make
diff --git a/devel/p5-Log-Agent/Makefile b/devel/p5-Log-Agent/Makefile
new file mode 100644
index 000000000000..e65a8099188f
--- /dev/null
+++ b/devel/p5-Log-Agent/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Net-Server
+# Date created: 24 Apr 2001
+# Whom: Jesse McConnell <jesse_mcconnell@hotmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Agent
+PORTVERSION= 0.2.8
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Log
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jesse_mcconnell@hotmail.com
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Log::Agent.3 \
+ Log::Agent::Tag_List.3 \
+ Log::Agent::Tag::Callback.3 \
+ Log::Agent::Channel.3 \
+ Log::Agent::Driver::File.3 \
+ Log::Agent::Tag.3 \
+ Log::Agent::Driver::Syslog.3 \
+ Log::Agent::Tag::Caller.3 \
+ Log::Agent::Driver::Default.3 \
+ Log::Agent::Tag::String.3 \
+ Log::Agent::Stamping.3 \
+ Log::Agent::Message.3 \
+ Log::Agent::Channel::File.3 \
+ Log::Agent::Channel::Syslog.3 \
+ Log::Agent::Driver::Silent.3 \
+ Log::Agent::Priorities.3 \
+ Log::Agent::Driver.3 \
+ Log::Agent::Tag::Priority.3 \
+ Log::Agent::Channel::Handle.3 \
+ Log::Agent::Driver::Datum.3 \
+ Log::Agent::File::Native.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Agent/distinfo b/devel/p5-Log-Agent/distinfo
new file mode 100644
index 000000000000..a25bab761b10
--- /dev/null
+++ b/devel/p5-Log-Agent/distinfo
@@ -0,0 +1 @@
+MD5 (Log-Agent-0.2.8.tar.gz) = fc59762caba048c5cbff9b5ba2f4b7dc
diff --git a/devel/p5-Log-Agent/pkg-comment b/devel/p5-Log-Agent/pkg-comment
new file mode 100644
index 000000000000..9b32678bb158
--- /dev/null
+++ b/devel/p5-Log-Agent/pkg-comment
@@ -0,0 +1 @@
+A set of perl modules that allows you to enhance logging capabilities
diff --git a/devel/p5-Log-Agent/pkg-descr b/devel/p5-Log-Agent/pkg-descr
new file mode 100644
index 000000000000..e57c04a038e3
--- /dev/null
+++ b/devel/p5-Log-Agent/pkg-descr
@@ -0,0 +1,20 @@
+The Log::Agent module provides an abstract layer for logging and tracing, which
+is independant from the actual method used to physically perform those
+activities. It acts as an agent (hence the name) that collects the requests and
+delegates processing to a sublayer: the logging driver.
+
+The Log::Agent module is meant to be used in all reusable components, since
+they cannot know in advance how the application which ends up using them will
+perform its logging activities: either by emitting messages on stdout and
+errors on stderr, or by directing messages to logfiles, or by using syslog(3).
+
+The logging interface is common for all the logging drivers, and is therefore
+the result of a compromise between many logging schemes: any information given
+at this level must be either handled by all drivers, or may be ignored
+depending on the application's final choice.
+
+WARNING: THIS INTERFACE IS STILL SOMEWHAT ALPHA AND COULD STILL CHANGE
+DEPENDING ON THE FEEDBACK THE AUTHOR RECIEVES, WITHOUT ANY BACKWARD
+COMPATIBILITY ASSURANCE.
+
+Author: Raphael Manfredi <Raphael_Manfredi@pobox.com>
diff --git a/devel/p5-Log-Agent/pkg-plist b/devel/p5-Log-Agent/pkg-plist
new file mode 100644
index 000000000000..eb6380a84b10
--- /dev/null
+++ b/devel/p5-Log-Agent/pkg-plist
@@ -0,0 +1,60 @@
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Channel.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Channel/File.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Channel/Handle.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Channel/Syslog.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver/Datum.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver/Default.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver/File.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver/Silent.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver/Syslog.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/File_Pool.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/File/Native.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Formatting.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Message.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Prefixer.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Priorities.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Stamping.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag_List.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag/Callback.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag/Caller.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag/Priority.pm
+lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag/String.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/DATUM_is_here.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/Priorities/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/Priorities/level_from_prio.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/Priorities/prio_from_level.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/Priorities/priority_level.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/bug.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/inited.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/log_default.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logcarp.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logconfig.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logconfess.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logcroak.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logdbg.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logdie.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logerr.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logsay.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logtags.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logtrc.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logwarn.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logxcarp.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logxcroak.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/logwrite.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/prio_tag.al
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Log/Agent/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Log/Agent
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Log 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent/Priorities
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Log/Agent
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Log 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Channel
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Driver
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/File
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Log/Agent/Tag
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Log/Agent
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Log 2>/dev/null || true