aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-01-24 18:24:03 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-01-24 18:24:03 +0000
commitb091501256db06312d5f6e5e6862b9dbb0a32b55 (patch)
tree21656046731870e22522e48469033270f8b237c3
parent612db1e47dc340230cc3aa4a959092764c8f830c (diff)
downloadports-b091501256db06312d5f6e5e6862b9dbb0a32b55.tar.gz
ports-b091501256db06312d5f6e5e6862b9dbb0a32b55.zip
Add p5-HTTP-MHTTP 0.15, low level access to the HTTP protocol.
Notes
Notes: svn path=/head/; revision=98973
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTTP-MHTTP/Makefile29
-rw-r--r--www/p5-HTTP-MHTTP/distinfo1
-rw-r--r--www/p5-HTTP-MHTTP/pkg-descr17
-rw-r--r--www/p5-HTTP-MHTTP/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 270d72cf0632..b9f327851b8d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -412,6 +412,7 @@
SUBDIR += p5-HTTP-DAV
SUBDIR += p5-HTTP-GHTTP
SUBDIR += p5-HTTP-Lite
+ SUBDIR += p5-HTTP-MHTTP
SUBDIR += p5-HTTP-MobileAgent
SUBDIR += p5-HTTP-WebTest
SUBDIR += p5-HTTPD-Log-Filter
diff --git a/www/p5-HTTP-MHTTP/Makefile b/www/p5-HTTP-MHTTP/Makefile
new file mode 100644
index 000000000000..a51ef775aa67
--- /dev/null
+++ b/www/p5-HTTP-MHTTP/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: HTTP-MHTTP
+# Date created: 22 January 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP-MHTTP
+PORTVERSION= 0.15
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTTP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Low level access to the HTTP protocol
+
+PERL_CONFIGURE= yes
+USE_OPENSSL= yes
+CONFIGURE_ENV= GOTSSL=yes
+CONFIGURE_ARGS= --default
+
+MAN3= HTTP::MHTTP.3
+
+post-patch:
+ @${PERL} -pi -e 's!(?<=POSSIBLE_SSL_DIRS = qw\().*(?=\);)!${OPENSSLBASE}!;' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTTP-MHTTP/distinfo b/www/p5-HTTP-MHTTP/distinfo
new file mode 100644
index 000000000000..743fbfa1bab4
--- /dev/null
+++ b/www/p5-HTTP-MHTTP/distinfo
@@ -0,0 +1 @@
+MD5 (HTTP-MHTTP-0.15.tar.gz) = 4df9d88421d02ff48a7008b5476187b9
diff --git a/www/p5-HTTP-MHTTP/pkg-descr b/www/p5-HTTP-MHTTP/pkg-descr
new file mode 100644
index 000000000000..dd437edb6a7b
--- /dev/null
+++ b/www/p5-HTTP-MHTTP/pkg-descr
@@ -0,0 +1,17 @@
+HTTP::MHTTP - this library provides reasonably low level access to the
+HTTP protocol, for perl. This does not replace LWP (what possibly could
+:-) but is a cut for speed. It also supports all of HTTP 1.0, so you
+have GET, POST, PUT, HEAD, and DELETE. Some support of HTTP 1.1 is
+available - specifically Transfer-Encoding = chunked and the Keep-Alive
+extensions.
+
+Additionally - rudimentary SSL support compiled in. This effectively
+enables negotiation of TLS, but does not validate the certificates.
+
+A way faster http access library that uses C extension based on mhttp to
+do the calls.
+
+WWW: http://search.cpan.org/dist/HTTP-MHTTP/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/www/p5-HTTP-MHTTP/pkg-plist b/www/p5-HTTP-MHTTP/pkg-plist
new file mode 100644
index 000000000000..adeb772b59ac
--- /dev/null
+++ b/www/p5-HTTP-MHTTP/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MHTTP/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MHTTP/MHTTP.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MHTTP/MHTTP.so
+%%SITE_PERL%%/%%PERL_ARCH%%/HTTP/MHTTP.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP/MHTTP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/HTTP 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTTP 2>/dev/null || true