aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:16:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:06 +0000
commitb0a0cacc08d7ba9aad4fa2f176758c1bb332a1bf (patch)
tree4bb68705435b93ac3343b12aa5aa6ed1fd87ef80
parente2bd8b024ee9d1e20c7f1a2fea371b9dbcaa7a2b (diff)
downloadports-b0a0cacc08d7ba9aad4fa2f176758c1bb332a1bf.tar.gz
ports-b0a0cacc08d7ba9aad4fa2f176758c1bb332a1bf.zip
devel/py-thinc: Add py-thinc 8.2.3
Thinc is a lightweight deep learning library that offers an elegant, type-checked, functional-programming API for composing models, with support for layers defined in other frameworks such as PyTorch, TensorFlow and MXNet. You can use Thinc as an interface layer, a standalone toolkit or a flexible way to develop new models. Previous versions of Thinc have been running quietly in production in thousands of companies, via both spaCy and Prodigy.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-thinc/Makefile41
-rw-r--r--devel/py-thinc/distinfo3
-rw-r--r--devel/py-thinc/pkg-descr6
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 22274e2fa1b0..7a51b415a038 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5727,6 +5727,7 @@
SUBDIR += py-testscenarios
SUBDIR += py-testtools
SUBDIR += py-thefuzz
+ SUBDIR += py-thinc
SUBDIR += py-threadpoolctl
SUBDIR += py-threema-msgapi
SUBDIR += py-thrift
diff --git a/devel/py-thinc/Makefile b/devel/py-thinc/Makefile
new file mode 100644
index 000000000000..349101d06b9b
--- /dev/null
+++ b/devel/py-thinc/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= thinc
+PORTVERSION= 8.2.3
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Refreshing functional take on deep learning
+WWW= https://thinc.ai/ \
+ https://github.com/explosion/thinc
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=0.7.8<0.8.0:math/py-blis@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.25.0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}preshed3>=3.0.2<3.1.0:devel/py-preshed3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blis>=0.7.8<0.8.0:math/py-blis@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}catalogue>=2.0.4<2.1.0:devel/py-catalogue@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}confection>=0.0.1<1.0.0:devel/py-confection@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cymem>=2.0.2<2.1.0:devel/py-cymem@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}murmurhash>=0.28.0<1.1.0:devel/py-murmurhash@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.19.0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=20.0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}preshed3>=3.0.2<3.1.0:devel/py-preshed3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pydantic2>=1.7.4<3.0.0:devel/py-pydantic2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}srsly>=2.4.0<3.0.0:devel/py-srsly@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wasabi>=0.8.1<1.2.0:textproc/py-wasabi@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython pep517
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/devel/py-thinc/distinfo b/devel/py-thinc/distinfo
new file mode 100644
index 000000000000..9391e7da1f83
--- /dev/null
+++ b/devel/py-thinc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448828
+SHA256 (thinc-8.2.3.tar.gz) = f5afc5222912a80bda8bdcec958362a2ba538d7027dc8db6154845d2859dca76
+SIZE (thinc-8.2.3.tar.gz) = 192870
diff --git a/devel/py-thinc/pkg-descr b/devel/py-thinc/pkg-descr
new file mode 100644
index 000000000000..877f18b24753
--- /dev/null
+++ b/devel/py-thinc/pkg-descr
@@ -0,0 +1,6 @@
+Thinc is a lightweight deep learning library that offers an elegant,
+type-checked, functional-programming API for composing models, with support for
+layers defined in other frameworks such as PyTorch, TensorFlow and MXNet. You
+can use Thinc as an interface layer, a standalone toolkit or a flexible way to
+develop new models. Previous versions of Thinc have been running quietly in
+production in thousands of companies, via both spaCy and Prodigy.