aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2021-11-30 06:01:29 +0000
committerXin LI <delphij@FreeBSD.org>2021-11-30 06:02:52 +0000
commitb0c353539e191aac84900dded1999958b9f710c8 (patch)
treed73eacba5c16facd0b5eff338f82f7b39984d3ed
parent16fde2029009314b42da37011c448cb1fac19a82 (diff)
downloadports-b0c353539e191aac84900dded1999958b9f710c8.tar.gz
ports-b0c353539e191aac84900dded1999958b9f710c8.zip
net/openldap2[56]-server: Make GSSAPI option work.
Reported by: sunpoet
-rw-r--r--net/openldap25-server/Makefile2
-rw-r--r--net/openldap26-server/Makefile2
2 files changed, 4 insertions, 0 deletions
diff --git a/net/openldap25-server/Makefile b/net/openldap25-server/Makefile
index e1d209d7cd3f..4734709e76ab 100644
--- a/net/openldap25-server/Makefile
+++ b/net/openldap25-server/Makefile
@@ -103,6 +103,7 @@ OPTIONS_GROUP_OVLYS+= TRANSLUCENT
OPTIONS_GROUP_OVLYS+= UNIQUE
OPTIONS_GROUP_OVLYS+= VALSORT
+OPTIONS_DEFINE+= GSSAPI
OPTIONS_DEFINE+= DYNACL ACI
OPTIONS_DEFINE+= RLOOKUPS SLP SLAPI
OPTIONS_DEFINE+= PBKDF2
@@ -192,6 +193,7 @@ DNSSRV_CONFIGURE_ENABLE= dnssrv=mod
DYNACL_CONFIGURE_ENABLE= dynacl
DYNGROUP_CONFIGURE_ENABLE= dyngroup=mod
DYNLIST_CONFIGURE_ENABLE= dynlist=mod
+GSSAPI_RUN_DEPENDS= cyrus-sasl-gssapi>0:security/cyrus-sasl2-gssapi
HOMEDIR_CONFIGURE_ENABLE= homedir=mod
LLOADD_CONFIGURE_ENABLE= balancer=mod
LLOADD_LIB_DEPENDS= libevent.so:devel/libevent
diff --git a/net/openldap26-server/Makefile b/net/openldap26-server/Makefile
index ecbff399d53e..58bf40274bfe 100644
--- a/net/openldap26-server/Makefile
+++ b/net/openldap26-server/Makefile
@@ -102,6 +102,7 @@ OPTIONS_GROUP_OVLYS+= TRANSLUCENT
OPTIONS_GROUP_OVLYS+= UNIQUE
OPTIONS_GROUP_OVLYS+= VALSORT
+OPTIONS_DEFINE+= GSSAPI
OPTIONS_DEFINE+= DYNACL ACI
OPTIONS_DEFINE+= RLOOKUPS SLP SLAPI
OPTIONS_DEFINE+= PBKDF2
@@ -191,6 +192,7 @@ DNSSRV_CONFIGURE_ENABLE= dnssrv=mod
DYNACL_CONFIGURE_ENABLE= dynacl
DYNGROUP_CONFIGURE_ENABLE= dyngroup=mod
DYNLIST_CONFIGURE_ENABLE= dynlist=mod
+GSSAPI_RUN_DEPENDS= cyrus-sasl-gssapi>0:security/cyrus-sasl2-gssapi
HOMEDIR_CONFIGURE_ENABLE= homedir=mod
LLOADD_CONFIGURE_ENABLE= balancer=mod
LLOADD_LIB_DEPENDS= libevent.so:devel/libevent