aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2022-05-29 21:54:42 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2022-06-06 18:19:10 +0000
commitb16eb860cc492d498eea6df7f481c93bbc851167 (patch)
treead4432a88cbf1b356c7f65aa9cb308f495f59123
parent3012ca2179ceb0e389fbeb30a66f9fe60a3cf5a1 (diff)
downloadports-b16eb860cc492d498eea6df7f481c93bbc851167.tar.gz
ports-b16eb860cc492d498eea6df7f481c93bbc851167.zip
*/*: Repair after switching to versioned Go ports
- Add 1.17 to USES=go for ports that still need go117, remove GO_PORT; - Add missing ${SETENV} ${MAKE_ENV} to repair BINARY_ALIAS; - Remove explicit dependencies on lang/go. PR: 264336 Reviewed by: ygy jwb yuri mikael drtr0jan@yandex.ru decke mat Differential Revision: https://reviews.freebsd.org/D35346
-rw-r--r--biology/ncbi-entrez-direct/Makefile2
-rw-r--r--devel/gocheese/Makefile2
-rw-r--r--devel/please/Makefile3
-rw-r--r--net-im/gotosocial/Makefile2
-rw-r--r--net-im/nextcloud-spreed-signaling/Makefile6
-rw-r--r--net-mgmt/chronograf/Makefile2
-rw-r--r--net/ooni-probe-cli/Makefile2
-rw-r--r--security/crowdsec-firewall-bouncer/Makefile5
-rw-r--r--security/crowdsec/Makefile3
-rw-r--r--sysutils/chezmoi/Makefile2
-rw-r--r--sysutils/containerd/Makefile5
-rw-r--r--sysutils/datadog-agent/Makefile10
-rw-r--r--sysutils/ipfs-go/Makefile3
-rw-r--r--sysutils/ipget/Makefile2
-rw-r--r--sysutils/minikube/Makefile2
-rw-r--r--www/adguardhome/Makefile3
16 files changed, 23 insertions, 31 deletions
diff --git a/biology/ncbi-entrez-direct/Makefile b/biology/ncbi-entrez-direct/Makefile
index 1944a8c31e8c..2dc474a0acf9 100644
--- a/biology/ncbi-entrez-direct/Makefile
+++ b/biology/ncbi-entrez-direct/Makefile
@@ -75,7 +75,7 @@ pre-configure:
do-build:
@${CP} ${FILESDIR}/modules.txt ${WRKSRC}/cmd/vendor
@${CP} -R ${WRKSRC}/eutils ${WRKSRC}/cmd/vendor
- @cd ${WRKSRC}/cmd && ${FILESDIR}/build-cmd
+ @cd ${WRKSRC}/cmd && ${SETENV} ${MAKE_ENV} ${FILESDIR}/build-cmd
do-install:
cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/gocheese/Makefile b/devel/gocheese/Makefile
index 1209e0ae46c7..c963a0daac23 100644
--- a/devel/gocheese/Makefile
+++ b/devel/gocheese/Makefile
@@ -18,7 +18,7 @@ PLIST_FILES= ${DOCSDIR}/README \
bin/pyshop2packages.sh
do-build:
- @cd ${WRKSRC} ; ${ENV} GOPATH=${WRKSRC} GO111MODULE=off go build -ldflags="-s -w" -o gocheese go.cypherpunks.ru/gocheese/v2
+ @cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} GO111MODULE=off ${GO_CMD} build -ldflags="-s -w" -o gocheese go.cypherpunks.ru/gocheese/v2
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/devel/please/Makefile b/devel/please/Makefile
index 9fdcf2b09b49..5de3a81bb996 100644
--- a/devel/please/Makefile
+++ b/devel/please/Makefile
@@ -11,8 +11,7 @@ COMMENT= High-performance extensible build system for reproducible builds
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/bin/go:lang/go \
- bash:shells/bash \
+BUILD_DEPENDS= bash:shells/bash \
ca_root_nss>0:security/ca_root_nss \
git:devel/git \
protoc:devel/protobuf
diff --git a/net-im/gotosocial/Makefile b/net-im/gotosocial/Makefile
index fb0ff7e70bb0..350b66896baf 100644
--- a/net-im/gotosocial/Makefile
+++ b/net-im/gotosocial/Makefile
@@ -38,7 +38,7 @@ post-patch:
.endif
do-build:
- @(cd ${WRKSRC} && ${SETENV} \
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
VERSION=${DISTVERSION} COMMIT=${GH_TAGNAME} scripts/build.sh )
do-install:
diff --git a/net-im/nextcloud-spreed-signaling/Makefile b/net-im/nextcloud-spreed-signaling/Makefile
index 63eef8f339e3..bebb154789e5 100644
--- a/net-im/nextcloud-spreed-signaling/Makefile
+++ b/net-im/nextcloud-spreed-signaling/Makefile
@@ -8,9 +8,7 @@ COMMENT= Signaling server used for Nextcloud Talk
LICENSE= AGPLv3
-BUILD_DEPENDS= go:lang/go
-
-USES= gmake
+USES= gmake go:no_targets
USERS= signaling
GROUPS= signaling
@@ -48,6 +46,6 @@ GH_TUPLE= coreos:go-semver:v0.2.0:coreos_go_semver/vendor/src/github.com/coreos/
uber-go:multierr:v1.1.0:uber_go_multierr/vendor/src/go.uber.org/multierr \
uber-go:zap:v1.10.0:uber_go_zap/vendor/src/go.uber.org/zap
-MAKE_ENV= GO111MODULE="off"
+MAKE_ENV= ${GO_ENV}
.include <bsd.port.mk>
diff --git a/net-mgmt/chronograf/Makefile b/net-mgmt/chronograf/Makefile
index b01aac080346..cf0fd227df1b 100644
--- a/net-mgmt/chronograf/Makefile
+++ b/net-mgmt/chronograf/Makefile
@@ -91,6 +91,6 @@ pre-build:
npm_config_tarball=${DISTDIR}/${DIST_SUBDIR}/node-v${NODEJS_VERSION}-headers.tar.gz \
yarn --frozen-lockfile --offline --no-progress --no-emoji
cd ${WRKSRC}/ui && ${SETENV} ${YARN_ENV} yarn run build
- cd ${WRKSRC} && ${GMAKE} .bindata
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} .bindata
.include <bsd.port.post.mk>
diff --git a/net/ooni-probe-cli/Makefile b/net/ooni-probe-cli/Makefile
index fc7f6c8039da..5ac4f77c802d 100644
--- a/net/ooni-probe-cli/Makefile
+++ b/net/ooni-probe-cli/Makefile
@@ -12,7 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
-USES= go:modules
+USES= go:1.17,modules
USE_GITHUB= yes
USE_GITLAB= nodefault
diff --git a/security/crowdsec-firewall-bouncer/Makefile b/security/crowdsec-firewall-bouncer/Makefile
index db4d992dcf88..427f7f3e659a 100644
--- a/security/crowdsec-firewall-bouncer/Makefile
+++ b/security/crowdsec-firewall-bouncer/Makefile
@@ -9,10 +9,9 @@ COMMENT= CrowdSec bouncer written in golang for firewalls
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= git:devel/git@lite \
- go:lang/go
+BUILD_DEPENDS= git:devel/git@lite
-USES= gmake
+USES= gmake go:no_targets
USE_GITHUB= yes
GH_ACCOUNT= crowdsecurity
diff --git a/security/crowdsec/Makefile b/security/crowdsec/Makefile
index 246c295893a9..4d46a8f0751b 100644
--- a/security/crowdsec/Makefile
+++ b/security/crowdsec/Makefile
@@ -10,10 +10,9 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= git:devel/git@lite \
- go:lang/go \
jq:textproc/jq
-USES= gmake
+USES= gmake go:no_targets
USE_GITHUB= yes
GH_ACCOUNT= crowdsecurity
diff --git a/sysutils/chezmoi/Makefile b/sysutils/chezmoi/Makefile
index 96ee2a503a63..6772c110dbe5 100644
--- a/sysutils/chezmoi/Makefile
+++ b/sysutils/chezmoi/Makefile
@@ -148,7 +148,7 @@ SOURCE_DATE_EPOCH_CMD= date -ur $$(grep TIMESTAMP ${DISTINFO_FILE} | ${SED} -e '
do-build-DOCS-on:
@${CP} ${_DISTDIR}/mermaid@8.8.0/dist/mermaid.min.js ${WRKSRC}/assets/chezmoi.io
- (cd ${WRKSRC}/assets/chezmoi.io && mkdocs build)
+ (cd ${WRKSRC}/assets/chezmoi.io && ${SETENV} ${MAKE_ENV} mkdocs build)
post-extract:
@${MKDIR} ${WRKSRC}/vendor/github.com/chris-ramon
diff --git a/sysutils/containerd/Makefile b/sysutils/containerd/Makefile
index 3b8efe4bf345..118a24bf76d4 100644
--- a/sysutils/containerd/Makefile
+++ b/sysutils/containerd/Makefile
@@ -9,10 +9,9 @@ COMMENT= Open and reliable container runtime
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= bash:shells/bash \
- go:lang/go
+BUILD_DEPENDS= bash:shells/bash
-USES= cpe gmake
+USES= cpe gmake go:modules,no_targets
USE_GITHUB= yes
GH_SUBDIR= src/github.com/containerd/containerd
diff --git a/sysutils/datadog-agent/Makefile b/sysutils/datadog-agent/Makefile
index c020d3595414..56c32fb5cb93 100644
--- a/sysutils/datadog-agent/Makefile
+++ b/sysutils/datadog-agent/Makefile
@@ -359,20 +359,20 @@ pre-build:
${MAKE_CMD} -C .)
# Generate go source from templates
- ${SETENV} ${GO_ENV} GOCACHE=${TMPDIR} GO111MODULE=off GOFLAGS="-mod=vendor" ${GO_CMD} generate ${WRKSRC}/pkg/status/render.go
- ${SETENV} ${GO_ENV} GOCACHE=${TMPDIR} GO111MODULE=off GOFLAGS="-mod=vendor" ${GO_CMD} generate ${WRKSRC}/cmd/agent/gui/gui.go
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOCACHE=${TMPDIR} GO111MODULE=off GOFLAGS="-mod=vendor" ${GO_CMD} generate ${WRKSRC}/pkg/status/render.go
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOCACHE=${TMPDIR} GO111MODULE=off GOFLAGS="-mod=vendor" ${GO_CMD} generate ${WRKSRC}/cmd/agent/gui/gui.go
post-build:
# Generate config files
- ${SETENV} ${GO_ENV} GOCACHE=${TMPDIR} ${GO_CMD} run ${WRKSRC}/pkg/config/render_config.go agent-py3 \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOCACHE=${TMPDIR} ${GO_CMD} run ${WRKSRC}/pkg/config/render_config.go agent-py3 \
${WRKSRC}/pkg/config/config_template.yaml \
${WRKSRC}/cmd/agent/dist/datadog.yaml
- ${SETENV} ${GO_ENV} GOCACHE=${TMPDIR} ${GO_CMD} run ${WRKSRC}/pkg/config/render_config.go system-probe \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOCACHE=${TMPDIR} ${GO_CMD} run ${WRKSRC}/pkg/config/render_config.go system-probe \
${WRKSRC}/pkg/config/config_template.yaml \
${WRKSRC}/cmd/agent/dist/system-probe.yaml
- ${SETENV} ${GO_ENV} GOCACHE=${TMPDIR} ${GO_CMD} run ${WRKSRC}/pkg/config/render_config.go dogstatsd \
+ ${SETENV} ${MAKE_ENV} ${GO_ENV} GOCACHE=${TMPDIR} ${GO_CMD} run ${WRKSRC}/pkg/config/render_config.go dogstatsd \
${WRKSRC}/pkg/config/config_template.yaml \
${WRKSRC}/cmd/agent/dist/dogstatsd.yaml
diff --git a/sysutils/ipfs-go/Makefile b/sysutils/ipfs-go/Makefile
index 6d5b4af462cf..eca70b4028f2 100644
--- a/sysutils/ipfs-go/Makefile
+++ b/sysutils/ipfs-go/Makefile
@@ -15,12 +15,11 @@ LICENSE_COMB= dual
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE-APACHE
-USES= cpe go:modules
+USES= cpe go:1.17,modules
CPE_VENDOR= protocol
GO_TARGET= ./cmd/ipfs:ipfs-go
-GO_PORT= lang/go117 # quic-go does not build on Go 1.18 yet
NO_WRKSUBDIR= yes
diff --git a/sysutils/ipget/Makefile b/sysutils/ipget/Makefile
index d1c9b40e846f..df9feb68ada2 100644
--- a/sysutils/ipget/Makefile
+++ b/sysutils/ipget/Makefile
@@ -10,7 +10,7 @@ COMMENT= Retrieve files over IPFS and save them locally
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go:modules
+USES= go:1.17,modules
USE_GITHUB= yes
GH_ACCOUNT= ipfs
diff --git a/sysutils/minikube/Makefile b/sysutils/minikube/Makefile
index aabaf4516f61..0a6ff706bff2 100644
--- a/sysutils/minikube/Makefile
+++ b/sysutils/minikube/Makefile
@@ -243,6 +243,6 @@ pre-build:
-o pkg/minikube/assets/assets.go -pkg assets deploy/addons/... && \
${LOCALBASE}/bin/go-bindata -nomemcopy \
-o pkg/minikube/translate/translations.go -pkg translate translations/... && \
- ${LOCALBASE}/bin/gofmt -s -w pkg/minikube/translate/translations.go
+ ${LOCALBASE}/bin/gofmt${GO_SUFFIX} -s -w pkg/minikube/translate/translations.go
.include <bsd.port.mk>
diff --git a/www/adguardhome/Makefile b/www/adguardhome/Makefile
index 5f1cee823f3c..880667cbb59d 100644
--- a/www/adguardhome/Makefile
+++ b/www/adguardhome/Makefile
@@ -10,10 +10,9 @@ COMMENT= Network-wide ads & trackers blocking DNS server
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cpe go:modules
+USES= cpe go:1.17,modules
GO_MODULE= github.com/AdguardTeam/AdGuardHome
-GO_PORT= lang/go117 # quic-go does not build on Go 1.18 yet
# to rebuild the deps archives:
# 1. set DEV_UPDATE_MODE=yes